aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-16 20:57:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-16 20:57:22 +0000
commitdb37aa8f5fd8e66b0f453e9818af8f70f13bfabb (patch)
tree19b2f146b7a505b66e757479cd911244edf5b6f6 /games
parent64be9ce342d3f7d168a245ae4ff202411d5f2878 (diff)
downloadports-db37aa8f5fd8e66b0f453e9818af8f70f13bfabb.tar.gz
ports-db37aa8f5fd8e66b0f453e9818af8f70f13bfabb.zip
games/dxx-rebirth: update to 20190530, remove unnecessary patches
Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D20661
Notes
Notes: svn path=/head/; revision=504375
Diffstat (limited to 'games')
-rw-r--r--games/dxx-rebirth/Makefile4
-rw-r--r--games/dxx-rebirth/distinfo6
-rw-r--r--games/dxx-rebirth/files/patch-SConstruct20
-rw-r--r--games/dxx-rebirth/files/patch-similar_main_digiobj.cpp11
-rw-r--r--games/dxx-rebirth/files/patch-similar_main_object.cpp20
5 files changed, 5 insertions, 56 deletions
diff --git a/games/dxx-rebirth/Makefile b/games/dxx-rebirth/Makefile
index e755babba479..f35d22cf54db 100644
--- a/games/dxx-rebirth/Makefile
+++ b/games/dxx-rebirth/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= dxx-rebirth
-PORTVERSION= 20190523
+PORTVERSION= 20190530
DISTVERSIONSUFFIX= -src
CATEGORIES= games
-MASTER_SITES= https://www.dxx-rebirth.com/download/dxx/weekly/
+MASTER_SITES= https://www.dxx-rebirth.com/download/dxx/rebirth/
DISTNAME= ${PORTNAME}_${PORTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= pkubaj@FreeBSD.org
diff --git a/games/dxx-rebirth/distinfo b/games/dxx-rebirth/distinfo
index 3f37761e1799..75da4bb5586c 100644
--- a/games/dxx-rebirth/distinfo
+++ b/games/dxx-rebirth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558946168
-SHA256 (dxx-rebirth_20190523-src.tar.xz) = a12c2defd587029b951d75a2b2e47e01d9ae7214aeac185b99cd413c970583e6
-SIZE (dxx-rebirth_20190523-src.tar.xz) = 1317288
+TIMESTAMP = 1560718581
+SHA256 (dxx-rebirth_20190530-src.tar.xz) = c7dcf8121a37fb1db6265f0cda110b22b6ea8828bb5fa74ac8daa26e5c21c415
+SIZE (dxx-rebirth_20190530-src.tar.xz) = 1319372
diff --git a/games/dxx-rebirth/files/patch-SConstruct b/games/dxx-rebirth/files/patch-SConstruct
deleted file mode 100644
index 03bc9194efa7..000000000000
--- a/games/dxx-rebirth/files/patch-SConstruct
+++ /dev/null
@@ -1,20 +0,0 @@
---- SConstruct.orig 2019-05-23 09:33:10 UTC
-+++ SConstruct
-@@ -3560,6 +3560,8 @@ class DXXCommon(LazyObjectConstructor):
- sys_platform = 'linux'
- elif sys_platform.startswith('openbsd'):
- sys_platform = 'openbsd'
-+ elif sys_platform.startswith('freebsd'):
-+ sys_platform = 'freebsd'
- return (
- {
- 'variable': EnumVariable,
-@@ -3589,7 +3591,7 @@ class DXXCommon(LazyObjectConstructor):
- 'cross-compile to specified platform',
- {
- 'map': {'msys':'win32'},
-- 'allowed_values' : ('darwin', 'linux', 'openbsd', 'win32'),
-+ 'allowed_values' : ('darwin', 'linux', 'openbsd', 'win32', 'freebsd'),
- }
- ),
- ('raspberrypi', None, 'build for Raspberry Pi (automatically selects opengles)', {'ignorecase': 2, 'map': {'1':'yes', 'true':'yes', '0':'no', 'false':'no'}, 'allowed_values': ('yes', 'no', 'mesa')}),
diff --git a/games/dxx-rebirth/files/patch-similar_main_digiobj.cpp b/games/dxx-rebirth/files/patch-similar_main_digiobj.cpp
deleted file mode 100644
index 3c9cd8044ff4..000000000000
--- a/games/dxx-rebirth/files/patch-similar_main_digiobj.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- similar/main/digiobj.cpp.orig 2019-05-27 11:05:14 UTC
-+++ similar/main/digiobj.cpp
-@@ -578,7 +578,7 @@ void digi_sync_sounds()
- &s.volume, &s.pan, s.max_distance );
-
- } else if ( s.flags & SOF_LINK_TO_OBJ ) {
-- const auto objp = [&vcobjptr, &s]{
-+ const auto objp = [&s]{
- if (Newdemo_state != ND_STATE_PLAYBACK)
- return vcobjptr(s.link_type.obj.objnum);
- auto objnum = newdemo_find_object(s.link_type.obj.objsignature);
diff --git a/games/dxx-rebirth/files/patch-similar_main_object.cpp b/games/dxx-rebirth/files/patch-similar_main_object.cpp
deleted file mode 100644
index 0ea68c4f50f5..000000000000
--- a/games/dxx-rebirth/files/patch-similar_main_object.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- similar/main/object.cpp.orig 2019-05-27 09:10:54 UTC
-+++ similar/main/object.cpp
-@@ -1057,7 +1057,7 @@ static void free_object_slots(uint_fast32_t num_used)
-
- // Capture before num_to_free modified
- const auto &&r = partial_const_range(obj_list, num_to_free);
-- auto l = [&vmobjptr, &r, &num_to_free](bool (*predicate)(const vcobjptr_t)) -> bool {
-+ auto l = [&r, &num_to_free](bool (*predicate)(const vcobjptr_t)) -> bool {
- range_for (const auto i, r)
- {
- const auto &&o = vmobjptr(i);
-@@ -1508,7 +1508,7 @@ static void start_player_death_sequence(object &player
- auto &proximity = player_info.hoard.orbs;
- if (proximity < player_info.max_hoard_orbs)
- {
-- const auto is_bad_kill = [&vmobjptr]{
-+ const auto is_bad_kill = []{
- auto &lplr = get_local_player();
- auto &lplrobj = get_local_plrobj();
- const auto killer_objnum = lplrobj.ctype.player_info.killer_objnum;