aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-19 08:13:51 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-19 08:13:51 +0000
commitdb6cce6f3bc09c625d37c175253c065adcac4a97 (patch)
treee2f8926afd3e01d02c97447b8fcfaa9138b9e677 /games
parent8351a03fe1dacd608bdade32455aeee377cdcf3c (diff)
downloadports-db6cce6f3bc09c625d37c175253c065adcac4a97.tar.gz
ports-db6cce6f3bc09c625d37c175253c065adcac4a97.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/gtkpool/Makefile9
-rw-r--r--games/gtkpool/files/patch-gtkpool_application.cpp19
2 files changed, 20 insertions, 8 deletions
diff --git a/games/gtkpool/Makefile b/games/gtkpool/Makefile
index 9232c2f0562f..0464eef75eff 100644
--- a/games/gtkpool/Makefile
+++ b/games/gtkpool/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkpool
PORTVERSION= 0.5.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= ftp://ftp.seul.org/pub/gtkpool/ \
http://www.sourcefiles.org/Games/Sports/Pool/
@@ -11,11 +11,14 @@ MASTER_SITES= ftp://ftp.seul.org/pub/gtkpool/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= 2D pool game using the GTK+ toolkit
-USES= autoreconf gmake perl5 pkgconfig
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf compiler:c++11-lang gmake perl5 pkgconfig
+USE_CXXSTD= c++11
USE_GNOME= gtk20
USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GCC= any
PLIST_FILES= bin/gtkpool \
share/icons/gtkpool.png
diff --git a/games/gtkpool/files/patch-gtkpool_application.cpp b/games/gtkpool/files/patch-gtkpool_application.cpp
index fcd47e77c32c..21658fc9e78a 100644
--- a/games/gtkpool/files/patch-gtkpool_application.cpp
+++ b/games/gtkpool/files/patch-gtkpool_application.cpp
@@ -1,6 +1,6 @@
---- gtkpool/application.cpp.orig 2002-08-06 13:02:45.000000000 +0900
-+++ gtkpool/application.cpp 2011-08-19 04:36:56.000000000 +0900
-@@ -67,11 +67,11 @@
+--- gtkpool/application.cpp.orig 2002-08-06 04:02:45 UTC
++++ gtkpool/application.cpp
+@@ -67,11 +67,11 @@ Application::Application(){
message_colours[14] = new GdkColor;
buf_pixmap = NULL;
@@ -17,7 +17,16 @@
running = true; placing_cue = false;
sunk_tf = collide_tf = bounce_tf = false;
connected = false;
-@@ -530,7 +530,7 @@
+@@ -234,7 +234,7 @@ reiterated until there are no more collisions left in
+ }
+
+ update_rack();
+- balls.erase(std::vector<Ball>::iterator(bnc)); // get rid of it
++ balls.erase(std::remove_if(balls.begin(), balls.end(), [bnc](Ball const &b) { return &b == bnc; }), balls.end()); // get rid of it
+ sunk_tf = true;
+ }
+ else // otherwise bounce it off the bumper
+@@ -530,7 +530,7 @@ void Application::mouse_down (double x, double y) {
bb = find_if(balls.begin(), balls.end(), pointer_selects( x, y, hit_moving));
if(bb != balls.end())
{
@@ -26,7 +35,7 @@
// FIXME: horrible, non-portable, converting a vector iterator
// to a pointer using g++ 3.0 private interface :-(
// -- Philip Martin <philip_martin@ntlworld.com>
-@@ -815,12 +815,18 @@
+@@ -815,12 +815,18 @@ void Application::init_sound()
load_sounds();
}