aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
commite99ceadaf6c77b80c19e16d91306e944305b1c88 (patch)
treee8a8f4dac51e148717ae07e2de0c635ec5d58833 /games
parent3a5afbdcc87c8da2cc12bd67ec501257e48bc034 (diff)
downloadports-e99ceadaf6c77b80c19e16d91306e944305b1c88.tar.gz
ports-e99ceadaf6c77b80c19e16d91306e944305b1c88.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/bomberinstinct/Makefile3
-rw-r--r--games/egoboo/Makefile2
-rw-r--r--games/gnocatan/Makefile2
-rw-r--r--games/gnomechess/Makefile2
-rw-r--r--games/hlserver-cs/Makefile2
-rw-r--r--games/lbreakout/Makefile4
-rw-r--r--games/moonlander/Makefile3
-rw-r--r--games/nil/Makefile6
-rw-r--r--games/pioneers/Makefile2
-rw-r--r--games/ptkei/Makefile6
-rw-r--r--games/q3server-ra3/Makefile2
-rw-r--r--games/quake3-ra3/Makefile2
-rw-r--r--games/rtcw/Makefile2
-rw-r--r--games/teg/Makefile4
-rw-r--r--games/toppler/Makefile4
-rw-r--r--games/utserver-to/Makefile4
-rw-r--r--games/utserver/Makefile2
-rw-r--r--games/xbomber/Makefile6
18 files changed, 31 insertions, 27 deletions
diff --git a/games/bomberinstinct/Makefile b/games/bomberinstinct/Makefile
index b522f6a6a524..115a4de9c42b 100644
--- a/games/bomberinstinct/Makefile
+++ b/games/bomberinstinct/Makefile
@@ -28,6 +28,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
pre-patch:
- @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e 's|<SDL/|<|g'
+ @${FIND} ${WRKSRC} -name "*.[ch]" | \
+ ${XARGS} ${PERL} -pi -e 's|<SDL/|<|g'
.include <bsd.port.mk>
diff --git a/games/egoboo/Makefile b/games/egoboo/Makefile
index 37579ddbdd90..bb922f2dec4f 100644
--- a/games/egoboo/Makefile
+++ b/games/egoboo/Makefile
@@ -24,7 +24,7 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_REINPLACE= yes
pre-patch:
- @find ${WRKSRC}/.. -type d -name CVS | ${XARGS} ${RM} -rf
+ @${FIND} ${WRKSRC}/.. -type d -name CVS | ${XARGS} ${RM} -rf
post-patch:
@cd ${WRKSRC}/code && ${GMAKE} clean
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index cca243306bd5..d308de5b42eb 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/games/gnomechess/Makefile b/games/gnomechess/Makefile
index 16eff1bb1087..33666f63a8cb 100644
--- a/games/gnomechess/Makefile
+++ b/games/gnomechess/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/games/hlserver-cs/Makefile b/games/hlserver-cs/Makefile
index 3ae96a58702f..efed0fa778b3 100644
--- a/games/hlserver-cs/Makefile
+++ b/games/hlserver-cs/Makefile
@@ -54,7 +54,7 @@ post-extract: slaveport-post-extract
pre-patch:
# remove trailing ^M
- @find -E ${WRKSRC} -type f \
+ @${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index e5c0d17e698d..6b6f59af2cf3 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -25,8 +25,8 @@ CONFIGURE_ENV= LIBS="-lcompat" \
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
- xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+ @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
+ ${XARGS} ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
pre-install:
${MKDIR} /var/games/${PORTNAME}
diff --git a/games/moonlander/Makefile b/games/moonlander/Makefile
index d6510a80208e..94900b073d82 100644
--- a/games/moonlander/Makefile
+++ b/games/moonlander/Makefile
@@ -43,6 +43,7 @@ do-install:
.endfor
post-install:
- @find ${PREFIX}/share/moonlander -type f -print0 |xargs -0 ${CHMOD} 444
+ @${FIND} ${PREFIX}/share/moonlander -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 444
.include <bsd.port.mk>
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 80242f560720..c6cfde611ee8 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -32,9 +32,9 @@ BROKEN= "Does not compile (bad C++ code)"
.endif
pre-patch:
- @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
- xargs ${PERL} -pi -e 's|"SDL/|"|g ; s|<SDL/|<|g'
- @find ${WRKSRC}/.. -type d -name CVS | xargs ${RM} -rf
+ @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
+ ${XARGS} ${PERL} -pi -e 's|"SDL/|"|g ; s|<SDL/|<|g'
+ @${FIND} ${WRKSRC}/.. -type d -name CVS | ${XARGS} ${RM} -rf
post-configure:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/nil/configuration.cpp
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index cca243306bd5..d308de5b42eb 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index 363d19e33a9b..c49b631adc45 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -19,9 +19,9 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinte
USE_PYTHON= yes
do-build:
- @find ${WRKSRC} -name "*.pyc" | xargs ${RM}
- @find ${WRKSRC} \( -type f -or -type l \) | xargs ${CHMOD} 644
- @find ${WRKSRC} -type d | xargs ${CHMOD} 755
+ @${FIND} ${WRKSRC} -name "*.pyc" | ${XARGS} ${RM}
+ @${FIND} ${WRKSRC} \( -type f -or -type l \) | ${XARGS} ${CHMOD} 644
+ @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC} 2>/dev/null
do-install:
diff --git a/games/q3server-ra3/Makefile b/games/q3server-ra3/Makefile
index d62d1ded0e2c..aa2b86884a56 100644
--- a/games/q3server-ra3/Makefile
+++ b/games/q3server-ra3/Makefile
@@ -61,7 +61,7 @@ post-extract:
pre-patch:
# remove trailing ^M
- @find -E ${WRKSRC} -type f \
+ @${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
diff --git a/games/quake3-ra3/Makefile b/games/quake3-ra3/Makefile
index d62d1ded0e2c..aa2b86884a56 100644
--- a/games/quake3-ra3/Makefile
+++ b/games/quake3-ra3/Makefile
@@ -61,7 +61,7 @@ post-extract:
pre-patch:
# remove trailing ^M
- @find -E ${WRKSRC} -type f \
+ @${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
diff --git a/games/rtcw/Makefile b/games/rtcw/Makefile
index 42a6ad2d0b09..bc414987c7e9 100644
--- a/games/rtcw/Makefile
+++ b/games/rtcw/Makefile
@@ -32,7 +32,7 @@ do-extract:
pre-patch:
# remove trailing ^M
- @find -E ${WRKSRC} -type f \
+ @${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
diff --git a/games/teg/Makefile b/games/teg/Makefile
index 176afabddd37..aa3e76b35db7 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
post-patch:
- @find ${WRKSRC} -name "*.[ch]" -type f | xargs ${REINPLACE_CMD} -e \
- 's|LIST_NEXT|TEG_LIST_NEXT|g'
+ @${FIND} ${WRKSRC} -name "*.[ch]" -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|LIST_NEXT|TEG_LIST_NEXT|g'
.include <bsd.port.mk>
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index b47aadaed902..96a1df74fdac 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -27,8 +27,8 @@ MAN6= toppler.6
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cc" \) | \
- xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+ @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cc" \) | \
+ ${XARGS} ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
post-install:
@cd ${WRKSRC} && ${MAKE} global_highscore
diff --git a/games/utserver-to/Makefile b/games/utserver-to/Makefile
index 04a5fceb6efc..c4ea2e4ac12b 100644
--- a/games/utserver-to/Makefile
+++ b/games/utserver-to/Makefile
@@ -66,12 +66,12 @@ post-extract:
pre-patch:
# remove trailing ^M
- @find -E ${WRKDIR} -type f \
+ @${FIND} -E ${WRKDIR} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
.ifdef(EXTRA_CLEAN_FILES)
.for pattern in ${EXTRA_CLEAN_FILES}
- @find -E ${WRKDIR} -type f \
+ @${FIND} -E ${WRKDIR} -type f \
-iregex "${pattern}" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
.endfor
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index e96ce900fd77..efd86c886712 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -39,7 +39,7 @@ EXECUTABLES= ucc ucc-bin ngStatsUT ngStatsUT.exe ngWorldStats \
pre-patch:
# remove trailing ^M
- @find -E ${WRKSRC} -type f \
+ @${FIND} -E ${WRKSRC} -type f \
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm)" \
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
@${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
diff --git a/games/xbomber/Makefile b/games/xbomber/Makefile
index 8076ea8729ca..a288f2c2aed8 100644
--- a/games/xbomber/Makefile
+++ b/games/xbomber/Makefile
@@ -24,8 +24,10 @@ do-install:
@${MKDIR} ${PREFIX}/share/xbomber
${TAR} -C ${WRKSRC} -cf - bitmaps jungle levels pixmaps sounds | \
${TAR} -C ${PREFIX}/share/xbomber --unlink -xf -
- @find ${PREFIX}/share/xbomber | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- @find ${PREFIX}/share/xbomber -type f | xargs ${CHMOD} ${SHAREMODE}
+ @${FIND} ${PREFIX}/share/xbomber | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @${FIND} ${PREFIX}/share/xbomber -type f | \
+ ${XARGS} ${CHMOD} ${SHAREMODE}
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xbomber
.for file in README.txt LEVELS.txt SOUND.txt GRAPHICS.txt