aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 11:05:18 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 11:05:18 +0000
commit4f6bece5409e1880b9dbeb2409144e72eeb6b24c (patch)
tree05d026c8a6c3f0057668c40e99d9177fe3474640 /games
parent1ea6d09b08984c5bff9f0ad3f45b04acf0a54b1e (diff)
downloadports-4f6bece5409e1880b9dbeb2409144e72eeb6b24c.tar.gz
ports-4f6bece5409e1880b9dbeb2409144e72eeb6b24c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/warmux/Makefile5
-rw-r--r--games/warmux/files/patch-src_interface_weapon__menu.cpp15
2 files changed, 19 insertions, 1 deletions
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index 342677d0fb2f..e344396e43e5 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -19,10 +19,13 @@ LIB_DEPENDS= libxml++-2.6.so:textproc/libxml++26 \
GNU_CONFIGURE= yes
CONFIGURE_ENV= cxx_present=yes
-USES= dos2unix gmake pkgconfig tar:bzip2
+USES= compiler dos2unix gmake pkgconfig tar:bzip2
USE_SDL= sdl image mixer ttf gfx net
DOS2UNIX_GLOB= fixed_class.h
+# build ignores CXXFLAGS
+CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
+CFLAGS_clang= -Wno-c++11-narrowing
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:R}
OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
diff --git a/games/warmux/files/patch-src_interface_weapon__menu.cpp b/games/warmux/files/patch-src_interface_weapon__menu.cpp
new file mode 100644
index 000000000000..b8b44fd7bdbb
--- /dev/null
+++ b/games/warmux/files/patch-src_interface_weapon__menu.cpp
@@ -0,0 +1,15 @@
+interface/weapon_menu.cpp:394:12: error: cannot initialize return object of type 'Weapon *' with an rvalue of type 'bool'
+ return false;
+ ^~~~~
+
+--- src/interface/weapon_menu.cpp.orig 2018-07-30 10:50:34 UTC
++++ src/interface/weapon_menu.cpp
+@@ -391,7 +391,7 @@ void WeaponsMenu::Draw()
+ Weapon * WeaponsMenu::UpdateCurrentOverflyItem(const Polygon * poly)
+ {
+ if (!show)
+- return false;
++ return NULL;
+ const std::vector<PolygonItem *>& items = poly->GetItem();
+ WeaponMenuItem * tmp;
+ Interface::GetInstance()->SetCurrentOverflyWeapon(NULL);