aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-07 17:50:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-07 17:50:46 +0000
commit6b9f906236ef6af47a05e31e547d2c7491c949e2 (patch)
tree2f7e5d0f5dfac0cd96ac9037a89422abeb224128 /games
parentab4f36340778352494986bb31a47268f5ae60ce7 (diff)
downloadports-6b9f906236ef6af47a05e31e547d2c7491c949e2.tar.gz
ports-6b9f906236ef6af47a05e31e547d2c7491c949e2.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/eduke32/Makefile21
-rw-r--r--games/eduke32/distinfo9
-rw-r--r--games/eduke32/files/patch-build-src-mmulti_unstable.c14
-rw-r--r--games/eduke32/files/patch-source-jaudiolib-dsl.c10
4 files changed, 42 insertions, 12 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index 2f0e0607f15f..5301a514cd44 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -5,11 +5,13 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20080924
-PORTREVISION= 1
+PORTVERSION= 20090313
+DISTVERSION= 20090131
CATEGORIES= games
-MASTER_SITES= http://wiki.eduke32.com/stuff/source_code/
-DISTFILES= ${PORTNAME}_src_${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= http://dukeworld.duke4.net/eduke32/source_code/
+DISTFILES= ${PORTNAME}_src_${DISTVERSION}${EXTRACT_SUFX}
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}_src_${PORTVERSION}.diff
MAINTAINER= olivier@gid0.org
COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
@@ -19,11 +21,12 @@ USE_GMAKE= yes
USE_GL= gl
USE_GNOME= gtk20
USE_SDL= mixer sdl
-WRKSRC= ${WRKDIR}/${PORTNAME}_src_${PORTVERSION}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}_src_${DISTVERSION}
+PATCH_ARGS= -d ${PATCH_WRKSRC} --forward --quiet -E ${PATCH_STRIP} -l
-OPTIONS= MIDI "Enable MIDI support" On \
+OPTIONS= MIDI "Enable original MIDI music support" On \
TIMIDITYPLUS "Use Timidity++ instead of Timidity" Off \
- VORBIS "Enable Ogg Vorbis support" On
+ VORBIS "Enable Ogg Vorbis music files support" On
.include "${.CURDIR}/../duke3d-data/Makefile.include"
@@ -63,8 +66,8 @@ post-patch:
s|/usr/X11R6|${LOCALBASE}|; \
s|sdl-config|${SDL_CONFIG}|' \
${WRKSRC}/Makefile \
- ${WRKSRC}/../build/Makefile \
- ${WRKSRC}/../build/Makefile.shared
+ ${WRKSRC}/build/Makefile \
+ ${WRKSRC}/build/Makefile.shared
@${REINPLACE_CMD} -e 's|LINUX|BSD|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/games/eduke32|${DN3DDIR}|' \
${WRKSRC}/source/game.c ${WRKSRC}/source/astub.c
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index 82dd7afaa975..083979c3fb03 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,3 +1,6 @@
-MD5 (eduke32_src_20080924.zip) = 3bba448c5b8fb9d6e34e2000e2155eed
-SHA256 (eduke32_src_20080924.zip) = d9645cd3fdf8a4009253ee9524602678b339a9a631cb686a45d64ae417e75c32
-SIZE (eduke32_src_20080924.zip) = 1664585
+MD5 (eduke32_src_20090131.zip) = cf5eb51de024f28e8b24aae2702d459e
+SHA256 (eduke32_src_20090131.zip) = e6b8cc2c7e0c32a6aa5a64359be8b8c494dcae08dda87e1de718c030426ef74d
+SIZE (eduke32_src_20090131.zip) = 1694234
+MD5 (eduke32_src_20090313.diff) = fd9fa13146c9a31b2eb709aff93a4afa
+SHA256 (eduke32_src_20090313.diff) = de13b9600868b98195c18a138fe6dd27fd29f054035ec966d03d28a220b472be
+SIZE (eduke32_src_20090313.diff) = 113568
diff --git a/games/eduke32/files/patch-build-src-mmulti_unstable.c b/games/eduke32/files/patch-build-src-mmulti_unstable.c
new file mode 100644
index 000000000000..e73eb20ea6b7
--- /dev/null
+++ b/games/eduke32/files/patch-build-src-mmulti_unstable.c
@@ -0,0 +1,14 @@
+--- build/src/mmulti_unstable.c.orig 2009-02-02 23:21:58.000000000 +0100
++++ build/src/mmulti_unstable.c 2009-02-02 23:27:30.000000000 +0100
+@@ -971,7 +971,11 @@
+ {
+ /* !!! FIXME: Might be Linux (not Unix, not BSD, not WinSock) specific. */
+ int32_t flags = 1;
+- setsockopt(udpsocket, SOL_IP, IP_RECVERR, &flags, sizeof(flags));
++ int sol_ip;
++ struct protoent *pent;
++ pent = getprotobyname ("ip");
++ sol_ip = (pent != NULL) ? pent->p_proto : 0;
++ setsockopt(udpsocket, sol_ip, SO_ERROR, &flags, sizeof(flags));
+ }
+ #endif
diff --git a/games/eduke32/files/patch-source-jaudiolib-dsl.c b/games/eduke32/files/patch-source-jaudiolib-dsl.c
new file mode 100644
index 000000000000..e999c131f17c
--- /dev/null
+++ b/games/eduke32/files/patch-source-jaudiolib-dsl.c
@@ -0,0 +1,10 @@
+--- source/jaudiolib/dsl.c.orig 2009-02-02 23:13:40.000000000 +0100
++++ source/jaudiolib/dsl.c 2009-02-02 23:13:53.000000000 +0100
+@@ -22,6 +22,7 @@
+ */
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+
+ #include "dsl.h"
+ #include "compat.h"