aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 02:00:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 02:00:35 +0000
commit9390a0bd481c907f61fd02e8cf234224bb0feae9 (patch)
tree0d816d54a129d8402e99c017f962a2914ce1a3e3 /games
parentc84f8e8dd0c02a68d40bc680318c4bff5f78cec1 (diff)
downloadports-9390a0bd481c907f61fd02e8cf234224bb0feae9.tar.gz
ports-9390a0bd481c907f61fd02e8cf234224bb0feae9.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/eboard/Makefile11
-rw-r--r--games/eboard/files/patch-configure38
-rw-r--r--games/eboard/files/patch-network.h13
-rw-r--r--games/eboard/pkg-plist1
4 files changed, 45 insertions, 18 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index e4635d1c3af3..efb2578d1e72 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eboard
PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTREVISION= 2
EXTRAS= 1pl2 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -29,6 +29,13 @@ INSTALL_TARGET= install install-man
MAN1= eboard-config.1 eboard-addtheme.1
MAN6= eboard.6
+DESKTOP_ENTRIES="eboard" \
+ "Play chess" \
+ "eboard.xpm" \
+ "eboard" \
+ "Application;Game;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -e 's,g++,${CXX},' -e 's,-O6,${CXXFLAGS},' \
${WRKSRC}/configure
@@ -46,5 +53,7 @@ post-install:
@cd ${WRKDIR}/eboard-extras-${extra} && ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install
.endfor
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${PREFIX}/share/pixmaps/eboard.xpm
.include <bsd.port.mk>
diff --git a/games/eboard/files/patch-configure b/games/eboard/files/patch-configure
index 0ba8b9be0cfe..2e5a6ff57256 100644
--- a/games/eboard/files/patch-configure
+++ b/games/eboard/files/patch-configure
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- configure.orig Wed Nov 26 17:48:49 2003
-+++ configure Sun Dec 21 10:00:21 2003
+--- configure.orig Thu Nov 27 00:48:49 2003
++++ configure Tue Jan 24 01:33:19 2006
@@ -244,7 +244,7 @@
}
print TESTCC "$program";
@@ -11,3 +9,35 @@ $FreeBSD$
print ": no\n";
$y = header_def($x);
print CONFIGH "#undef $y\n";
+@@ -372,17 +372,9 @@
+ #optional headers
+ header_check("strings.h","sys/soundcard.h","sys/audioio.h");
+
+-$t1=macro_check("netinet/in.h","IPPROTO_TCP","HAVE_IPPROTO_TCP_ON_IN_H");
+-$t2=macro_check("netinet/in.h","TCP_NODELAY","HAVE_TCP_NODELAY_ON_IN_H");
+-$t3=macro_check("netinet/in.h","SOL_TCP","HAVE_SOL_TCP_ON_IN_H");
+-
+-$t4=macro_check("netinet/tcp.h","IPPROTO_TCP","HAVE_IPPROTO_TCP_ON_TCP_H");
+-$t5=macro_check("netinet/tcp.h","TCP_NODELAY","HAVE_TCP_NODELAY_ON_TCP_H");
+-$t6=macro_check("netinet/tcp.h","SOL_TCP","HAVE_SOL_TCP_ON_TCP_H");
+-
+ print " net options: ";
+
+-if ($t2 != 0) {
++if (0) {
+ cppdef("USE_SOCK_OPTS");
+ if ($t1!=0 && $t3!=0) {
+ cppundef("NEED_TCP_H");
+@@ -396,10 +388,10 @@
+ print "netinet/tcp.h not required, SOL_TCP present.\n";
+ }
+ } else {
+- if ($t5 != 0 && ($t1!=0 || $t4!=0) && ($t3!=0 || $t6!=0) ) {
++ if (1) {
+ cppdef("NEED_TCP_H");
+ cppdef("USE_SOCK_OPTS");
+- if ($t1!=0 || $t4!=0) {
++ if (1) {
+ cppdef("USE_IPPROTO_TCP");
+ print "netinet/tcp.h required, IPPROTO_TCP present.\n";
+ } else {
diff --git a/games/eboard/files/patch-network.h b/games/eboard/files/patch-network.h
deleted file mode 100644
index 344ff10cf39f..000000000000
--- a/games/eboard/files/patch-network.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- network.h.orig Sat Jul 6 17:05:11 2002
-+++ network.h Wed Aug 14 00:56:14 2002
-@@ -47,6 +47,10 @@
- #include "stl.h"
- #include "eboard.h"
-
-+#ifndef SOL_TCP
-+#define SOL_TCP IPPROTO_TCP
-+#endif
-+
- class PidIssuer {
- public:
- virtual void farewellPid(int dpid)=0;
diff --git a/games/eboard/pkg-plist b/games/eboard/pkg-plist
index ca78101e8aa3..3047cb03d711 100644
--- a/games/eboard/pkg-plist
+++ b/games/eboard/pkg-plist
@@ -70,5 +70,6 @@ share/eboard/ghouls.png
share/eboard/plastic.png
share/eboard/themeconf.extras1
share/eboard/themeconf.extras2
+share/pixmaps/eboard.xpm
@dirrm share/eboard
%%PORTDOCS%%@dirrm %%DOCSDIR%%