aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-12-19 15:17:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-12-19 15:17:07 +0000
commitb22594f22e2bacb0aaf17d7e580bcf8a8d2c4886 (patch)
tree8ca999a316484c85e26019d67870cf627cffee7e /games
parent2004ea81d920f48086663533bbc5c974d2e14033 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/7kaa/Makefile4
-rw-r--r--games/eduke32/Makefile5
2 files changed, 7 insertions, 2 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index f1a8139f7bf8..64f7dd15b66a 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -16,6 +16,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libenet.so:net/enet \
libcurl.so:ftp/curl
+BROKEN_aarch64= fails to compile: OBULLET.cpp:41:9: constant expression evaluates to -1 which cannot be narrowed to type 'char'
+BROKEN_armv6= fails to compile: OBULLET.cpp:41:9: constant expression evaluates to -1 which cannot be narrowed to type 'char'
+BROKEN_armv7= fails to compile: OBULLET.cpp:41:9: constant expression evaluates to -1 which cannot be narrowed to type 'char'
+
USES= compiler:c++11-lib gmake localbase openal:al pkgconfig tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls # no translations ATM
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index cd7e59760df4..3cb5c2fb6fe1 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -28,6 +28,9 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libvpx.so:multimedia/libvpx \
libpng.so:graphics/png
+BROKEN_aarch64= fails to compile: polymost.cpp:2403:18: non-constant-expression cannot be narrowed from type 'long' to 'int32_t' (aka 'int') in initializer list
+BROKEN_sparc64= fails to compile
+
USES= gmake pkgconfig tar:xz
USE_GL= gl glu
USE_GNOME= gtk20
@@ -42,8 +45,6 @@ MAKE_ARGS= CC=${CC} CXX=${CXX}
PLIST_FILES= bin/eduke32 bin/mapster32
PORTEXAMPLES= *
-BROKEN_sparc64= does not compile on sparc64
-
OPTIONS_DEFINE= EXAMPLES GCC HRP OFFENSIVE SHAREWARE VOXEL
OPTIONS_DEFINE_i386= ASM
OPTIONS_DEFAULT_i386= ASM