aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-27 09:16:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-27 09:16:22 +0000
commitb9594659331b70b27540349d802f23a172b6cc10 (patch)
treea1d516f9769b84b5b94097090abec92b8ad3570d /games
parentc6efd5d16d9c67d3cb0d5418bf86ee7c73ba80f1 (diff)
downloadports-b9594659331b70b27540349d802f23a172b6cc10.tar.gz
ports-b9594659331b70b27540349d802f23a172b6cc10.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/dungeoncrawl/Makefile42
-rw-r--r--games/dungeoncrawl/files/patch-effects.cc10
-rw-r--r--games/dungeoncrawl/files/patch-it_use3.cc10
-rw-r--r--games/dungeoncrawl/files/patch-randart.cc10
-rw-r--r--games/dungeoncrawl/files/patch-tags.cc10
-rw-r--r--games/dungeoncrawl/pkg-descr12
6 files changed, 70 insertions, 24 deletions
diff --git a/games/dungeoncrawl/Makefile b/games/dungeoncrawl/Makefile
index a5360a967445..4c8853d9585c 100644
--- a/games/dungeoncrawl/Makefile
+++ b/games/dungeoncrawl/Makefile
@@ -4,38 +4,42 @@
PORTNAME= dungeoncrawl
PORTVERSION= 4.0.0.b26
CATEGORIES= games
-MASTER_SITES= ftp://ftp.dungeoncrawl.org/dev/4.0.x/src/
+MASTER_SITES= ftp://ftp.dungeoncrawl.org/dev/4.0.x/src/ \
+ http://www.sourcefiles.org/Games/Role_Play/
DISTNAME= dc${PORTVERSION:S/.//g}-src
EXTRACT_SUFX= .tbz2
MAINTAINER= ports@FreeBSD.org
-COMMENT= An old school roguelike game
+COMMENT= Old school roguelike game
+
+WRKSRC_SUBDIR= source
USE_BZIP2= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/source
-MAKEFILE= ${WRKSRC}/makefile.bsd
+USES= ncurses
+MAKEFILE= makefile.bsd
-PLIST_FILES= bin/dungeoncrawl
PORTDOCS= buglist.txt crawl.txt
-MAN6= dungeoncrawl.6
+PLIST_FILES= bin/dungeoncrawl man/man6/dungeoncrawl.6.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e "s|g++|${CXX}|; \
- s|/tmp/CRAWLTEST/testdev|${PREFIX}/bin|; \
- s|crawl|dungeoncrawl|; \
- s|CFLAGS =|CFLAGS=${CXXFLAGS} |;" \
- ${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ 's|^CXX =|CXX ?=| ; \
+ s|^CFLAGS =|CXXFLAGS +=| ; \
+ s|^LDFLAGS =|# &| ; \
+ s|^INSTALLDIR =|# &| ; \
+ s|^INCLUDES =|# &| ; \
+ s|$$(CFLAGS)|$$(CXXFLAGS)| ; \
+ s|$${CFLAGS}|$${CXXFLAGS}|' ${WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dungeoncrawl ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/crawl.6 ${PREFIX}/man/man6/dungeoncrawl.6
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} crawl \
+ ${STAGEDIR}${PREFIX}/bin/dungeoncrawl)
+ (cd ${WRKSRC}/../docs && ${INSTALL_MAN} crawl.6 \
+ ${STAGEDIR}${MANPREFIX}/man/man6/dungeoncrawl.6)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/docs/${doc} ${DOCSDIR}
+ (cd ${WRKSRC}/../docs && ${INSTALL_DATA} ${doc} \
+ ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/dungeoncrawl/files/patch-effects.cc b/games/dungeoncrawl/files/patch-effects.cc
new file mode 100644
index 000000000000..b138f3078357
--- /dev/null
+++ b/games/dungeoncrawl/files/patch-effects.cc
@@ -0,0 +1,10 @@
+--- effects.cc.orig
++++ effects.cc
+@@ -13,6 +13,7 @@
+
+ #include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include "externs.h"
+
diff --git a/games/dungeoncrawl/files/patch-it_use3.cc b/games/dungeoncrawl/files/patch-it_use3.cc
new file mode 100644
index 000000000000..e89b1a243f82
--- /dev/null
+++ b/games/dungeoncrawl/files/patch-it_use3.cc
@@ -0,0 +1,10 @@
+--- it_use3.cc.orig
++++ it_use3.cc
+@@ -15,6 +15,7 @@
+ #include "it_use3.h"
+
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "externs.h"
+
diff --git a/games/dungeoncrawl/files/patch-randart.cc b/games/dungeoncrawl/files/patch-randart.cc
new file mode 100644
index 000000000000..71955220e1fe
--- /dev/null
+++ b/games/dungeoncrawl/files/patch-randart.cc
@@ -0,0 +1,10 @@
+--- randart.cc.orig
++++ randart.cc
+@@ -17,6 +17,7 @@
+
+ #include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include "externs.h"
+ #include "itemname.h"
diff --git a/games/dungeoncrawl/files/patch-tags.cc b/games/dungeoncrawl/files/patch-tags.cc
new file mode 100644
index 000000000000..411d9ee4ca19
--- /dev/null
+++ b/games/dungeoncrawl/files/patch-tags.cc
@@ -0,0 +1,10 @@
+--- tags.cc.orig
++++ tags.cc
+@@ -54,6 +54,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h> // for memcpy
+
+ #ifdef LINUX
diff --git a/games/dungeoncrawl/pkg-descr b/games/dungeoncrawl/pkg-descr
index 3283ad3b27c3..a599139a7f53 100644
--- a/games/dungeoncrawl/pkg-descr
+++ b/games/dungeoncrawl/pkg-descr
@@ -1,8 +1,10 @@
-Linley's Dungeon Crawl is a free and portable roguelike molded in the tradition
-of the early greats of the genre: Rogue, Hack, and Moria.
+Linley's Dungeon Crawl is a free and portable roguelike molded in the
+tradition of the early greats of the genre: Rogue, Hack, and Moria.
+
The player guides a single character deep into a subterranean complex
-to retrieve the Orb of Zot, fending off many horrible and hideous creatures
-along the way. Once retrieved, the player must return both character and Orb
-safely to the surface world. Easier said than done, but fun all the same.
+to retrieve the Orb of Zot, fending off many horrible and hideous
+creatures along the way. Once retrieved, the player must return both
+character and Orb safely to the surface world. Easier said than done,
+but fun all the same.
WWW: http://www.dungeoncrawl.org/