aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-26 16:03:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-26 16:03:52 +0000
commitd421afbce3badd035e0c8877a11360a4063ec9c5 (patch)
tree9ce91b5049210b7e2e89ead8682bf27539ec23bb /games
parentdbbf12785c06bc38bcfa7150cd807ee0097687af (diff)
downloadports-d421afbce3badd035e0c8877a11360a4063ec9c5.tar.gz
ports-d421afbce3badd035e0c8877a11360a4063ec9c5.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/bsp/Makefile8
-rw-r--r--games/bsp/files/patch-endian.c11
-rw-r--r--games/bsp/pkg-plist4
3 files changed, 14 insertions, 9 deletions
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index 505000db656b..fc0b6f676726 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -17,12 +17,6 @@ COMMENT= Node builder for Doom
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s,-O2 -fomit-frame-pointer -ffast-math,${CFLAGS}," \
${WRKSRC}/configure
@@ -34,4 +28,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/bsp/files/patch-endian.c b/games/bsp/files/patch-endian.c
new file mode 100644
index 000000000000..1740538e20d9
--- /dev/null
+++ b/games/bsp/files/patch-endian.c
@@ -0,0 +1,11 @@
+--- endian.c Mon Jan 24 21:25:33 2005
++++ endian.c Mon Jan 24 21:25:09 2005
+@@ -195,7 +195,7 @@
+ {
+ Verbose("Doing endianness correction... ");
+ ConvertVertex();
+- ConvertLineDef();
++ ConvertLinedef();
+ ConvertSidedef();
+ ConvertSector();
+ ConvertPseg();
diff --git a/games/bsp/pkg-plist b/games/bsp/pkg-plist
index ef955435f9ab..f80953b76e6a 100644
--- a/games/bsp/pkg-plist
+++ b/games/bsp/pkg-plist
@@ -1,3 +1,3 @@
bin/bsp
-%%PORTDOCS%%share/doc/bsp/README
-%%PORTDOCS%%@dirrm share/doc/bsp
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%