aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-09 07:44:41 +0000
commit06f79b66f2eb028c4ab81977dcb1e010ef9cf946 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /games
parent5c3f57fd49a53ee36e7a7bc6263e4dd1fd331c27 (diff)
downloadports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.tar.gz
ports-06f79b66f2eb028c4ab81977dcb1e010ef9cf946.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/fortunate/Makefile8
-rw-r--r--games/gmastermind/Makefile6
-rw-r--r--games/gmines/Makefile6
-rw-r--r--games/gnustep-ladder/Makefile6
-rw-r--r--games/gnustep-sudoku/Makefile6
-rw-r--r--games/grubik/Makefile7
-rw-r--r--games/gshisen/Makefile6
-rw-r--r--games/jigsaw/Makefile6
-rw-r--r--games/lapispuzzle/Makefile6
-rw-r--r--games/nextgo/Makefile6
10 files changed, 20 insertions, 43 deletions
diff --git a/games/fortunate/Makefile b/games/fortunate/Makefile
index 9171fba4301c..15162ea800f8 100644
--- a/games/fortunate/Makefile
+++ b/games/fortunate/Makefile
@@ -9,11 +9,7 @@ MASTER_SITES= ${MASTER_SITE_GNUSTEP_CH}
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical front-end to the command-line BSD fortune
-BROKEN= No public distfiles
-
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
.include <bsd.port.mk>
diff --git a/games/gmastermind/Makefile b/games/gmastermind/Makefile
index eaa798de9055..d4e0a24e905c 100644
--- a/games/gmastermind/Makefile
+++ b/games/gmastermind/Makefile
@@ -13,10 +13,8 @@ COMMENT= Well-known mastermind game
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/GMastermind.app/GMastermind
diff --git a/games/gmines/Makefile b/games/gmines/Makefile
index 27b8e874219b..0b88d1cc5b96 100644
--- a/games/gmines/Makefile
+++ b/games/gmines/Makefile
@@ -12,10 +12,8 @@ COMMENT= Well-known minesweeper game for GNUstep
LICENSE= GPLv2 # or later
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/GMines.app/GMines
diff --git a/games/gnustep-ladder/Makefile b/games/gnustep-ladder/Makefile
index fdb7e8e7fb42..43ecaf1767be 100644
--- a/games/gnustep-ladder/Makefile
+++ b/games/gnustep-ladder/Makefile
@@ -17,10 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING.GPL
RUN_DEPENDS= gnugo:${PORTSDIR}/games/gnugo
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Ladder.app/Ladder
diff --git a/games/gnustep-sudoku/Makefile b/games/gnustep-sudoku/Makefile
index 7c1aca641a60..f52b0aa6b01b 100644
--- a/games/gnustep-sudoku/Makefile
+++ b/games/gnustep-sudoku/Makefile
@@ -13,10 +13,8 @@ COMMENT= Sudoku solver and generator
LICENSE= GPLv3 # or later
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Sudoku.app/Sudoku
diff --git a/games/grubik/Makefile b/games/grubik/Makefile
index f3b245104c4a..b2bdcecc0114 100644
--- a/games/grubik/Makefile
+++ b/games/grubik/Makefile
@@ -12,11 +12,8 @@ COMMENT= Virtual 3D Rubiks cube for GNUstep
LICENSE= GPLv2 # or later
-USES= tar:tgz tar:tgz
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= tar:tgz gnustep
+USE_GNUSTEP= back build
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index b4fdad509cf7..27323c612c12 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -13,10 +13,8 @@ COMMENT= Shisen-sho puzzle game for GNUstep
LICENSE= GPLv2 # or later
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
diff --git a/games/jigsaw/Makefile b/games/jigsaw/Makefile
index eeb7635465f1..9cff22112c0b 100644
--- a/games/jigsaw/Makefile
+++ b/games/jigsaw/Makefile
@@ -12,10 +12,8 @@ COMMENT= Simulates a jigsaw puzzle and illustrates the use of clipping paths
LICENSE= GPLv2 # or later
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Jigsaw.app/Jigsaw
diff --git a/games/lapispuzzle/Makefile b/games/lapispuzzle/Makefile
index a6d4223e0c33..9b038ba40f27 100644
--- a/games/lapispuzzle/Makefile
+++ b/games/lapispuzzle/Makefile
@@ -14,10 +14,8 @@ COMMENT= Tetris-like game for GNUstep
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/LapisPuzzle-${PORTVERSION}
diff --git a/games/nextgo/Makefile b/games/nextgo/Makefile
index df739b92b2ee..187a9cc0fd28 100644
--- a/games/nextgo/Makefile
+++ b/games/nextgo/Makefile
@@ -13,10 +13,8 @@ COMMENT= Classic Go game for OPENSTEP/GNUstep
LICENSE= GPLv1
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \