aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2010-08-08 13:34:11 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2010-08-08 13:34:11 +0000
commit130ba0dabf13b16b7c15f658a447d52ebe6f126b (patch)
tree4c3d5d224a24db448f72a30090b31c197c7f56da /games
parent6be20afddde62ef137929c6074b8e2f723626a47 (diff)
downloadports-130ba0dabf13b16b7c15f658a447d52ebe6f126b.tar.gz
ports-130ba0dabf13b16b7c15f658a447d52ebe6f126b.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/connect4/Makefile1
-rw-r--r--games/connect4/files/patch-aa6
2 files changed, 4 insertions, 3 deletions
diff --git a/games/connect4/Makefile b/games/connect4/Makefile
index fc1bf5d3bc7c..9fa373126d54 100644
--- a/games/connect4/Makefile
+++ b/games/connect4/Makefile
@@ -28,6 +28,7 @@ MAN6= connect4.6
SCOREFILE= /var/games/connect4.scores
PLIST_SUB= SCOREFILE=${SCOREFILE}
+MAKE_ENV= SCOREFILE=${SCOREFILE}
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/c4 \
diff --git a/games/connect4/files/patch-aa b/games/connect4/files/patch-aa
index ff7ae8dc93df..7ca8aa4133ab 100644
--- a/games/connect4/files/patch-aa
+++ b/games/connect4/files/patch-aa
@@ -1,10 +1,10 @@
---- Makefile.orig 2010-08-07 20:02:05.000000000 +0200
-+++ Makefile 2010-08-07 20:23:05.000000000 +0200
+--- Makefile.orig 2010-08-08 15:30:29.000000000 +0200
++++ Makefile 2010-08-08 15:30:54.000000000 +0200
@@ -1,10 +1,12 @@
# Makefile for c4
-CFLAGS = -g #-DSCOREFILE=\"/usr/games/lib/c4.scores\"
-+CFLAGS += -DSCOREFILE=\"/var/games/connect4.scores\"
++CFLAGS += -DSCOREFILE=\"${SCOREFILE}\"
CURSES = -lcurses -ltermcap
+all: c4