aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /games
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adonthell/Makefile4
-rw-r--r--games/adonthell/files/patch-src_SDL_ttf.c20
-rw-r--r--games/childsplay/Makefile3
-rw-r--r--games/childsplay_plugins/Makefile3
-rw-r--r--games/childsplay_plugins/files/patch-Makefile2
-rw-r--r--games/gnomesudoku/Makefile2
-rw-r--r--games/gnomesudoku/pkg-plist11
-rw-r--r--games/wesnoth-devel/Makefile6
-rw-r--r--games/wesnoth-devel/files/patch-src_sdl_ttf_SDL_ttf.c19
-rw-r--r--games/wesnoth-devel/pkg-plist6
-rw-r--r--games/wesnoth/Makefile6
-rw-r--r--games/wesnoth/files/patch-src_sdl_ttf_SDL_ttf.c19
-rw-r--r--games/wesnoth/pkg-plist6
-rw-r--r--games/xfce4-toys/Makefile3
-rw-r--r--games/xfce4-toys/pkg-plist36
-rw-r--r--games/xteddy/Makefile9
16 files changed, 122 insertions, 33 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 054895e6907e..81a587dc9afa 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -3,11 +3,11 @@
# Whom: Miguel Mendez <flynn@energyhq.es.eu.org>
#
# $FreeBSD$
-#
+# $MCom: ports/games/adonthell/Makefile,v 1.1 2006/10/04 20:13:33 ahze Exp $
PORTNAME= adonthell
PORTVERSION= 0.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/adonthell/files/patch-src_SDL_ttf.c b/games/adonthell/files/patch-src_SDL_ttf.c
new file mode 100644
index 000000000000..0999b7f20ed3
--- /dev/null
+++ b/games/adonthell/files/patch-src_SDL_ttf.c
@@ -0,0 +1,20 @@
+--- src/SDL_ttf.c.orig Wed Oct 4 16:00:53 2006
++++ src/SDL_ttf.c Wed Oct 4 16:12:38 2006
+@@ -43,7 +43,7 @@
+ #include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+ #include FT_TRUETYPE_IDS_H
+-#include FT_INTERNAL_OBJECTS_H
++/* #include FT_INTERNAL_OBJECTS_H */
+
+ #include "SDL.h"
+ #include "SDL_endian.h"
+@@ -270,7 +270,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/games/childsplay/Makefile b/games/childsplay/Makefile
index 8eff4dd88390..9bc8aea67820 100644
--- a/games/childsplay/Makefile
+++ b/games/childsplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= childsplay
PORTVERSION= 0.80.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= childsplay
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/pygame/pygame.h:${PORTSDIR}/
LIB_DEPENDS= assetml.0:${PORTSDIR}/devel/libassetml
USE_PYTHON= yes
-USE_X_PREFIX= yes
NO_BUILD= yes
# avoid asking for translation to your local language on install
diff --git a/games/childsplay_plugins/Makefile b/games/childsplay_plugins/Makefile
index 8f237bd66822..2a43736deb4c 100644
--- a/games/childsplay_plugins/Makefile
+++ b/games/childsplay_plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= childsplay_plugins
PORTVERSION= 0.80.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= childsplay
@@ -20,7 +20,6 @@ BUILD_DEPENDS= childsplay:${PORTSDIR}/games/childsplay
RUN_DEPENDS= childsplay:${PORTSDIR}/games/childsplay
USE_PYTHON= yes
-USE_X_PREFIX= yes
post-patch:
@${REINPLACE_CMD} -e "s@PREFIX=/usr/local@PREFIX=${PREFIX}@g " ${WRKSRC}/install.sh
diff --git a/games/childsplay_plugins/files/patch-Makefile b/games/childsplay_plugins/files/patch-Makefile
index a15980f0207f..e02280ccbc25 100644
--- a/games/childsplay_plugins/files/patch-Makefile
+++ b/games/childsplay_plugins/files/patch-Makefile
@@ -2,7 +2,7 @@
+++ Makefile Sat May 7 23:04:02 2005
@@ -0,0 +1,9 @@
+PYTHON = /usr/bin/env python
-+CPDIR=${X11BASE}/childsplay
++CPDIR=${LOCALBASE}/childsplay
+
+all:
+ echo "Compiling modules to bytecode..."
diff --git a/games/gnomesudoku/Makefile b/games/gnomesudoku/Makefile
index d94710a0ebbe..b0c583aa2627 100644
--- a/games/gnomesudoku/Makefile
+++ b/games/gnomesudoku/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomesudoku
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gnome-sudoku
diff --git a/games/gnomesudoku/pkg-plist b/games/gnomesudoku/pkg-plist
index c3415e3cf0e8..64fafebcd0ba 100644
--- a/games/gnomesudoku/pkg-plist
+++ b/games/gnomesudoku/pkg-plist
@@ -90,10 +90,17 @@ share/locale/sv/LC_MESSAGES/gnome-sudoku.mo
share/locale/tr/LC_MESSAGES/gnome-sudoku.mo
share/locale/uk/LC_MESSAGES/gnome-sudoku.mo
share/pixmaps/sudoku.png
+@dirrmtry share/pixmaps
@dirrm share/gnome-sudoku
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
@dirrm %%PYTHON_SITELIBDIR%%/gnome_sudoku/gtk_goodies
@dirrm %%PYTHON_SITELIBDIR%%/gnome_sudoku
@dirrmtry %%PYTHON_SITELIBDIR%%
@dirrmtry %%PYTHON_LIBDIR%%
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index b31e3523d092..1483a9691371 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
@@ -110,8 +110,8 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/applications|g ; \
- s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
+ @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${LOCALBASE}/share/gnome/applications|g ; \
+ s|[$$][(]datadir[)]/icons|${LOCALBASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
.include <bsd.port.post.mk>
diff --git a/games/wesnoth-devel/files/patch-src_sdl_ttf_SDL_ttf.c b/games/wesnoth-devel/files/patch-src_sdl_ttf_SDL_ttf.c
new file mode 100644
index 000000000000..ee4f8be540e1
--- /dev/null
+++ b/games/wesnoth-devel/files/patch-src_sdl_ttf_SDL_ttf.c
@@ -0,0 +1,19 @@
+--- src/sdl_ttf/SDL_ttf.c.orig Wed Oct 4 16:45:59 2006
++++ src/sdl_ttf/SDL_ttf.c Wed Oct 4 16:46:32 2006
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -282,7 +281,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/games/wesnoth-devel/pkg-plist b/games/wesnoth-devel/pkg-plist
index 4028e099c5b7..b495531ad338 100644
--- a/games/wesnoth-devel/pkg-plist
+++ b/games/wesnoth-devel/pkg-plist
@@ -4015,18 +4015,18 @@ share/locale/tr/LC_MESSAGES/wesnoth.mo
@dirrm %%DATADIR%%/data/campaigns
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
-@dirrmtry share/locale/la/LC_MESSAGES
-@dirrmtry share/locale/la
@dirrmtry man/sv/man6
@dirrmtry man/sv
@dirrmtry man/hu/man6
@dirrmtry man/hu
@dirrmtry man/de/man6
@dirrmtry man/de
+%%GNOME:%%@cwd %%LOCALBASE%%
%%GNOME:%%share/gnome/applications/wesnoth.desktop
%%GNOME:%%share/gnome/pixmaps/wesnoth-icon.png
-
%%KDE:%%@cwd %%LOCALBASE%%
%%KDE:%%share/applnk/Games/TacticStrategy/wesnoth.desktop
%%KDE:%%share/icons/wesnoth-icon.png
%%SERVER:%%@unexec rmdir /var/run/wesnothd 2>/dev/null || echo "If you are permanently removing this port, you should do a 'rm -rf /var/run/wesnothd' to remove it." | fmt
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index b31e3523d092..1483a9691371 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
@@ -110,8 +110,8 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/applications|g ; \
- s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
+ @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${LOCALBASE}/share/gnome/applications|g ; \
+ s|[$$][(]datadir[)]/icons|${LOCALBASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
.include <bsd.port.post.mk>
diff --git a/games/wesnoth/files/patch-src_sdl_ttf_SDL_ttf.c b/games/wesnoth/files/patch-src_sdl_ttf_SDL_ttf.c
new file mode 100644
index 000000000000..ee4f8be540e1
--- /dev/null
+++ b/games/wesnoth/files/patch-src_sdl_ttf_SDL_ttf.c
@@ -0,0 +1,19 @@
+--- src/sdl_ttf/SDL_ttf.c.orig Wed Oct 4 16:45:59 2006
++++ src/sdl_ttf/SDL_ttf.c Wed Oct 4 16:46:32 2006
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -282,7 +281,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index 4028e099c5b7..b495531ad338 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -4015,18 +4015,18 @@ share/locale/tr/LC_MESSAGES/wesnoth.mo
@dirrm %%DATADIR%%/data/campaigns
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
-@dirrmtry share/locale/la/LC_MESSAGES
-@dirrmtry share/locale/la
@dirrmtry man/sv/man6
@dirrmtry man/sv
@dirrmtry man/hu/man6
@dirrmtry man/hu
@dirrmtry man/de/man6
@dirrmtry man/de
+%%GNOME:%%@cwd %%LOCALBASE%%
%%GNOME:%%share/gnome/applications/wesnoth.desktop
%%GNOME:%%share/gnome/pixmaps/wesnoth-icon.png
-
%%KDE:%%@cwd %%LOCALBASE%%
%%KDE:%%share/applnk/Games/TacticStrategy/wesnoth.desktop
%%KDE:%%share/icons/wesnoth-icon.png
%%SERVER:%%@unexec rmdir /var/run/wesnothd 2>/dev/null || echo "If you are permanently removing this port, you should do a 'rm -rf /var/run/wesnothd' to remove it." | fmt
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
diff --git a/games/xfce4-toys/Makefile b/games/xfce4-toys/Makefile
index 1b9f00976094..82c6e0758c79 100644
--- a/games/xfce4-toys/Makefile
+++ b/games/xfce4-toys/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-toys
PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games xfce
MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://www.ca-us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
@@ -26,7 +26,6 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GETTEXT= yes
USE_GNOME= gtk20
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/games/xfce4-toys/pkg-plist b/games/xfce4-toys/pkg-plist
index 34d11103a8cb..cf5e3fed9a4a 100644
--- a/games/xfce4-toys/pkg-plist
+++ b/games/xfce4-toys/pkg-plist
@@ -77,9 +77,37 @@ share/xfce4/tips/tips.dat
@dirrm share/xfce4/tips
@dirrmtry share/xfce4
@dirrmtry lib/xfce4/panel-plugins
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
@dirrmtry share/locale/nb_NO/LC_MESSAGES
@dirrmtry share/locale/nb_NO
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be
diff --git a/games/xteddy/Makefile b/games/xteddy/Makefile
index d68136c2bed6..f3e0903f0d43 100644
--- a/games/xteddy/Makefile
+++ b/games/xteddy/Makefile
@@ -3,11 +3,11 @@
# Whom: Eckart "Isegrim" Hofmann
#
# $FreeBSD$
-#
+# $MCom: ports/games/xteddy/Makefile,v 1.1 2006/10/04 13:16:56 ahze Exp $
PORTNAME= xteddy
PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://staffwww.itn.liu.se/~stegu/xteddy/
@@ -16,10 +16,9 @@ COMMENT= A cuddlesome teddy for the X desktop
NO_CDROM= Can only be distributed for free
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
- LDFLAGS="-L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
USE_GNOME= imlib
MAN6= xteddy.6