aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-26 13:21:14 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-26 13:21:14 +0000
commit4aea7eee782742aa548d44882789d20b3bfccc49 (patch)
tree71ffb3a3359e73ff5e01a605aea03dccf4cd8dc1 /games
parent01d8c0a33ff4bc8c07f5999d20b95afd0e808139 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/entombed/Makefile46
-rw-r--r--games/entombed/distinfo4
-rw-r--r--games/entombed/pkg-descr17
-rw-r--r--games/entombed/pkg-plist75
5 files changed, 143 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index f964ef701b93..e7aaa39a86c7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -226,6 +226,7 @@
SUBDIR += endgame-singularity-music
SUBDIR += enigma
SUBDIR += ensemblist
+ SUBDIR += entombed
SUBDIR += enygma
SUBDIR += epiar
SUBDIR += etracer
diff --git a/games/entombed/Makefile b/games/entombed/Makefile
new file mode 100644
index 000000000000..ff7c2bef9af9
--- /dev/null
+++ b/games/entombed/Makefile
@@ -0,0 +1,46 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= entombed
+PORTVERSION= 2007.07.04
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/entombed/ \
+ ftp://ftp.billsgames.com/unix/x/entombed/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= One- or two-player maze game based on the Entombed
+
+LICENSE= GPLv2
+
+USES= gmake
+USE_SDL= image mixer sdl
+
+PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+
+DESKTOP_ENTRIES="Entombed" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.for d in embedded images images_halfsize music sounds
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/entombed/distinfo b/games/entombed/distinfo
new file mode 100644
index 000000000000..2233fcb24955
--- /dev/null
+++ b/games/entombed/distinfo
@@ -0,0 +1,4 @@
+SHA256 (entombed-2007.07.04.tar.gz) = a0c392d86901fbc2e263b7a9531dc8a87634c0799f114e856150bf3e8b374ab1
+SIZE (entombed-2007.07.04.tar.gz) = 304328
+SHA256 (entombed.png) = 0783e9d7322b24584e93e60034ee7d40ccd5afe11429a39c31b2caa72747d48c
+SIZE (entombed.png) = 2937
diff --git a/games/entombed/pkg-descr b/games/entombed/pkg-descr
new file mode 100644
index 000000000000..1a61476bcde6
--- /dev/null
+++ b/games/entombed/pkg-descr
@@ -0,0 +1,17 @@
+Entombed! is a one- or two-player maze game based on the classic Atari 2600
+game "Entombed", 1982 U.S. Games.
+
+Wikipedia "Entombed (video game)"
+
+You and your team of archeologists have fallen into the
+"catacombs of the zombies". There's no time for research, though;
+the walls are closing in, and the zombies have sprung to life!
+
+Fortunately, you've discovered an ancient mystical potion which allows you to
+create and destroy walls. Bottles of this potion are strewn about the catacombs.
+Grab them, and you can break through walls when you get stuck,
+or create a wall behind you, if you're being chased.
+
+The longer you survive, the faster you have to move.
+
+WWW: http://www.newbreedsoftware.com/entombed/
diff --git a/games/entombed/pkg-plist b/games/entombed/pkg-plist
new file mode 100644
index 000000000000..5deb12ed8a6f
--- /dev/null
+++ b/games/entombed/pkg-plist
@@ -0,0 +1,75 @@
+bin/entombed
+%%DATADIR%%/embedded/images/title.bmp.bz2
+%%DATADIR%%/images/1.png
+%%DATADIR%%/images/2.png
+%%DATADIR%%/images/brick1.png
+%%DATADIR%%/images/brick2.png
+%%DATADIR%%/images/brick3.png
+%%DATADIR%%/images/brick4.png
+%%DATADIR%%/images/brick5.png
+%%DATADIR%%/images/credits1.png
+%%DATADIR%%/images/credits2.png
+%%DATADIR%%/images/credits3.png
+%%DATADIR%%/images/credits4.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/makebreak1.png
+%%DATADIR%%/images/makebreak2.png
+%%DATADIR%%/images/makebreak3.png
+%%DATADIR%%/images/makebreak4.png
+%%DATADIR%%/images/makebreak5.png
+%%DATADIR%%/images/man1.png
+%%DATADIR%%/images/man2.png
+%%DATADIR%%/images/numbers.png
+%%DATADIR%%/images/paused.png
+%%DATADIR%%/images/title.jpg
+%%DATADIR%%/images/woman1.png
+%%DATADIR%%/images/woman2.png
+%%DATADIR%%/images/zombie1.png
+%%DATADIR%%/images/zombie2.png
+%%DATADIR%%/images/zombie_mad1.png
+%%DATADIR%%/images/zombie_mad2.png
+%%DATADIR%%/images_halfsize/1.png
+%%DATADIR%%/images_halfsize/2.png
+%%DATADIR%%/images_halfsize/brick1.png
+%%DATADIR%%/images_halfsize/brick2.png
+%%DATADIR%%/images_halfsize/brick3.png
+%%DATADIR%%/images_halfsize/brick4.png
+%%DATADIR%%/images_halfsize/brick5.png
+%%DATADIR%%/images_halfsize/credits1.png
+%%DATADIR%%/images_halfsize/credits2.png
+%%DATADIR%%/images_halfsize/credits3.png
+%%DATADIR%%/images_halfsize/credits4.png
+%%DATADIR%%/images_halfsize/icon.png
+%%DATADIR%%/images_halfsize/makebreak1.png
+%%DATADIR%%/images_halfsize/makebreak2.png
+%%DATADIR%%/images_halfsize/makebreak3.png
+%%DATADIR%%/images_halfsize/makebreak4.png
+%%DATADIR%%/images_halfsize/makebreak5.png
+%%DATADIR%%/images_halfsize/man1.png
+%%DATADIR%%/images_halfsize/man2.png
+%%DATADIR%%/images_halfsize/numbers.png
+%%DATADIR%%/images_halfsize/paused.png
+%%DATADIR%%/images_halfsize/title.jpg
+%%DATADIR%%/images_halfsize/woman1.png
+%%DATADIR%%/images_halfsize/woman2.png
+%%DATADIR%%/images_halfsize/zombie1.png
+%%DATADIR%%/images_halfsize/zombie2.png
+%%DATADIR%%/images_halfsize/zombie_mad1.png
+%%DATADIR%%/images_halfsize/zombie_mad2.png
+%%DATADIR%%/music/AMAZE.S3M
+%%DATADIR%%/music/Suggestive_vibes_01.mod
+%%DATADIR%%/sounds/die.wav
+%%DATADIR%%/sounds/gameover.wav
+%%DATADIR%%/sounds/makebreak_get.wav
+%%DATADIR%%/sounds/makebreak_use.wav
+%%DATADIR%%/sounds/zombie_appear.wav
+%%DATADIR%%/sounds/zombie_eat.wav
+%%DATADIR%%/sounds/zombie_mad.wav
+share/pixmaps/entombed.png
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images_halfsize
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/embedded/images
+@dirrm %%DATADIR%%/embedded
+@dirrm %%DATADIR%%