aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-14 22:30:49 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-10-14 22:30:49 +0000
commit4eb5b88d9eb1a88094ac3ae85f20e29e7510e97b (patch)
tree07820ebb6104ca954e4d94f3a2fdb93d78912435 /games
parentb49d99567f90be4113da01b6a7ef65427d682653 (diff)
downloadports-4eb5b88d9eb1a88094ac3ae85f20e29e7510e97b.tar.gz
ports-4eb5b88d9eb1a88094ac3ae85f20e29e7510e97b.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/quake2forge/Makefile132
-rw-r--r--games/quake2forge/distinfo2
-rw-r--r--games/quake2forge/files/patch-Makefile.in11
-rw-r--r--games/quake2forge/files/patch-configure.in45
-rw-r--r--games/quake2forge/files/patch-src__files.c23
-rw-r--r--games/quake2forge/files/patch-src__gl_fxmesa.c11
-rw-r--r--games/quake2forge/files/patch-src__gl_glx.c11
-rw-r--r--games/quake2forge/files/patch-src__snd_ao.c10
-rw-r--r--games/quake2forge/pkg-descr8
-rw-r--r--games/quake2forge/pkg-message15
-rw-r--r--games/quake2forge/pkg-plist67
12 files changed, 0 insertions, 336 deletions
diff --git a/games/Makefile b/games/Makefile
index f0440619df3f..c4e17171a9b0 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -726,7 +726,6 @@
SUBDIR += quake2-source
SUBDIR += quake2-xatrix
SUBDIR += quake2-zaero
- SUBDIR += quake2forge
SUBDIR += quake2lnx
SUBDIR += quake2max
SUBDIR += quake3
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
deleted file mode 100644
index 5d0003109239..000000000000
--- a/games/quake2forge/Makefile
+++ /dev/null
@@ -1,132 +0,0 @@
-# New ports collection makefile for: quake2
-# Date created: 20.01.2003
-# Whom: Ulrich Spoerlein <q@uni.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= quake2forge
-PORTVERSION= 0.3
-PORTREVISION= 8
-CATEGORIES= games
-MASTER_SITES= https://www.spoerlein.net/pub/
-DISTNAME= quake2-${PORTVERSION}
-
-MAINTAINER= danfe@FreeBSD.org
-COMMENT= First Person Shooter with many addons available
-
-FORBIDDEN= Vulnerable since 2005-01-21, http://portaudit.freebsd.org/2c25e762-6bb9-11d9-93db-000a95bc6fae.html
-EXPIRATION_DATE= 2011-10-14
-
-USE_AUTOTOOLS= autoconf libtool
-USE_BZIP2= yes
-
-CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/${PORTNAME}/' \
- --disable-warn
-
-OPTIONS= AO "Build libao sound module" off \
- CTF "Build the CTF (Capture The Flag) modification" off \
- GAME "Build a main game .so file" off \
- GL "Build OpenGL renderer" on \
- SDL "Build SDL renderers" off \
- SVGA "Build SVGA renderer" off \
- X11 "Build X11 renderer" on
-
-LIBDIR= ${PREFIX}/lib/${PORTNAME}
-
-.include "${.CURDIR}/../quake2-data/Makefile.include"
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_GL) || defined(WITH_X11)
-USE_XORG= xxf86dga
-.endif
-
-.if defined(WITH_AO)
-LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
-CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
-PLIST_SUB+= AO=""
-.else
-CONFIGURE_ARGS+=--without-ao
-PLIST_SUB+= AO="@comment "
-.endif
-
-.if defined(WITH_CTF)
-PLIST_SUB+= CTF=""
-.else
-Q2F_BADMODS+= ctf
-PLIST_SUB+= CTF="@comment "
-.endif
-
-.if defined(WITH_GAME)
-PLIST_SUB+= GAME=""
-.else
-Q2F_BADMODS+= baseq2
-PLIST_SUB+= GAME="@comment "
-.endif
-
-.if defined(WITH_GL)
-USE_GL= yes
-CONFIGURE_ARGS+=--with-opengl=${LOCALBASE}
-PLIST_SUB+= GL=""
-.else
-CONFIGURE_ARGS+=--with-opengl=no
-PLIST_SUB+= GL="@comment "
-.endif
-
-.if defined(WITH_SDL)
-USE_SDL= yes
-CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
-PLIST_SUB+= SDL=""
-.else
-CONFIGURE_ARGS+=--disable-sdl --disable-sdltest
-PLIST_SUB+= SDL="@comment "
-.endif
-
-.if defined(WITH_GL) && defined(WITH_SDL)
-PLIST_SUB+= SDLGL=""
-.else
-PLIST_SUB+= SDLGL="@comment "
-.endif
-
-.if defined(WITH_SVGA)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-CONFIGURE_ARGS+=--with-svgalib=${LOCALBASE}
-PLIST_SUB+= SVGA=""
-.else
-CONFIGURE_ARGS+=--with-svgalib=no
-PLIST_SUB+= SVGA="@comment "
-.endif
-
-.if defined(WITH_X11)
-CONFIGURE_ARGS+=--with-x
-PLIST_SUB+= X11=""
-.else
-CONFIGURE_ARGS+=--without-x
-PLIST_SUB+= X11="@comment "
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} -e \
- 's|\($$(libdir)/\)@PACKAGE@|\1${PORTNAME}|'
- @${REINPLACE_CMD} -e 's|\($$libdir/\)$$PACKAGE|\1${PORTNAME}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}.in
-.for f in ${Q2F_BADMODS}
- @${REINPLACE_CMD} -i "" -e 's/${f}//' ${WRKSRC}/src/Makefile.in
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/README.* ${WRKSRC}/docs/*.txt ${DOCSDIR}
-.if defined(WITH_CTF)
- ${MKDIR} ${DOCSDIR}/ctf
-.for f in *.html *.gif *.jpg
- ${INSTALL_DATA} ${WRKSRC}/docs/ctf/${f} ${DOCSDIR}/ctf
-.endfor
-.endif
-.endif
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-
-.include <bsd.port.post.mk>
diff --git a/games/quake2forge/distinfo b/games/quake2forge/distinfo
deleted file mode 100644
index f0d0697bdf92..000000000000
--- a/games/quake2forge/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (quake2-0.3.tar.bz2) = 5a868970b16eb674fd019201700f0c3011a1a5479cf8fad2c297ded0c0c74f03
-SIZE (quake2-0.3.tar.bz2) = 1383644
diff --git a/games/quake2forge/files/patch-Makefile.in b/games/quake2forge/files/patch-Makefile.in
deleted file mode 100644
index 3ee9068f2ae8..000000000000
--- a/games/quake2forge/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Mar 16 07:38:08 2004
-+++ Makefile.in Wed Sep 28 17:52:34 2005
-@@ -243,7 +243,7 @@
- target_os = @target_os@
- target_vendor = @target_vendor@
- unamepath = @unamepath@
--SUBDIRS = src data docs
-+SUBDIRS = src docs
- EXTRA_DIST = quake2.dsp quake2.dsw quake2.mak \
- quake2.spec \
- HACKING NEWS THANKS TODO \
diff --git a/games/quake2forge/files/patch-configure.in b/games/quake2forge/files/patch-configure.in
deleted file mode 100644
index dda92f3412ef..000000000000
--- a/games/quake2forge/files/patch-configure.in
+++ /dev/null
@@ -1,45 +0,0 @@
---- configure.in.orig Tue Mar 16 07:07:38 2004
-+++ configure.in Wed Sep 28 20:52:44 2005
-@@ -109,6 +109,7 @@
- # test for the library first, for people who may have the libs
- # installed but no headers
- AC_CHECK_LIB(vga, vga_getmousetype,
-+ SVGALIB_LIBS="$SVGALIB_LIBS -lvga"
- HAVE_SVGALIB=maybe,
- HAVE_SVGALIB=no,
- [ $SVGALIB_LIBS ]
-@@ -125,7 +126,6 @@
- # if it's all there, define the relevant bits
- if test "x$HAVE_SVGALIB" = xyes ; then
- AC_DEFINE(HAVE_SVGALIB, 1, [Define this if you have SVGAlib])
-- SVGALIB_LIBS="-lvga"
- AC_SUBST(SVGALIB_CFLAGS)
- AC_SUBST(SVGALIB_LIBS)
- else
-@@ -221,7 +221,7 @@
- # --with-opengl was explicitly given, so look in that directory
- if test "x${ac_with_opengl}" != xauto ; then
- OPENGL_CFLAGS="$OPENGL_CFLAGS -I$withval/include"
-- OPENGL_LIBS="$OPENGL_CFLAGS -L$withval/lib"
-+ OPENGL_LIBS="$OPENGL_LIBS -L$withval/lib"
- fi
- # save and set CPPFLAGS for coming tests
- save_CPPFLAGS="$CPPFLAGS"
-@@ -263,7 +263,6 @@
-
- if test "x$HAVE_OPENGL" = xyes; then
- AC_DEFINE(HAVE_OPENGL, 1, [Define this if you have OpenGL])
-- OPENGL_LIBS="-lGL"
- AC_SUBST(OPENGL_CFLAGS)
- AC_SUBST(OPENGL_LIBS)
- else
-@@ -779,9 +778,6 @@
- src/ctf/Makefile
- src/xatrix/Makefile
- src/rogue/Makefile
-- data/Makefile
-- data/pixmaps/Makefile
-- data/baseq2/Makefile
- docs/Makefile
- docs/ctf/Makefile
- quake2.spec
diff --git a/games/quake2forge/files/patch-src__files.c b/games/quake2forge/files/patch-src__files.c
deleted file mode 100644
index 5370103a4c64..000000000000
--- a/games/quake2forge/files/patch-src__files.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/files.c.orig Sun Feb 23 09:12:37 2003
-+++ src/files.c Thu Jul 27 17:05:41 2006
-@@ -721,6 +721,8 @@
- Cvar_FullSet ("gamedir", dir, CVAR_SERVERINFO|CVAR_NOSET);
- if (fs_cddir->string[0])
- FS_AddGameDirectory (va("%s/%s", fs_cddir->string, dir) );
-+ FS_AddGameDirectory(PKGDATADIR"/"BASEDIRNAME);
-+ FS_AddGameDirectory(PKGLIBDIR"/"BASEDIRNAME);
- FS_AddGameDirectory (va("%s/%s", fs_basedir->string, dir) );
- FS_AddHomeAsGameDirectory (dir);
- }
-@@ -953,9 +955,9 @@
- //
- // add baseq2 to search path
- //
-- /*FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );*/
-- FS_AddGameDirectory(PKGLIBDIR"/"BASEDIRNAME);
- FS_AddGameDirectory(PKGDATADIR"/"BASEDIRNAME);
-+ FS_AddGameDirectory(PKGLIBDIR"/"BASEDIRNAME);
-+ FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
-
- //
- // then add a '.quake2/baseq2' directory in home directory by default
diff --git a/games/quake2forge/files/patch-src__gl_fxmesa.c b/games/quake2forge/files/patch-src__gl_fxmesa.c
deleted file mode 100644
index 3487f933ac2d..000000000000
--- a/games/quake2forge/files/patch-src__gl_fxmesa.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gl_fxmesa.c.orig Sat Jul 20 01:30:46 2002
-+++ src/gl_fxmesa.c Wed Feb 22 20:24:51 2006
-@@ -72,8 +72,6 @@
- extern cvar_t *vid_fullscreen;
- extern cvar_t *vid_ref;
-
--#define GLAPI extern
--#define GLAPIENTRY
-
- #define FXMESA_NONE 0 // to terminate attribList
- #define FXMESA_DOUBLEBUFFER 10
diff --git a/games/quake2forge/files/patch-src__gl_glx.c b/games/quake2forge/files/patch-src__gl_glx.c
deleted file mode 100644
index 08c18af39eaf..000000000000
--- a/games/quake2forge/files/patch-src__gl_glx.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gl_glx.c.orig Sun Mar 14 23:25:43 2004
-+++ src/gl_glx.c Wed Feb 22 20:20:51 2006
-@@ -797,8 +797,6 @@
- {
- mx += ((int)event.xmotion.x - mwx) * 2;
- my += ((int)event.xmotion.y - mwy) * 2;
-- mwx = event.xmotion.x;
-- mwy = event.xmotion.y;
-
- if (mx || my)
- dowarp = true;
diff --git a/games/quake2forge/files/patch-src__snd_ao.c b/games/quake2forge/files/patch-src__snd_ao.c
deleted file mode 100644
index 66ea0431d7e1..000000000000
--- a/games/quake2forge/files/patch-src__snd_ao.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/snd_ao.c.orig 2010-06-06 16:01:19.000000000 +0200
-+++ src/snd_ao.c 2010-06-06 16:01:46.000000000 +0200
-@@ -62,6 +62,7 @@ qboolean SNDDMA_Init(struct sndinfo * s)
- }
- }
-
-+ memset(&format, 0, sizeof(format));
- format.bits = si->dma->samplebits = si->bits->value;
- format.rate = si->dma->speed = 44100;
- format.channels = si->dma->channels = si->channels->value;
diff --git a/games/quake2forge/pkg-descr b/games/quake2forge/pkg-descr
deleted file mode 100644
index 71fce4806712..000000000000
--- a/games/quake2forge/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This is a port of the GPL'd Quake 2 source maintained by the Quake Forge
-team. They're patching it with an eye towards portability and bug fixes,
-and in the future, feature enhancments.
-
-Note that to actually USE this port you will need to obtain a copy of
-the original Quake 2 from id Software.
-
-WWW: http://www.quakeforge.net/
diff --git a/games/quake2forge/pkg-message b/games/quake2forge/pkg-message
deleted file mode 100644
index c1c391c419bb..000000000000
--- a/games/quake2forge/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-==============================================================================
-
-Quake2Forge has been installed.
-
-The Quake2Forge binary now gets installed as "quake2forge" instead of "quake2"
-to avoid conflicting with "games/quake2lnx".
-
-If you experience problems with mouse movements when running in GLX-Mode, try
-setting in_dgamouse to 1 (this is actually for people that use the DGA X11
-extension).
-
-You can not change the gamma in SDL-Mode, but you can use "xgamma" to adjust
-it before and after running Quake2Forge.
-
-==============================================================================
diff --git a/games/quake2forge/pkg-plist b/games/quake2forge/pkg-plist
deleted file mode 100644
index d509b7614c40..000000000000
--- a/games/quake2forge/pkg-plist
+++ /dev/null
@@ -1,67 +0,0 @@
-bin/quake2forge
-%%GAME%%lib/quake2forge/baseq2/game.a
-%%GAME%%lib/quake2forge/baseq2/game.la
-%%GAME%%lib/quake2forge/baseq2/game.so
-%%CTF%%lib/quake2forge/ctf/game.a
-%%CTF%%lib/quake2forge/ctf/game.la
-%%CTF%%lib/quake2forge/ctf/game.so
-%%GL%%lib/quake2forge/ref_glx.a
-%%GL%%lib/quake2forge/ref_glx.la
-%%GL%%lib/quake2forge/ref_glx.so
-%%SDLGL%%lib/quake2forge/ref_sdlgl.a
-%%SDLGL%%lib/quake2forge/ref_sdlgl.la
-%%SDLGL%%lib/quake2forge/ref_sdlgl.so
-%%SVGA%%lib/quake2forge/ref_soft.a
-%%SVGA%%lib/quake2forge/ref_soft.la
-%%SVGA%%lib/quake2forge/ref_soft.so
-%%SDL%%lib/quake2forge/ref_softsdl.a
-%%SDL%%lib/quake2forge/ref_softsdl.la
-%%SDL%%lib/quake2forge/ref_softsdl.so
-%%X11%%lib/quake2forge/ref_softx.a
-%%X11%%lib/quake2forge/ref_softx.la
-%%X11%%lib/quake2forge/ref_softx.so
-%%SVGA%%%%GL%%lib/quake2forge/ref_tdfx.a
-%%SVGA%%%%GL%%lib/quake2forge/ref_tdfx.la
-%%SVGA%%%%GL%%lib/quake2forge/ref_tdfx.so
-%%AO%%lib/quake2forge/snd_ao.a
-%%AO%%lib/quake2forge/snd_ao.la
-%%AO%%lib/quake2forge/snd_ao.so
-lib/quake2forge/snd_oss.a
-lib/quake2forge/snd_oss.la
-lib/quake2forge/snd_oss.so
-%%SDL%%lib/quake2forge/snd_sdl.a
-%%SDL%%lib/quake2forge/snd_sdl.la
-%%SDL%%lib/quake2forge/snd_sdl.so
-%%PORTDOCS%%%%DOCSDIR%%/README.Solaris
-%%PORTDOCS%%%%DOCSDIR%%/README.axp
-%%PORTDOCS%%%%DOCSDIR%%/README.install
-%%PORTDOCS%%%%DOCSDIR%%/README.joystick
-%%PORTDOCS%%%%DOCSDIR%%/README.linux
-%%PORTDOCS%%%%DOCSDIR%%/README.sdl
-%%PORTDOCS%%%%DOCSDIR%%/README.solaris
-%%PORTDOCS%%%%DOCSDIR%%/README.sound
-%%PORTDOCS%%%%DOCSDIR%%/TODO-ctf.txt
-%%PORTDOCS%%%%DOCSDIR%%/changes-ctf.txt
-%%PORTDOCS%%%%DOCSDIR%%/changes.txt
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/admin.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/adminset.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/automac.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/ghost.jpg
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/grapple.jpg
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/layout.jpg
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/mainctf_back.jpg
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/menu.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/q2ctf.html
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/say_team.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/stats.jpg
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/tech1.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/tech2.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/tech3.gif
-%%CTF%%%%PORTDOCS%%%%DOCSDIR%%/ctf/tech4.gif
-%%PORTDOCS%%%%DOCSDIR%%/joystick.txt
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%CTF%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/ctf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%CTF%%@dirrm lib/quake2forge/ctf
-%%GAME%%@dirrm lib/quake2forge/baseq2
-@dirrm lib/quake2forge