aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-02-14 17:15:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-02-14 17:15:40 +0000
commit5815e58c6e9a8a371e65b6c08d617def5cc41148 (patch)
treeb03daae12ed977d488e153d995fc92d25227fa6a /games
parent5e3696a7ad5461fefbe47aa86ce60e0ce9903230 (diff)
downloadports-5815e58c6e9a8a371e65b6c08d617def5cc41148.tar.gz
ports-5815e58c6e9a8a371e65b6c08d617def5cc41148.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/gnome-games/Makefile3
-rw-r--r--games/gnome-games/distinfo4
-rw-r--r--games/gnome-games/files/patch-gataxx_gtkgridboard.c21
-rw-r--r--games/gnome-games/files/patch-iagno_othello.c19
-rw-r--r--games/gnomegames2/Makefile3
-rw-r--r--games/gnomegames2/distinfo4
-rw-r--r--games/gnomegames2/files/patch-gataxx_gtkgridboard.c21
-rw-r--r--games/gnomegames2/files/patch-iagno_othello.c19
8 files changed, 16 insertions, 78 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 66f2e916061b..eba339873a13 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomegames2
-PORTVERSION= 2.8.2
-PORTREVISION= 1
+PORTVERSION= 2.8.3
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-games/2.8
diff --git a/games/gnome-games/distinfo b/games/gnome-games/distinfo
index b3f1b4b1cb1c..2104d853d2e5 100644
--- a/games/gnome-games/distinfo
+++ b/games/gnome-games/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-games-2.8.2.tar.bz2) = cbc1013dd490c017fd443ba8ed50c0b2
-SIZE (gnome2/gnome-games-2.8.2.tar.bz2) = 5925337
+MD5 (gnome2/gnome-games-2.8.3.tar.bz2) = 0ee8f7cb3a95a5e69a7c9cbb4dc6c66a
+SIZE (gnome2/gnome-games-2.8.3.tar.bz2) = 5923240
diff --git a/games/gnome-games/files/patch-gataxx_gtkgridboard.c b/games/gnome-games/files/patch-gataxx_gtkgridboard.c
deleted file mode 100644
index 9ceabef83f4f..000000000000
--- a/games/gnome-games/files/patch-gataxx_gtkgridboard.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- gataxx/gtkgridboard.c.orig Thu May 20 17:17:56 2004
-+++ gataxx/gtkgridboard.c Thu May 20 17:18:13 2004
-@@ -140,6 +140,7 @@
- static gint gtk_gridboard_button_press(GtkWidget *widget, GdkEventButton *event)
- {
- GtkGridBoard * gridboard;
-+ int x, y;
-
- g_return_val_if_fail (widget != NULL, FALSE);
- g_return_val_if_fail (GTK_IS_GRIDBOARD(widget), FALSE);
-@@ -147,8 +148,8 @@
-
- gridboard=GTK_GRIDBOARD(widget);
-
-- int x=event->x/gridboard->tilewidth;
-- int y=event->y/gridboard->tileheight;
-+ x=event->x/gridboard->tilewidth;
-+ y=event->y/gridboard->tileheight;
- g_signal_emit (G_OBJECT(widget),
- gridboard_signals[BOXCLICKED], 0, x, y);
- return TRUE;
diff --git a/games/gnome-games/files/patch-iagno_othello.c b/games/gnome-games/files/patch-iagno_othello.c
index 4b87018a5f18..84b963a911e2 100644
--- a/games/gnome-games/files/patch-iagno_othello.c
+++ b/games/gnome-games/files/patch-iagno_othello.c
@@ -1,6 +1,6 @@
---- iagno/othello.c.orig Thu May 20 17:20:21 2004
-+++ iagno/othello.c Thu May 20 17:21:11 2004
-@@ -544,7 +544,7 @@
+--- iagno/othello.c.orig Mon Feb 14 12:07:12 2005
++++ iagno/othello.c Mon Feb 14 12:07:47 2005
+@@ -551,7 +551,7 @@
memcpy (tboard, board, sizeof (gint8) * 8 * 8);
move_board(tboard, i, j, me, 0);
@@ -9,16 +9,7 @@
tmp_move = find_best_move(tboard, not_me, ply_depth-1,
-pass_thresh, -use_thresh, 0, 0);
-@@ -559,7 +559,7 @@
- }
- }
-
-- // check if we have to pass
-+ /* check if we have to pass */
- if (best_x == 8 && best_y == 8) {
- tmp_move = find_best_move(board, not_me, ply_depth-1,
- -pass_thresh, -use_thresh, 0, 0);
-@@ -802,14 +802,14 @@
+@@ -808,14 +808,14 @@
found_free = TRUE;
}
@@ -32,7 +23,7 @@
- // if the game is finished, return the actual score rather than
- // a huristic
+ /* if the game is finished, return the actual score rather than
-+ * a huristic */
++ a huristic */
if (!found_free)
return (actual_score);
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index 66f2e916061b..eba339873a13 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomegames2
-PORTVERSION= 2.8.2
-PORTREVISION= 1
+PORTVERSION= 2.8.3
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-games/2.8
diff --git a/games/gnomegames2/distinfo b/games/gnomegames2/distinfo
index b3f1b4b1cb1c..2104d853d2e5 100644
--- a/games/gnomegames2/distinfo
+++ b/games/gnomegames2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-games-2.8.2.tar.bz2) = cbc1013dd490c017fd443ba8ed50c0b2
-SIZE (gnome2/gnome-games-2.8.2.tar.bz2) = 5925337
+MD5 (gnome2/gnome-games-2.8.3.tar.bz2) = 0ee8f7cb3a95a5e69a7c9cbb4dc6c66a
+SIZE (gnome2/gnome-games-2.8.3.tar.bz2) = 5923240
diff --git a/games/gnomegames2/files/patch-gataxx_gtkgridboard.c b/games/gnomegames2/files/patch-gataxx_gtkgridboard.c
deleted file mode 100644
index 9ceabef83f4f..000000000000
--- a/games/gnomegames2/files/patch-gataxx_gtkgridboard.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- gataxx/gtkgridboard.c.orig Thu May 20 17:17:56 2004
-+++ gataxx/gtkgridboard.c Thu May 20 17:18:13 2004
-@@ -140,6 +140,7 @@
- static gint gtk_gridboard_button_press(GtkWidget *widget, GdkEventButton *event)
- {
- GtkGridBoard * gridboard;
-+ int x, y;
-
- g_return_val_if_fail (widget != NULL, FALSE);
- g_return_val_if_fail (GTK_IS_GRIDBOARD(widget), FALSE);
-@@ -147,8 +148,8 @@
-
- gridboard=GTK_GRIDBOARD(widget);
-
-- int x=event->x/gridboard->tilewidth;
-- int y=event->y/gridboard->tileheight;
-+ x=event->x/gridboard->tilewidth;
-+ y=event->y/gridboard->tileheight;
- g_signal_emit (G_OBJECT(widget),
- gridboard_signals[BOXCLICKED], 0, x, y);
- return TRUE;
diff --git a/games/gnomegames2/files/patch-iagno_othello.c b/games/gnomegames2/files/patch-iagno_othello.c
index 4b87018a5f18..84b963a911e2 100644
--- a/games/gnomegames2/files/patch-iagno_othello.c
+++ b/games/gnomegames2/files/patch-iagno_othello.c
@@ -1,6 +1,6 @@
---- iagno/othello.c.orig Thu May 20 17:20:21 2004
-+++ iagno/othello.c Thu May 20 17:21:11 2004
-@@ -544,7 +544,7 @@
+--- iagno/othello.c.orig Mon Feb 14 12:07:12 2005
++++ iagno/othello.c Mon Feb 14 12:07:47 2005
+@@ -551,7 +551,7 @@
memcpy (tboard, board, sizeof (gint8) * 8 * 8);
move_board(tboard, i, j, me, 0);
@@ -9,16 +9,7 @@
tmp_move = find_best_move(tboard, not_me, ply_depth-1,
-pass_thresh, -use_thresh, 0, 0);
-@@ -559,7 +559,7 @@
- }
- }
-
-- // check if we have to pass
-+ /* check if we have to pass */
- if (best_x == 8 && best_y == 8) {
- tmp_move = find_best_move(board, not_me, ply_depth-1,
- -pass_thresh, -use_thresh, 0, 0);
-@@ -802,14 +802,14 @@
+@@ -808,14 +808,14 @@
found_free = TRUE;
}
@@ -32,7 +23,7 @@
- // if the game is finished, return the actual score rather than
- // a huristic
+ /* if the game is finished, return the actual score rather than
-+ * a huristic */
++ a huristic */
if (!found_free)
return (actual_score);