aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-03-13 20:15:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-03-13 20:15:41 +0000
commit71a5906f5f68f4ee0b97e1ef8b64d7f528090cd1 (patch)
tree1a0a407c7675b03d8c97b683999dca0c9e385326 /games
parentfc90917cf0760fa810f912efd7d069fd83f6c9c5 (diff)
downloadports-71a5906f5f68f4ee0b97e1ef8b64d7f528090cd1.tar.gz
ports-71a5906f5f68f4ee0b97e1ef8b64d7f528090cd1.zip
Unbreak against Clang 10 and Python 3.
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=528376
Diffstat (limited to 'games')
-rw-r--r--games/gtkradiant/Makefile5
-rw-r--r--games/gtkradiant/files/patch-SConstruct9
-rw-r--r--games/gtkradiant/files/patch-install.py9
3 files changed, 19 insertions, 4 deletions
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 599f263c0169..9c57cb8994e1 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -16,14 +16,11 @@ COMMENT= Map editor for FPS games, by id Software and Loki Software
LICENSE= GPLv2
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-08-15
-
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libmhash.so:security/mhash \
libpng.so:graphics/png
-USES= compiler:c++11-lang gnome pkgconfig python:2.7,build scons zip
+USES= compiler:c++11-lang gnome pkgconfig python:build scons zip
USE_GNOME= gtk20 libxml2
MAKE_ARGS= ${MAKE_ENV} BUILD=release
SSP_UNSAFE= yes
diff --git a/games/gtkradiant/files/patch-SConstruct b/games/gtkradiant/files/patch-SConstruct
index 64c22e9411c4..b966a6f9b0cf 100644
--- a/games/gtkradiant/files/patch-SConstruct
+++ b/games/gtkradiant/files/patch-SConstruct
@@ -33,6 +33,15 @@
# OS
OS = commands.getoutput('uname')
+@@ -140,7 +132,7 @@
+ ver_cc = GetGCCVersion(CC)
+ ver_cxx = GetGCCVersion(CXX)
+
+-if ( ver_cc is None or ver_cxx is None or ver_cc[0] < '3' or ver_cxx[0] < '3' or ver_cc != ver_cxx ):
++if ( ver_cc is None or ver_cxx is None or ver_cc[0] < 3 or ver_cxx[0] < 3 or ver_cc != ver_cxx ):
+ print 'Compiler version check failed - need gcc 3.x or later:'
+ print 'CC: %s %s\nCXX: %s %s' % ( CC, repr(ver_cc), CXX, repr(ver_cxx) )
+ Exit(1)
@@ -172,8 +164,8 @@
# common flags
warningFlags = '-W -Wall -Wcast-align -Wcast-qual -Wno-unused-parameter '
diff --git a/games/gtkradiant/files/patch-install.py b/games/gtkradiant/files/patch-install.py
index 322b9f18e4b2..fd0a507b47fb 100644
--- a/games/gtkradiant/files/patch-install.py
+++ b/games/gtkradiant/files/patch-install.py
@@ -1,5 +1,14 @@
--- ./install.py.orig Sun Feb 12 16:47:01 2006
+++ ./install.py Thu Mar 16 16:09:46 2006
+@@ -38,7 +38,7 @@
+ targetFile = target
+ if os.path.isdir(targetFile):
+ targetFile = os.path.join(target, os.path.basename(source))
+- print source, "->", targetFile
++ print(source, "->", targetFile)
+ shutil.copyfile(source, targetFile)
+
+ def copyFileIfExists(source, target):
@@ -98,8 +98,6 @@
]