aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2007-03-15 19:33:51 +0000
committerThomas Gellekum <tg@FreeBSD.org>2007-03-15 19:33:51 +0000
commit7b130584e9625c80015f0824e93eb76bee650745 (patch)
tree7c6da8634b307aa3c99f642732036516ca993b36 /games
parent84908c52df77425e9eba17aa53f76634886c910d (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/awele/Makefile12
-rw-r--r--games/awele/files/patch-aa4
-rw-r--r--games/awele/files/patch-ab25
-rw-r--r--games/awele/pkg-plist2
4 files changed, 21 insertions, 22 deletions
diff --git a/games/awele/Makefile b/games/awele/Makefile
index eec13c05728e..f529926e65d6 100644
--- a/games/awele/Makefile
+++ b/games/awele/Makefile
@@ -7,7 +7,8 @@
PORTNAME= awele
PORTVERSION= 1.0
-CATEGORIES= games tk82
+PORTREVISION= 1
+CATEGORIES= games tk84
MASTER_SITES= http://www-air.inria.fr/ftp/Jean-Paul/ \
${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@@ -16,14 +17,19 @@ DISTFILES= ${PORTNAME}1.0.tgz
MAINTAINER= tg@FreeBSD.org
COMMENT= An african board game
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
-
+USE_TK= yes
WRKSRC= ${WRKDIR}/awele
USE_IMAKE= yes
USE_PERL5_BUILD=yes
MAN6= xawele.6
+PLIST_FILES= bin/awelewish bin/xawele
post-patch:
${PERL} -pi -e "s|\@\@LOCALBASE\@\@|${LOCALBASE}|g;" ${WRKSRC}/Imakefile
+post-install:
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "Use xawele to start awele"
+ @${ECHO_CMD} ""
+
.include <bsd.port.mk>
diff --git a/games/awele/files/patch-aa b/games/awele/files/patch-aa
index 873a72ece4bf..6547b7154f42 100644
--- a/games/awele/files/patch-aa
+++ b/games/awele/files/patch-aa
@@ -11,10 +11,10 @@
XCOMM libs, includes
XCOMM TK_LIB AND TK_INCLUDE stand for tk and tcl
- TK_LIB = -L/usr/local/lib -ltk -ltcl
-+ TK_LIB = -L@@LOCALBASE@@/lib -ltk82 -ltcl82
++ TK_LIB = -L@@LOCALBASE@@/lib -ltk84 -ltcl84
XCOMM TK_LIB = -L/usr/local/lib -ltk4.0 -ltcl7.4
- TK_INCLUDE = -I/usr/local/include
-+ TK_INCLUDE = -I@@LOCALBASE@@/include/tcl8.2 -I@@LOCALBASE@@/include/tk8.2
++ TK_INCLUDE = -I@@LOCALBASE@@/include/tcl8.4 -I@@LOCALBASE@@/include/tk8.4
DEFINES = $(TK_INCLUDE)
LOCAL_LIBRARIES = $(TK_LIB) -lX11 -lm
XCOMM ANSI-C compiler
diff --git a/games/awele/files/patch-ab b/games/awele/files/patch-ab
index cfc786f006f9..f2050064b31d 100644
--- a/games/awele/files/patch-ab
+++ b/games/awele/files/patch-ab
@@ -1,5 +1,5 @@
--- tkAppInit.c.orig Fri Dec 8 16:35:38 1995
-+++ tkAppInit.c Fri May 1 09:36:18 1998
++++ tkAppInit.c Thu Mar 15 08:44:13 2007
@@ -9,12 +9,10 @@
*
* See the file "license.terms" for information on usage and redistribution
@@ -15,15 +15,18 @@
#include "tk.h"
extern void create_commands(Tcl_Interp *,Tk_Window);
-@@ -27,6 +25,7 @@
+@@ -25,9 +23,7 @@
+ * Sun shared libraries to be used for Tcl.
+ */
- extern int matherr();
- int *tclDummyMathPtr = (int *) matherr;
+-extern int matherr();
+-int *tclDummyMathPtr = (int *) matherr;
+-
+
-
/*
*----------------------------------------------------------------------
-@@ -77,14 +76,13 @@
+ *
+@@ -77,14 +73,13 @@
Tcl_AppInit(interp)
Tcl_Interp *interp; /* Interpreter for application. */
{
@@ -39,15 +42,7 @@
/*
* Call the init procedures for included packages. Each call should
-@@ -103,17 +101,14 @@
- */
- create_commands(interp, main);
- link_global_variables(interp, main);
--
-+
- /*
- * Specify a user-specific startup file to invoke if the application
- * is run interactively. Typically the startup file is "~/.apprc"
+@@ -110,10 +105,7 @@
* where "app" is the name of the application. If this line is deleted
* then no user-specific startup file will be run under any conditions.
*/
diff --git a/games/awele/pkg-plist b/games/awele/pkg-plist
deleted file mode 100644
index 6fef8b50b922..000000000000
--- a/games/awele/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/awelewish
-bin/xawele