aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-22 19:49:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-22 19:49:43 +0000
commit8c2aab382d5ceff395ed38e45399378035c4968e (patch)
treeea623aea7a81d860cc89359721fd92c71b84534d /games
parente9cf7164b93e5dbdb7bef22c3dc3980161a34dad (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/qmars/Makefile1
-rw-r--r--games/sarien/Makefile1
-rw-r--r--games/slashem-tty/Makefile1
-rw-r--r--games/stratagus/Makefile1
-rw-r--r--games/torcs/Makefile1
-rw-r--r--games/tuxpuck/Makefile1
-rw-r--r--games/uhexen2/Makefile1
-rw-r--r--games/ultimatestunts/Makefile1
-rw-r--r--games/unnethack/Makefile1
-rw-r--r--games/vitetris/Makefile1
-rw-r--r--games/vultures-claw/Makefile1
-rw-r--r--games/vultures-eye/Makefile1
-rw-r--r--games/xevil/Makefile1
-rw-r--r--games/xgospel/Makefile1
-rw-r--r--games/xkoules/Makefile1
-rw-r--r--games/xmille/Makefile1
16 files changed, 16 insertions, 0 deletions
diff --git a/games/qmars/Makefile b/games/qmars/Makefile
index 64141536df22..f6d85d6aa648 100644
--- a/games/qmars/Makefile
+++ b/games/qmars/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
USE_BZIP2= yes
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's|g++|${CXX}|; s|CCFLAGS =|& ${CXXFLAGS}|' \
diff --git a/games/sarien/Makefile b/games/sarien/Makefile
index 4a58c44d6038..4794cf905446 100644
--- a/games/sarien/Makefile
+++ b/games/sarien/Makefile
@@ -17,6 +17,7 @@ COMMENT= Sierra AGI games interpreter
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_XORG= x11
+MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index dc74827d517b..621984674aa6 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -19,6 +19,7 @@ USE_GMAKE= yes
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
MAKE_ENV+= DATADIR="${DATADIR}"
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index fbcf13fd95cf..e90a261cbf2d 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -31,6 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-extra-includes=${LUA_INCDIR} \
--with-extra-libs=${LUA_LIBDIR}
+MAKE_JOBS_UNSAFE= yes
PORTDOCS= *
PLIST_FILES= bin/stratagus
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index 2f78019cc906..3ecea3525203 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -32,6 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DE
ALL_TARGET= default
INSTALL_TARGET= install datainstall
+MAKE_JOBS_UNSAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index 694e0ef01628..13d1093015c2 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= jpeg.10:${PORTSDIR}/graphics/jpeg \
USE_SDL= sdl
USE_GMAKE= yes
ALL_TARGET= tuxpuck
+MAKE_JOBS_UNSAFE= yes
MANCOMPRESSED= yes
MAN6= tuxpuck.6
diff --git a/games/uhexen2/Makefile b/games/uhexen2/Makefile
index c6af02bf6b3a..d997f406f213 100644
--- a/games/uhexen2/Makefile
+++ b/games/uhexen2/Makefile
@@ -21,6 +21,7 @@ USE_GMAKE= yes
USE_GL= yes
USE_SDL= sdl mixer
WANT_GNOME= yes
+MAKE_JOBS_UNSAFE= yes
OPTIONS= DEMO "Install demo version of the game data" off \
HEXEN2 "Build Hexen II clients and servers" on \
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index 2893de2b72a5..a879ceb5d09b 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -28,6 +28,7 @@ CPPFLAGS+= `${SDL_CONFIG} --cflags`
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PORT_VERBS= ${PORTNAME} ustunts
+MAKE_JOBS_UNSAFE= yes
post-extract:
@${FIND} ${WRKSRC} -name CVS|${SED} -e 's| |\\ |g'|${XARGS} ${RM} -rf
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index dc74827d517b..621984674aa6 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -19,6 +19,7 @@ USE_GMAKE= yes
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
MAKE_ENV+= DATADIR="${DATADIR}"
diff --git a/games/vitetris/Makefile b/games/vitetris/Makefile
index eb7d73f9ae9d..5bc22b0c3120 100644
--- a/games/vitetris/Makefile
+++ b/games/vitetris/Makefile
@@ -17,6 +17,7 @@ HAS_CONFIGURE= yes
ALL_TARGET= #
CONFIGURE_ARGS= --prefix=${PREFIX} --datarootdir=${PREFIX}/share \
curses="-lncurses" xlib=no
+MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/vitetris \
share/allegro/licence.txt \
diff --git a/games/vultures-claw/Makefile b/games/vultures-claw/Makefile
index 04f5e537d61e..14a4e5134eb5 100644
--- a/games/vultures-claw/Makefile
+++ b/games/vultures-claw/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
USE_SDL= sdl ttf mixer
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/slashem
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 0e6b832ecce0..147f36d08f68 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/sys/unix
CONFIGURE_SCRIPT= setup.sh
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
MAKE_ENV+= DATADIR="${DATADIR}" MAKE="${GMAKE}"
+MAKE_JOBS_UNSAFE= yes
pre-configure:
@${CHMOD} 755 ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index 379c8a3cfae6..4b1bf70401db 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -19,6 +19,7 @@ USE_ZIP= yes
USE_XORG= xpm
MAKEFILE= makefile
ALL_TARGET= freebsd
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/games/xgospel/Makefile b/games/xgospel/Makefile
index 18551526207e..bec220d08259 100644
--- a/games/xgospel/Makefile
+++ b/games/xgospel/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XORG= ice sm x11 xaw xext xmu xpm xt
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS= --with-x --with-xpm --with-xaw3d
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
index b4fee1c0c214..6d1415ea8c2a 100644
--- a/games/xkoules/Makefile
+++ b/games/xkoules/Makefile
@@ -20,6 +20,7 @@ COMMENT= Fast action arcade-style game for X Window
USE_IMAKE= yes
USE_XORG= x11 xext
MAN6= xkoules.6
+MAKE_JOBS_UNSAFE= yes
post-extract:
@${CP} ${WRKSRC}/xkoules.6 ${WRKSRC}/xkoules.man
diff --git a/games/xmille/Makefile b/games/xmille/Makefile
index 5eb2639f0e1f..46cdd01625dd 100644
--- a/games/xmille/Makefile
+++ b/games/xmille/Makefile
@@ -22,6 +22,7 @@ USE_IMAKE= yes
USE_XORG= x11 xext
MAN1= xmille.1
PLIST_FILES= bin/xmille
+MAKE_JOBS_UNSAFE= yes
post-extract:
@${FIND} ${WRKSRC} -name '*.[ao]' -delete