aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 00:46:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 00:46:28 +0000
commita24aeb28ebac7c4473971f143405ca1b7c78c2d3 (patch)
tree5d77d58c324cf9ed79b739d131372076aa339e0f /games
parent1e85259f841c221927375264c78fb5070bcdf91d (diff)
downloadports-a24aeb28ebac7c4473971f143405ca1b7c78c2d3.tar.gz
ports-a24aeb28ebac7c4473971f143405ca1b7c78c2d3.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/teeworlds/Makefile12
-rw-r--r--games/teeworlds/distinfo6
-rw-r--r--games/teeworlds/files/patch-default.bam12
3 files changed, 15 insertions, 15 deletions
diff --git a/games/teeworlds/Makefile b/games/teeworlds/Makefile
index 00c8a2aa088d..b7259552cd97 100644
--- a/games/teeworlds/Makefile
+++ b/games/teeworlds/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= teeworlds
-PORTVERSION= 0.4.2
+PORTVERSION= 0.4.3
CATEGORIES= games
MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
http://www.teeworlds.com/files/
@@ -18,7 +18,7 @@ COMMENT= Platform game featuring buggers equipped with weapons
USE_PYTHON_BUILD= yes
-BAM= ${WRKDIR}/bam.bin
+BAM= ${WRKDIR}/bam.bin
BAM_VERSION= 20080326
BAM_TARGET= release
@@ -26,10 +26,6 @@ OPTIONS= TEEWORLDS_SERVER_ONLY "Build dedicated server only" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700042
-BROKEN= Does not compile
-.endif
-
.if defined(WITH_TEEWORLDS_SERVER_ONLY)
BAM_TARGET= server_release
PLIST_SUB+= CLIENT="@comment "
@@ -51,6 +47,10 @@ post-patch:
@${FIND} ${WRKSRC}/src -name "*.c" -o -name "*.cpp" | \
${XARGS} ${REINPLACE_CMD} -e 's|"data/|"${DATADIR}/|g'
@${REINPLACE_CMD} -e 's|"data/|"${DATADIR}/|g' ${WRKSRC}/datasrc/*
+.if ${OSVERSION} < 700042
+ @${REINPLACE_CMD} -e 's|-fstack-protector -fstack-protector-all||' \
+ ${WRKSRC}/default.bam
+.endif
# build bam executable - teeworlds own build system
pre-build:
diff --git a/games/teeworlds/distinfo b/games/teeworlds/distinfo
index 48a9402281f7..8aff4ae6551d 100644
--- a/games/teeworlds/distinfo
+++ b/games/teeworlds/distinfo
@@ -1,6 +1,6 @@
-MD5 (teeworlds-0.4.2-src.tar.gz) = 97f1833ea94015b472a0f828003693b8
-SHA256 (teeworlds-0.4.2-src.tar.gz) = da7fed1d6d51b2f2fccfc106a08dec31a702be01e20ed751e328d2ebd462c7b4
-SIZE (teeworlds-0.4.2-src.tar.gz) = 5050346
+MD5 (teeworlds-0.4.3-src.tar.gz) = a31a8cbd1af3f71a462122166e5872d6
+SHA256 (teeworlds-0.4.3-src.tar.gz) = 366418de9228818516edf9efbb3cb54dcd62e09e1354838ae010327e420924cc
+SIZE (teeworlds-0.4.3-src.tar.gz) = 5056193
MD5 (bam-20080326.tar.gz) = 7eb70ccacd95d05319eef4a73e485e8e
SHA256 (bam-20080326.tar.gz) = 1103142f2a0297541021a75e3df7e4b4c4a71afcf31ca53b46844b90d026485e
SIZE (bam-20080326.tar.gz) = 124493
diff --git a/games/teeworlds/files/patch-default.bam b/games/teeworlds/files/patch-default.bam
index 48b8c61c5919..208af794b1fd 100644
--- a/games/teeworlds/files/patch-default.bam
+++ b/games/teeworlds/files/patch-default.bam
@@ -1,8 +1,8 @@
---- default.bam.orig 2008-03-23 16:34:56.000000000 +0300
-+++ default.bam 2008-03-23 22:39:30.000000000 +0300
+--- default.bam.orig 2008-08-31 17:30:59.000000000 +0400
++++ default.bam 2008-09-06 03:08:34.000000000 +0400
@@ -207,14 +207,16 @@
if platform == "macosx" then
- settings.cc.flags = "-Wall -fno-exceptions"
+ settings.cc.flags = "-Wall -fno-exceptions -mmacosx-version-min=10.4"
else
- settings.cc.flags = "-Wall -fstack-protector -fstack-protector-all -fno-exceptions"
+ settings.cc.flags = settings.cc.flags .. " -Wall -fstack-protector -fstack-protector-all -fno-exceptions"
@@ -73,16 +73,16 @@
wavpack = Compile(external_settings, Collect("src/engine/external/wavpack/*.c"))
pnglite = Compile(external_settings, Collect("src/engine/external/pnglite/*.c"))
-@@ -337,7 +331,7 @@
+@@ -338,7 +332,7 @@
- -- build client, server and master server
+ -- build client, server, version server and master server
client_exe = Link(client_settings, "teeworlds", game_shared, game_client,
- engine, client, game_editor, glfw, portaudio, zlib, pnglite, wavpack,
+ engine, client, game_editor, glfw, pnglite, wavpack,
client_link_other)
server_exe = Link(server_settings, "teeworlds_srv", engine, server,
-@@ -383,7 +377,7 @@
+@@ -389,7 +383,7 @@
release_settings.config_name = "release"
release_settings.config_ext = ""
release_settings.debug = 0