aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-23 02:35:53 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-23 02:35:53 +0000
commit012ad4f28eac02421dbc32420efa08a9b56320a7 (patch)
tree5b980e60b1dce9ac0a48161521ebfde00f8c74b1 /games
parent1961a474130dda7aa19df7662ebc60ef5d074062 (diff)
downloadports-012ad4f28eac02421dbc32420efa08a9b56320a7.tar.gz
ports-012ad4f28eac02421dbc32420efa08a9b56320a7.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/asteroids3d/Makefile29
-rw-r--r--games/asteroids3d/pkg-plist14
2 files changed, 12 insertions, 31 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 8d175e375b86..13bb0d9923d2 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= asteroids3d
@@ -6,12 +6,12 @@ PORTVERSION= 0.5.1
PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/a3d/${PORTVERSION}/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTNAME= ${PORTNAME:S/3d/3D/}-${DISTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= First-person shooter blowing up asteroids in 3D space
LICENSE= GPLv2
@@ -33,32 +33,27 @@ ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
-NO_STAGE= yes
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${DATADIR})
+ @${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${STAGEDIR}${DATADIR})
-post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/asteroids3d/pkg-plist b/games/asteroids3d/pkg-plist
index 577143961f87..5147265594ad 100644
--- a/games/asteroids3d/pkg-plist
+++ b/games/asteroids3d/pkg-plist
@@ -26,18 +26,4 @@ share/icons/hicolor/64x64/apps/asteroids3d.png
share/icons/hicolor/72x72/apps/asteroids3d.png
share/icons/hicolor/96x96/apps/asteroids3d.png
share/pixmaps/asteroids3d.png
-@dirrmtry share/icons/hicolor/96x96/apps
-@dirrmtry share/icons/hicolor/96x96
-@dirrmtry share/icons/hicolor/72x72/apps
-@dirrmtry share/icons/hicolor/72x72
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
@dirrm %%DATADIR%%