aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-09-14 18:34:21 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-09-14 18:34:21 +0000
commit0ecaeefd5fc97fd49984c7dea8994a60160ce01c (patch)
tree35976349e0053041b39ba874753c38e004a78ece /games
parent09e2b8f6e31d5a4f156114afc01524a28f33141f (diff)
downloadports-0ecaeefd5fc97fd49984c7dea8994a60160ce01c.tar.gz
ports-0ecaeefd5fc97fd49984c7dea8994a60160ce01c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile18
-rw-r--r--games/0ad/distinfo8
-rw-r--r--games/0ad/files/patch-build-premake-premake4-build-gmake.bsd-Premake4.make20
-rw-r--r--games/0ad/files/patch-build-premake-premake4-build-gmake.unix-Premake4.make32
-rw-r--r--games/0ad/files/patch-build-premake-premake4.lua18
5 files changed, 38 insertions, 58 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 5faaa68e51aa..9f831e9efb20 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -1,17 +1,11 @@
-# New ports collection makefile for: 0ad
-# Date created: 13 Jan 2012
-# Whom: Guido Falsi <mad@madpilot.net>
-#
# $FreeBSD$
-#
PORTNAME= 0ad
-DISTVERSION= alpha.10
-PORTREVISION= 2
+PORTVERSION= 0.0.11
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
-DISTFILES= ${PORTNAME}-${SVNREV}-alpha-unix-build.tar.xz \
- ${PORTNAME}-${SVNREV}-alpha-unix-data.tar.xz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
+ ${PORTNAME}-${PORTVERSION}-alpha-unix-data.tar.xz
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Real-time strategy (RTS) game of ancient warfare
@@ -27,7 +21,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
curl:${PORTSDIR}/ftp/curl \
gamin-1:${PORTSDIR}/devel/gamin
-WRKSRC= ${WRKDIR}/${PORTNAME}-${SVNREV}-alpha
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
USE_GMAKE= yes
@@ -37,7 +31,7 @@ USE_GNOME= libxml2 gtk20
USE_GL= gl
USE_OPENAL= al
USE_DOS2UNIX= yes
-DOS2UNIX_REGEX= .*\.[ch]p{0,2}
+DOS2UNIX_REGEX= .*\.([ch]p{0,2}|make)
MAKE_JOBS_SAFE= yes
USE_WX= 2.8
@@ -47,8 +41,6 @@ MAKE_ENV+= JOBS=${_MAKE_JOBS}
MANUAL_PACKAGE_BUILD= yes # huge
-SVNREV= r11863
-
PORTDATA= *
.include <bsd.port.pre.mk>
diff --git a/games/0ad/distinfo b/games/0ad/distinfo
index 96bc20218483..8e36a9cc6251 100644
--- a/games/0ad/distinfo
+++ b/games/0ad/distinfo
@@ -1,4 +1,4 @@
-SHA256 (0ad-r11863-alpha-unix-build.tar.xz) = 46c08d380ce098d3d8f577d04d602bb245dfbb7f7da7b1ad009e7a0d4751435f
-SIZE (0ad-r11863-alpha-unix-build.tar.xz) = 8657204
-SHA256 (0ad-r11863-alpha-unix-data.tar.xz) = 76702023402361d27b61eea37034b08e9e19b282e4cdd69954495d2dd087b90a
-SIZE (0ad-r11863-alpha-unix-data.tar.xz) = 310994700
+SHA256 (0ad-0.0.11-alpha-unix-build.tar.xz) = a218c42bce111d0bcb02b3a18eb14d7c06a839b8863df362083ebd0835d3c6a3
+SIZE (0ad-0.0.11-alpha-unix-build.tar.xz) = 8682272
+SHA256 (0ad-0.0.11-alpha-unix-data.tar.xz) = a28dd9160637bc1345223ec6f9c36bb693350e9dcc35a3194f43ed463b3ba20e
+SIZE (0ad-0.0.11-alpha-unix-data.tar.xz) = 350967036
diff --git a/games/0ad/files/patch-build-premake-premake4-build-gmake.bsd-Premake4.make b/games/0ad/files/patch-build-premake-premake4-build-gmake.bsd-Premake4.make
new file mode 100644
index 000000000000..45d8a468a5c5
--- /dev/null
+++ b/games/0ad/files/patch-build-premake-premake4-build-gmake.bsd-Premake4.make
@@ -0,0 +1,20 @@
+--- build/premake/premake4/build/gmake.bsd/Premake4.make.orig 2012-09-13 04:29:58.196744551 +0200
++++ build/premake/premake4/build/gmake.bsd/Premake4.make 2012-09-13 04:32:48.083760584 +0200
+@@ -24,7 +24,7 @@
+ TARGETDIR = ../../bin/release
+ TARGET = $(TARGETDIR)/premake4
+ DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+- INCLUDES += -I../../src/host/lua-5.1.4/src
++ INCLUDES += -I../../src/host/lua-5.1.4/src -I$(LOCALBASE)/include/wx-2.8
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+ CFLAGS += $(CPPFLAGS) -Wall -Os
+ CXXFLAGS += $(CPPFLAGS) -Wall -Os
+@@ -46,7 +46,7 @@
+ TARGETDIR = ../../bin/debug
+ TARGET = $(TARGETDIR)/premake4
+ DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+- INCLUDES += -I../../src/host/lua-5.1.4/src
++ INCLUDES += -I../../src/host/lua-5.1.4/src -I$(LOCALBASE)/include/wx-2.8
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+ CFLAGS += $(CPPFLAGS) -Wall -g
+ CXXFLAGS += $(CPPFLAGS) -Wall -g
diff --git a/games/0ad/files/patch-build-premake-premake4-build-gmake.unix-Premake4.make b/games/0ad/files/patch-build-premake-premake4-build-gmake.unix-Premake4.make
deleted file mode 100644
index 0b73356e7210..000000000000
--- a/games/0ad/files/patch-build-premake-premake4-build-gmake.unix-Premake4.make
+++ /dev/null
@@ -1,32 +0,0 @@
---- build/premake/premake4/build/gmake.unix/Premake4.make.orig 2012-01-12 01:03:37.000000000 +0100
-+++ build/premake/premake4/build/gmake.unix/Premake4.make 2012-05-03 16:24:21.478971350 +0200
-@@ -24,12 +24,12 @@
- TARGETDIR = ../../bin/release
- TARGET = $(TARGETDIR)/premake4
- DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
-- INCLUDES += -I../../src/host/lua-5.1.4/src
-+ INCLUDES += -I../../src/host/lua-5.1.4/src -I$(LOCALBASE)/include/wx-2.8
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
- CFLAGS += $(CPPFLAGS) -Wall -Os
- CXXFLAGS += $(CFLAGS)
- LDFLAGS += -s -rdynamic
-- LIBS += -lm -ldl
-+ LIBS += -lm
- RESFLAGS += $(DEFINES) $(INCLUDES)
- LDDEPS +=
- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LDDEPS) $(LIBS)
-@@ -46,12 +46,12 @@
- TARGETDIR = ../../bin/debug
- TARGET = $(TARGETDIR)/premake4
- DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
-- INCLUDES += -I../../src/host/lua-5.1.4/src
-+ INCLUDES += -I../../src/host/lua-5.1.4/src -I$(LOCALBASE)/include/wx-2.8
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
- CFLAGS += $(CPPFLAGS) -Wall -g
- CXXFLAGS += $(CFLAGS)
- LDFLAGS += -rdynamic
-- LIBS += -lm -ldl
-+ LIBS += -lm
- RESFLAGS += $(DEFINES) $(INCLUDES)
- LDDEPS +=
- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LDDEPS) $(LIBS)
diff --git a/games/0ad/files/patch-build-premake-premake4.lua b/games/0ad/files/patch-build-premake-premake4.lua
index e03163ab788e..ba2d912fd2af 100644
--- a/games/0ad/files/patch-build-premake-premake4.lua
+++ b/games/0ad/files/patch-build-premake-premake4.lua
@@ -1,14 +1,14 @@
---- build/premake/premake4.lua.orig 2012-02-21 21:27:25.000000000 +0100
-+++ build/premake/premake4.lua 2012-05-17 23:23:30.211530880 +0200
-@@ -215,7 +215,6 @@
+--- build/premake/premake4.lua.orig 2012-08-15 02:10:44.000000000 +0200
++++ build/premake/premake4.lua 2012-09-13 04:13:10.184743291 +0200
+@@ -220,7 +220,6 @@
- -- enable security features (stack checking etc) that shouldn't have
- -- a significant effect on performance and can catch bugs
-- "-fstack-protector-all",
- "-D_FORTIFY_SOURCE=2",
+ -- enable security features (stack checking etc) that shouldn't have
+ -- a significant effect on performance and can catch bugs
+- "-fstack-protector-all",
+ "-D_FORTIFY_SOURCE=2",
- -- always enable strict aliasing (useful in debug builds because of the warnings)
-@@ -276,11 +275,11 @@
+ -- always enable strict aliasing (useful in debug builds because of the warnings)
+@@ -292,11 +291,11 @@
-- X11 includes may be installed in one of a gadzillion of three places
-- Famous last words: "You can't include too much! ;-)"
includedirs {