aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-02 21:07:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-02 21:07:38 +0000
commit3c55e4d248b0c9c82fc6b8fef67ee27e9b7b6462 (patch)
tree732359190811881f44d79f66c4fab7f2e4c435f5 /games
parent2f0486b64721a1072cdd1b8d2840d6539b2247d2 (diff)
downloadports-3c55e4d248b0c9c82fc6b8fef67ee27e9b7b6462.tar.gz
ports-3c55e4d248b0c9c82fc6b8fef67ee27e9b7b6462.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/freeminer/Makefile4
-rw-r--r--games/springlobby/Makefile6
-rw-r--r--games/supertuxkart/Makefile5
-rw-r--r--games/wargus/Makefile8
-rw-r--r--games/widelands/Makefile6
5 files changed, 3 insertions, 26 deletions
diff --git a/games/freeminer/Makefile b/games/freeminer/Makefile
index e20609230722..d33b28153fd5 100644
--- a/games/freeminer/Makefile
+++ b/games/freeminer/Makefile
@@ -64,10 +64,6 @@ LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-BROKEN= does not build on 8.x (lack of long long support)
-.endif
-
.if ${PORT_OPTIONS:MCLIENT} && ${PORT_OPTIONS:MSOUND}
USES+= openal
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index 32e2a3a50ceb..2ee740d394de 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -46,10 +46,4 @@ NOTIFY_CMAKE_ON= -DOPTION_NOTIFY=ON
NOTIFY_CMAKE_OFF= -DOPTION_NOTIFY=OFF
NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 901000
-IGNORE= does not build (no strtoll(3) support)
-.endif
-
.include <bsd.port.mk>
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 8500ab94b4e8..c509eb3493b9 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libcurl.so:${PORTSDIR}/ftp/curl \
libpng.so:${PORTSDIR}/graphics/png
-BROKEN_powerpc= does not configure on powerpc
-BROKEN_FreeBSD_8= does not build on 8.x
+BROKEN_powerpc= does not configure on powerpc
-USES= alias cmake compiler:c++11-lib dos2unix gettext \
+USES= alias cmake compiler:c++11-lib dos2unix gettext \
gmake jpeg openal:al pkgconfig tar:xz
USE_GL= gl glu
USE_SDL= sdl
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 077f1e4d50a7..b67843936487 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -30,15 +30,9 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-BROKEN= does not build
-.endif
-
post-install:
cd ${WRKSRC}/doc && ${INSTALL_MAN} *.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 71d0fdb13adb..648df77eedd6 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -40,12 +40,6 @@ DESKTOP_ENTRIES="Widelands" \
"Game;StrategyGame;" \
""
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-IGNORE= doesn't build on 8.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/*.cmake