aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-08-01 07:15:38 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-08-01 07:15:38 +0000
commit464ce24e2ce8c332dc990d78ca284f4a1a17abf7 (patch)
treeacacbaf55352d8821c06134dce5bafd1e3d121b7 /games
parent9b422a0d5a5b751fd997815299c67ddea95f4078 (diff)
downloadports-464ce24e2ce8c332dc990d78ca284f4a1a17abf7.tar.gz
ports-464ce24e2ce8c332dc990d78ca284f4a1a17abf7.zip
MFH: r543817
games/py-mnemosyne: Take Maintainer'ship, fix runtime error and add missing dependencies Latest version of games/py-mnemosyne requires new dependencies. This commit adds the missing dependencies: - audio/py-gtts - security/py-gtts-token (required by audio/py-gtts) - textproc/py-googletrans The games/py-mnemosyne port needs to be limited to Python 3.7+ to keep the dependency chains intact. This is because textproc/py-googletrans depends on www/py-httpx which is only for Python 3.7+. PR: 247595 Submitted by: kai Reported by: gspurki@gmail.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D25895 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q3/; revision=543891
Diffstat (limited to 'games')
-rw-r--r--games/py-mnemosyne/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
index fe3735c86fbd..0371baeb36ed 100644
--- a/games/py-mnemosyne/Makefile
+++ b/games/py-mnemosyne/Makefile
@@ -3,13 +3,14 @@
PORTNAME= mnemosyne
PORTVERSION= 2.7.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= games python
MASTER_SITES= SF/mnemosyne-proj/${PORTNAME}/${PORTNAME}-${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Mnemosyne-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= Flash-card tool which optimises your learning process
LICENSE= LGPL3
@@ -19,15 +20,17 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webob>=1.4:www/py-webob@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cheroot>=0:www/py-cheroot@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}cheroot>=0:www/py-cheroot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}googletrans>=0:textproc/py-googletrans@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gtts>=0:audio/py-gtts@${PY_FLAVOR}
-USES= pyqt:5 python:3.5+
+USES= pyqt:5 python:3.7+ #due textproc/py-googletrans
USE_PYQT= gui_run network_run printsupport_run sip_run sql_run webengine_run
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} -e 's|\(share/\)icons|\1pixmaps|' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|icons|pixmaps|' ${WRKSRC}/setup.py
.include <bsd.port.mk>