aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-08-02 18:33:29 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-08-02 18:33:29 +0000
commit6b1fe9fd71e4dcfd36ece5fdafdde994327d5351 (patch)
treebfc7aea5d71a0397031ab8bb3c8dec34f838edb8 /games
parent33c09221a0a2ca46753ff8462837866d96db9759 (diff)
downloadports-6b1fe9fd71e4dcfd36ece5fdafdde994327d5351.tar.gz
ports-6b1fe9fd71e4dcfd36ece5fdafdde994327d5351.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile22
-rw-r--r--games/alephone/distinfo6
-rw-r--r--games/alephone/files/patch-Source_Files-Misc-preferences.cpp13
-rw-r--r--games/alephone/pkg-plist7
4 files changed, 18 insertions, 30 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index d7d215d81ea2..dcabe0de2b3a 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= alephone
-PORTVERSION= 20080913
-PORTREVISION= 4
+PORTVERSION= 20100424
CATEGORIES= games
-MASTER_SITES= SF/marathon/Aleph%20One/2008-09-13
+MASTER_SITES= SF/marathon/Aleph%20One/2010-04-24
DISTNAME= AlephOne-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fiziologus@gmail.com
COMMENT= The open source version of Bungie's Marathon game
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/include/zzip/lib.h:${PORTSDIR}/devel/zziplib
USE_BZIP2= yes
USE_GL= yes
-USE_GNOME= gnometarget
USE_LUA= 5.1
-USE_SDL= image net sdl sound
+USE_SDL= image ttf net sdl sound
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}" \
LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}"
@@ -31,17 +30,14 @@ DATADIR= ${PREFIX}/share/AlephOne
MAN6= alephone.6
-PORTDOCS= *
-
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README docs/* ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${DOCSDIR}
.endif
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index 2a8634f82add..7e03df0c2654 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,3 +1,3 @@
-MD5 (AlephOne-20080913.tar.bz2) = 28f0233b0cbb5a87f43b2b20cc57d52b
-SHA256 (AlephOne-20080913.tar.bz2) = 5ad744c111fa87c6106f9e9e84737b4c0320083d99ec63a47c1971fca8da1dce
-SIZE (AlephOne-20080913.tar.bz2) = 3038836
+MD5 (AlephOne-20100424.tar.bz2) = 9fd5517fcf4e1dd8ce3fe6331ac58e8e
+SHA256 (AlephOne-20100424.tar.bz2) = d97089890ce99952027eaf6185baa6cb01b26c2882dfca9e68816dfe7076a5e6
+SIZE (AlephOne-20100424.tar.bz2) = 3180896
diff --git a/games/alephone/files/patch-Source_Files-Misc-preferences.cpp b/games/alephone/files/patch-Source_Files-Misc-preferences.cpp
deleted file mode 100644
index 22d0eb9d8325..000000000000
--- a/games/alephone/files/patch-Source_Files-Misc-preferences.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- Source_Files/Misc/preferences.cpp.orig 2008-07-22 04:06:39.000000000 +0400
-+++ Source_Files/Misc/preferences.cpp 2008-08-21 23:10:31.000000000 +0400
-@@ -175,10 +175,7 @@
- static void default_environment_preferences(environment_preferences_data *preferences);
- static bool validate_environment_preferences(environment_preferences_data *preferences);
-
--#if 0
- static inline float log2(int x) { return std::log((float) x) / std::log(2.0); };
--static inline float exp2(int x) { return std::exp((float) x + std::log(2.0)); };
--#endif
-
- // Prototypes
- static void player_dialog(void *arg);
diff --git a/games/alephone/pkg-plist b/games/alephone/pkg-plist
index 4babe801fd8e..8486f21e507e 100644
--- a/games/alephone/pkg-plist
+++ b/games/alephone/pkg-plist
@@ -42,7 +42,12 @@ bin/alephone
%%DATADIR%%/Themes/Default/tiny_button_c.bmp
%%DATADIR%%/Themes/Default/tiny_button_l.bmp
%%DATADIR%%/Themes/Default/tiny_button_r.bmp
+%%PORTDOCS%%%%DOCSDIR%%/Lua.html
+%%PORTDOCS%%%%DOCSDIR%%/Lua_HUD.html
+%%PORTDOCS%%%%DOCSDIR%%/MML.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/Themes/Default
@dirrm %%DATADIR%%/Themes
@dirrm %%DATADIR%%/MML
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%