aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-19 17:12:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-19 17:12:33 +0000
commit78472fd2bda442d65a5a1ec9a0e2f9674c004f47 (patch)
treea3d2abdc7ff5d0c1080ca0eb21ba446b9e5b6575 /games
parent1ef4f8a6ed2cf345da8dffd62c2cd3d616b63f9d (diff)
downloadports-78472fd2bda442d65a5a1ec9a0e2f9674c004f47.tar.gz
ports-78472fd2bda442d65a5a1ec9a0e2f9674c004f47.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/foobillard/Makefile18
-rw-r--r--games/foobillard/distinfo2
-rw-r--r--games/foobillard/files/patch-Makefile.in21
-rw-r--r--games/foobillard/files/patch-billard3d.c20
-rw-r--r--games/foobillard/pkg-plist8
5 files changed, 51 insertions, 18 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index a0fd2e0987a4..bbef7073884a 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= foobillard
-PORTVERSION= 1.8
+PORTVERSION= 2.4
CATEGORIES= games
MASTER_SITES= http://foobillard.sunsite.dk/dnl/
@@ -14,23 +14,33 @@ MAINTAINER= thomas.vogt@bsdunix.ch
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
png.5:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_MESA= yes
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_REINPLACE= yes
-
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-SDL --prefix=${PREFIX} \
--includedir="${X11BASE}/include"
+.if !defined(WITH_NVIDIA_BUMPREF)
+CONFIGURE_ARGS+= --disable-bumpref
+.endif
+
+MAN6= foobillard.6
+MANCOMPRESSED= no
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Makefile.in
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/foobillard.6 ${PREFIX}/man/man6/foobillard.6
+
.include <bsd.port.mk>
diff --git a/games/foobillard/distinfo b/games/foobillard/distinfo
index 4ec1e3a991f9..62bf9a3bf6dd 100644
--- a/games/foobillard/distinfo
+++ b/games/foobillard/distinfo
@@ -1 +1 @@
-MD5 (foobillard-1.8.tar.gz) = 14038a77187316f378e95ab6ef9ce6fc
+MD5 (foobillard-2.4.tar.gz) = 9f1adabaf9b62ed1ab7e050d43519f73
diff --git a/games/foobillard/files/patch-Makefile.in b/games/foobillard/files/patch-Makefile.in
index b88793647eaa..40b9f6d70e0e 100644
--- a/games/foobillard/files/patch-Makefile.in
+++ b/games/foobillard/files/patch-Makefile.in
@@ -1,16 +1,9 @@
---- src/Makefile.in.orig Sat Oct 26 22:01:08 2002
-+++ src/Makefile.in Sat Oct 26 22:01:40 2002
-@@ -1,4 +1,4 @@
--# Makefile.in generated automatically by automake 1.4-p6 from Makefile.am
-+# Makefile.in generated automatically by automake 1.4-p6 from Makefile.am
+--- src/Makefile.in.orig Sun Feb 16 13:48:17 2003
++++ src/Makefile.in Sun Feb 16 13:52:33 2003
+@@ -69,16 +69,16 @@
- # Copyright (C) 1994, 1995-8, 1999, 2001 Free Software Foundation, Inc.
- # This Makefile.in is free software; the Free Software Foundation
-@@ -72,14 +72,14 @@
- #INCDIR = /usr/X11R6/include
--CC = gcc
-+CC ?= gcc
+ INCLUDES = -DNDEBUG -DDATA_DIRECTORY='"${pkgdatadir}/"'
-@USE_SDL_TRUE@SDL_CFLAGS = `sdl-config --cflags` -DUSE_SDL
+@USE_SDL_TRUE@SDL_CFLAGS = `$(SDL_CONFIG) --cflags` -DUSE_SDL
@USE_SDL_FALSE@SDL_CFLAGS =
@@ -19,9 +12,11 @@
@USE_SDL_FALSE@SDL_LIBS =
@USE_SDL_TRUE@GLUT_LIBS =
@USE_SDL_FALSE@GLUT_LIBS = -lglut
+ @USE_BUMPREF_TRUE@BUMPREF_CFLAGS =
+ @USE_BUMPREF_FALSE@BUMPREF_CFLAGS = -DNO_NV_BUMPREF
--CFLAGS = -Wall -O3 `freetype-config --cflags` ${SDL_CFLAGS}
-+CFLAGS += -Wall `freetype-config --cflags` ${SDL_CFLAGS} -I%%X11BASE%%/include -I%%LOCALBASE%%/include -I%%LOCALBASE%%/include/SDL11
+-CFLAGS = -Wall -O3 `freetype-config --cflags` ${SDL_CFLAGS} ${BUMPREF_CFLAGS}
++CFLAGS += -Wall `freetype-config --cflags` ${SDL_CFLAGS} ${BUMPREF_CFLAGS} -I%%X11BASE%%/include
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
diff --git a/games/foobillard/files/patch-billard3d.c b/games/foobillard/files/patch-billard3d.c
new file mode 100644
index 000000000000..3c8a29ec1965
--- /dev/null
+++ b/games/foobillard/files/patch-billard3d.c
@@ -0,0 +1,20 @@
+--- src/billard3d.c.orig Sat Jan 11 02:04:01 2003
++++ src/billard3d.c Sun Feb 16 16:39:59 2003
+@@ -24,7 +24,7 @@
+ #include <string.h>
+ #include <math.h>
+ #include <unistd.h>
+-#include <endian.h>
++#include <machine/endian.h>
+
+ #ifndef USE_SDL
+ #include <GL/glut.h>
+@@ -4094,7 +4094,7 @@
+ fread( &ball_ball_snd.data[SOUND_NULLOFFS*2], 1, ball_ball_snd.len-SOUND_NULLOFFS*2*2 , f );
+ fclose(f);
+
+-#if __BYTE_ORDER == __BIG_ENDIAN
++#if _BYTE_ORDER == _BIG_ENDIAN
+ {
+ char *snd=ball_ball_snd.data;
+ for(i=0;i<ball_ball_snd.len;i+=2)
diff --git a/games/foobillard/pkg-plist b/games/foobillard/pkg-plist
index 1fd68bc20c97..ee55caf31269 100644
--- a/games/foobillard/pkg-plist
+++ b/games/foobillard/pkg-plist
@@ -1,6 +1,8 @@
bin/foobillard
+share/foobillard/ball_ball.raw
share/foobillard/blende.png
share/foobillard/bluebold.ttf
+share/foobillard/bumpref.png
share/foobillard/cue_shadow.png
share/foobillard/foobillard.gif
share/foobillard/foobillard.png
@@ -9,7 +11,13 @@ share/foobillard/fullhalf_symbol.png
share/foobillard/half_symbol.png
share/foobillard/iomanoid.ttf
share/foobillard/lightflare.png
+share/foobillard/negx.png
+share/foobillard/negy.png
+share/foobillard/negz.png
share/foobillard/place_cue_ball.png
+share/foobillard/posx.png
+share/foobillard/posy.png
+share/foobillard/posz.png
share/foobillard/queue.png
share/foobillard/queue_shadow.png
share/foobillard/shadow2.png