aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-18 11:17:45 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-18 11:17:45 +0000
commit8b3c8800eb286d7ad9ba4d8e56c1f94a436e2ca9 (patch)
tree05eb10cc44d61de9b8f970b16f50e25c5a245d53 /games
parentcf14e8bdd746039cc679bf4d0fc205ba4b95a2fb (diff)
downloadports-8b3c8800eb286d7ad9ba4d8e56c1f94a436e2ca9.tar.gz
ports-8b3c8800eb286d7ad9ba4d8e56c1f94a436e2ca9.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/yamsweeper/Makefile31
-rw-r--r--games/yamsweeper/distinfo2
-rw-r--r--games/yamsweeper/files/Imakefile84
-rw-r--r--games/yamsweeper/files/patch-aa10
-rw-r--r--games/yamsweeper/files/patch-ab11
-rw-r--r--games/yamsweeper/pkg-descr22
-rw-r--r--games/yamsweeper/pkg-plist5
8 files changed, 0 insertions, 166 deletions
diff --git a/games/Makefile b/games/Makefile
index 04fc4b73e3b7..a32ef073a3f3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -1162,7 +1162,6 @@
SUBDIR += xzip
SUBDIR += yadex
SUBDIR += yahtzee
- SUBDIR += yamsweeper
SUBDIR += zangband
SUBDIR += zatacka
SUBDIR += zaz
diff --git a/games/yamsweeper/Makefile b/games/yamsweeper/Makefile
deleted file mode 100644
index 6cb3308668bd..000000000000
--- a/games/yamsweeper/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# Created by: Hidekazu Kuroki <hidekazu@cs.titech.ac.jp>
-# $FreeBSD$
-
-PORTNAME= yamsweeper
-PORTVERSION= 1.9
-PORTREVISION= 3
-CATEGORIES= games
-MASTER_SITES= http://hanzubon.jp/mirrors/Vine/%SUBDIR%/ \
- http://ftp.jaist.ac.jp/pub/Linux/Vine/%SUBDIR%/ \
- http://ftp.riken.go.jp/Linux/vine/%SUBDIR%/ \
- http://ftp.yz.yamagata-u.ac.jp/pub/Linux/Vine/%SUBDIR%/ \
- http://ftp.nara.wide.ad.jp/pub/Linux/vine/%SUBDIR%/ \
- http://ftp.vinelinux.org/pub/Vine/%SUBDIR%/
-MASTER_SITE_SUBDIR= VinePlus/1.1/JG-0.9.1/sources
-EXTRACT_SUFX= .taz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Yet Another Mine Sweeper
-
-DEPRECATED= Unmaintained since 2002
-EXPIRATION_DATE= 2014-04-17
-USES= imake
-USE_XORG= x11 xaw xext xmu xt xpm sm ice
-MAN1= yamsweeper.1
-
-NO_STAGE= yes
-pre-configure:
- @${MV} ${WRKSRC}/Imakefile ${WRKSRC}/Imakefile.old
- @${CP} ${FILESDIR}/Imakefile ${WRKSRC}
-
-.include <bsd.port.mk>
diff --git a/games/yamsweeper/distinfo b/games/yamsweeper/distinfo
deleted file mode 100644
index dc2fbbda65cb..000000000000
--- a/games/yamsweeper/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (yamsweeper-1.9.taz) = 11f4d909afbe85c6c6e3807e04693474b607de252ad2989298e8e8ce0e14c6de
-SIZE (yamsweeper-1.9.taz) = 34260
diff --git a/games/yamsweeper/files/Imakefile b/games/yamsweeper/files/Imakefile
deleted file mode 100644
index f0a3306f4b0d..000000000000
--- a/games/yamsweeper/files/Imakefile
+++ /dev/null
@@ -1,84 +0,0 @@
-#ifndef XCOMM
-#define XCOMM #
-#endif
-
-XCOMM Imakefile src for Yamsweeper, created by hirofumi
-XCOMM
-XCOMM $FreeBSD$
-XCOMM
-
-#include "REVISION"
-
- DEPLIBS = XawClientDepLibs
-LOCAL_LIBRARIES = XawClientLibs
- HEADERS = bmps.h gentype.h struct.h funcs.h highscore.h
- SRCS = version.c main.c win.c bmps.c highscore.c
-OBJS = $(SRCS:.c=.o)
-
-#define cppLogUser 1
-#define cppHighScore 1
-
-YAMSDIR = $(LIBDIR)/yamsweeper
-LOGFILE = $(YAMSDIR)/yams.log
-SCRFILE = $(YAMSDIR)/yams.hi
-OWNER = root
-GROUP = games
-
-DEFINES = '-DLOGFILE="$(LOGFILE)"' -DLOG_USER=cppLogUser \ @@\
- -DHAS_RANDOM=1 -DNO_FD_SET=0 \ @@\
- -DHIGH_SCORE=cppHighScore '-DHIGH_SCORE_FILE="$(SCRFILE)"'
-
-INSTALLDIR= $(BINDIR)
-
-#if cppLogUser || cppHighScore
-
-all:: yamsweeper
-
-#ifdef SetUIDProgramTarget
- /* X11R[56] */
-SetUIDProgramTarget(yamsweeper,$(OBJS),$(DEPLIB),XawClientLibs,)
-#else
- /* X11R4 */
-NormalProgramTarget(yamsweeper,$(OBJS),$(DEPLIB),XawClientLibs,)
-#endif
-
-InstallProgramWithFlags(yamsweeper,$(INSTALLDIR),$(INSTUIDFLAGS))
-InstallManPage(yamsweeper,$(MANDIR))
-
-install::
- chown $(OWNER):$(GROUP) $(BINDIR)/yamsweeper
- chmod 2755 $(BINDIR)/yamsweeper
-
-
-#if cppLogUser
-install::
- MakeDir($(YAMSDIR))
- chown $(OWNER):$(GROUP) $(YAMSDIR)
- touch $(LOGFILE)
- chown $(OWNER):$(GROUP) $(LOGFILE)
- chmod 664 $(LOGFILE)
-#endif /* cppLogUser */
-
-#if cppHighScore
-install::
- MakeDir($(YAMSDIR))
- chown $(OWNER):$(GROUP) $(YAMSDIR)
- touch $(SCRFILE)
- chown $(OWNER):$(GROUP) $(SCRFILE)
- chmod 664 $(SCRFILE)
-#endif
-
-#else /* cppLogUser || cppHighScore */
-
-ComplexProgramTarget(yamsweeper)
-
-#endif
-
-
-InstallAppDefaults(Yamsweeper)
-
-
-
-#include "PACK"
-
-DependTarget()
diff --git a/games/yamsweeper/files/patch-aa b/games/yamsweeper/files/patch-aa
deleted file mode 100644
index 7f7a50e9843b..000000000000
--- a/games/yamsweeper/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- main.c.orig 1994-11-03 09:20:41.000000000 +0900
-+++ main.c 2011-11-26 23:01:07.000000000 +0900
-@@ -23,6 +23,7 @@
- #include <X11/cursorfont.h>
- #include <stdio.h>
- #include <signal.h>
-+#include <stdlib.h>
- #ifndef sun
- #include <time.h>
- #endif
diff --git a/games/yamsweeper/files/patch-ab b/games/yamsweeper/files/patch-ab
deleted file mode 100644
index afce367a8f83..000000000000
--- a/games/yamsweeper/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- highscore.c.orig Wed Nov 2 16:20:40 1994
-+++ highscore.c Thu Apr 27 14:12:23 2000
-@@ -212,7 +212,7 @@
- read_highscore();
- if (atoi((char*)high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].seconds) >= done - start) {
- sprintf(high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].seconds, "%3.3d", done - start);
-- strcpy(high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].uname, getenv(appData.identifier));
-+ strncpy(high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].uname, getenv(appData.identifier), sizeof(high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].uname));
- sprintf(high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].hitime,
- "%0*ld", sizeof high_score_tab[mode].holders[HIGHSCORE_MAX_KEEP - 1].hitime - 1,
- (long)time(NULL));
diff --git a/games/yamsweeper/pkg-descr b/games/yamsweeper/pkg-descr
deleted file mode 100644
index 0cc80ed513da..000000000000
--- a/games/yamsweeper/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-Yamsweeper is a game to clear the field filled with bombs (mines). On the left
-top corner of the main window, the number of mines left is displayed. You can
-mark hidden mines underneath the panels, then the number is decreased. The
-number can be minus, but that means you have over-marked. On the right top
-corner, the time passed is displayed. The time counts up to 999 seconds. On
-center top, there's the symbol of yamsweeper. You can start a new game by
-clicking the symbol. A panel is opened with the left mouse button. If unopened
-panels are around the panel, and if they don't have mines underneath and around
-them, panels are also opened. This can happen like a chain reaction. Be
-careful; the game is over when you open a mine. If the panel opened has mines
-around, you will see a number varies from 1 to 8, which means the number of
-mines. For example, `1' tells you one of the panels around has a mine. `2' says
-that two mines are hidden next to. You can mark suspicious panels by the right
-button, which toggles the state of the panel between "Bomb" or "?" (in which it
-cannot be opened) and Normal. The middle button is assigned a special
-functionality. You can use the middle button to open the unmarked panels
-around, under certain conditions:
-- the panel you clicked is opened
-- the panel is not null, a number is displayed
-- the number of marked panels is equal to the number displayed on the
- clicked panel.
-Click the middle button on a opened panel.
diff --git a/games/yamsweeper/pkg-plist b/games/yamsweeper/pkg-plist
deleted file mode 100644
index 43145e19725a..000000000000
--- a/games/yamsweeper/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/yamsweeper
-lib/X11/yamsweeper/yams.hi
-lib/X11/yamsweeper/yams.log
-lib/X11/app-defaults/Yamsweeper
-@dirrm lib/X11/yamsweeper