aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-05-22 07:36:27 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-05-22 07:36:27 +0000
commit913539a7ed732158d1ceaa5121432de66fd7f754 (patch)
tree0c95129b4c21e459409e70c01a1f5b8ed598b762 /games
parentfe096ba3d130d28de670c64c02fc5b38fb433f59 (diff)
downloadports-913539a7ed732158d1ceaa5121432de66fd7f754.tar.gz
ports-913539a7ed732158d1ceaa5121432de66fd7f754.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/bubble-chains/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/games/bubble-chains/Makefile b/games/bubble-chains/Makefile
index 6cda5ce75848..50b04fc21541 100644
--- a/games/bubble-chains/Makefile
+++ b/games/bubble-chains/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bubble-chains
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://bubble-chains.sintegrial.com/files/
DISTNAME= chains-${DISTVERSION}
@@ -29,10 +29,8 @@ USE_XORG= xrandr
USE_QT_VER= 4
QT_COMPONENTS= moc_build qmake_build rcc_build uic_build iconengines imageformats \
corelib svg xml opengl network
-HAS_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ENV+= UIC="${UIC}" QMAKE="${QMAKE}" QMAKESPEC="${QMAKESPEC}"
-MAKE_ENV+= QMAKESPEC="${QMAKESPEC}"
+
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/bubble-chains \
share/pixmaps/bubble-chains.ico \
@@ -45,8 +43,6 @@ PORTDOCS= README
P7ZIP_CMD= ${LOCALBASE}/bin/7z
P7ZIP_ARGS= x -o${WRKDIR}
-MAKE_JOBS_SAFE= yes
-
do-extract:
@${MKDIR} ${WRKDIR}
@${P7ZIP_CMD} ${P7ZIP_ARGS} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
@@ -57,25 +53,28 @@ post-patch:
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} ${WRKSRC}/Game.pro
+ ${QMAKE} ${QMAKEFLAGS}
do-install:
+# Executable
${INSTALL_PROGRAM} ${WRKSRC}/bin/chains ${PREFIX}/bin/${PORTNAME}
+
+# Pixmaps and Desktop
${INSTALL_DATA} ${WRKSRC}/images/logo.png \
${PREFIX}/share/pixmaps/${PORTNAME}.png
${INSTALL_DATA} ${WRKSRC}/icon.ico \
${PREFIX}/share/pixmaps/${PORTNAME}.ico
+# Data
.if !defined (NOPORTDATA)
${MKDIR} ${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
.endif
+# Documentation
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>