aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2011-02-23 09:35:51 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2011-02-23 09:35:51 +0000
commita71161db8f5db73d7fd6608a190093cff9c7e831 (patch)
tree321b280e2007bec0fdce48a4c9476a7a53eda6cf /games
parentc9cb0b882b0357e3cb57c99df0a372331e77ed94 (diff)
downloadports-a71161db8f5db73d7fd6608a190093cff9c7e831.tar.gz
ports-a71161db8f5db73d7fd6608a190093cff9c7e831.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gnake/Makefile38
-rw-r--r--games/gnake/distinfo2
-rw-r--r--games/gnake/pkg-descr8
4 files changed, 49 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 49eb0889271c..2df647f0a68f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -319,6 +319,7 @@
SUBDIR += gma
SUBDIR += gmastermind
SUBDIR += gmines
+ SUBDIR += gnake
SUBDIR += gnarr
SUBDIR += gnmm
SUBDIR += gno3dtet
diff --git a/games/gnake/Makefile b/games/gnake/Makefile
new file mode 100644
index 000000000000..546a1dc82134
--- /dev/null
+++ b/games/gnake/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: gnake
+# Date created: 2011/02/20
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnake
+PORTVERSION= 0.94b
+CATEGORIES= games
+MASTER_SITES= LOCAL/chinsan \
+ http://lightless.org/files/
+DISTNAME= Gnake.${PORTVERSION}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A Nibbles clone for GNU/Linux and *BSD
+
+LICENSE= GPLv2
+LDFLAGS+= -L${LOCALBASE}/lib -lncurses
+CFLAGS+= -Wall
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
+ ${WRKSRC}/gnake.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gnake/distinfo b/games/gnake/distinfo
new file mode 100644
index 000000000000..72c975bff060
--- /dev/null
+++ b/games/gnake/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Gnake.0.94b.tar.gz) = 0a969e09f2dd60cdad56174728f13e4bf6056173f2d566312e06935e13b3d827
+SIZE (Gnake.0.94b.tar.gz) = 6656
diff --git a/games/gnake/pkg-descr b/games/gnake/pkg-descr
new file mode 100644
index 000000000000..5cb17dd9f20c
--- /dev/null
+++ b/games/gnake/pkg-descr
@@ -0,0 +1,8 @@
+Gnake is a Nibbles clone for GNU/Linux and *BSD.
+It's played on a terminal (controlled by the curses library) with the
+keyboard: the game is really simple and that's why I like playing it even in
+the oh-my-god-my-graphics-card-costs-more-than-the-rest-of-the-computer era.
+
+For the list of available options, type ``gnake -h''.
+
+WWW: http://lightless.org/gnake/