aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-10 22:15:35 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-10 22:15:35 +0000
commitc3c97af09b4e528cf68b5e02246cd17782ae8cca (patch)
tree05205fac619a515f646fbee4d1d528594b61dfaf /games
parent80e073da543edb5917a95ad54005a8964154e9c2 (diff)
downloadports-c3c97af09b4e528cf68b5e02246cd17782ae8cca.tar.gz
ports-c3c97af09b4e528cf68b5e02246cd17782ae8cca.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/nsnake/Makefile28
-rw-r--r--games/nsnake/distinfo2
-rw-r--r--games/nsnake/files/patch-Makefile11
-rw-r--r--games/nsnake/pkg-descr6
5 files changed, 48 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2df647f0a68f..95b890a93d28 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -593,6 +593,7 @@
SUBDIR += noegnud-slashem
SUBDIR += nonsense
SUBDIR += npush
+ SUBDIR += nsnake
SUBDIR += nuclearchess
SUBDIR += numptyphysics
SUBDIR += numptyphysics-npcomplete
diff --git a/games/nsnake/Makefile b/games/nsnake/Makefile
new file mode 100644
index 000000000000..5177c90cf226
--- /dev/null
+++ b/games/nsnake/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: nsnake
+# Date created: 08 March 2011
+# Whom: markand
+#
+# $FreeBSD$
+#
+
+PORTNAME= nsnake
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://softs.malikania.fr/releases/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= markand@malikania.fr
+COMMENT= A snake game written in C and ncurses
+
+MAN6= nsnake.6
+PLIST_FILES= bin/nsnake
+PORTDOCS= LICENSE
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
+
diff --git a/games/nsnake/distinfo b/games/nsnake/distinfo
new file mode 100644
index 000000000000..642b118bf849
--- /dev/null
+++ b/games/nsnake/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nsnake-1.0.1.tgz) = 2fe356057fe40707766c1b1155ff82069af24f0c3162bca406e04f58ac243887
+SIZE (nsnake-1.0.1.tgz) = 5644
diff --git a/games/nsnake/files/patch-Makefile b/games/nsnake/files/patch-Makefile
new file mode 100644
index 000000000000..09834dd878ea
--- /dev/null
+++ b/games/nsnake/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2011-03-08 18:04:22.000000000 +0100
++++ Makefile 2011-03-08 18:04:41.000000000 +0100
+@@ -27,7 +27,7 @@
+ INSTALL= install
+ PREFIX= /usr/local
+ VARBASE= /var
+-MANPREFIX= /share/man
++MANPREFIX= /man
+ RM= rm -f
+
+ all: ${PROG}
diff --git a/games/nsnake/pkg-descr b/games/nsnake/pkg-descr
new file mode 100644
index 000000000000..16b5fbabc11d
--- /dev/null
+++ b/games/nsnake/pkg-descr
@@ -0,0 +1,6 @@
+nsnake is small game written in C and using ncurses API for drawing stuff on the
+screen.
+
+It currently supports colors and can save highscores in a file.
+
+WWW: http://softs.malikania.fr/nsnake