aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-02-11 12:33:55 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-02-11 12:33:55 +0000
commitc768a3f3db9e651690af3eb417bc262adc06da57 (patch)
treef53f4dfa0382e9032c18c3927483fc657659db99 /games
parent892a534e39412e694275d1073a19bd942f1a851d (diff)
downloadports-c768a3f3db9e651690af3eb417bc262adc06da57.tar.gz
ports-c768a3f3db9e651690af3eb417bc262adc06da57.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/xboard/Makefile17
-rw-r--r--games/xboard/distinfo5
-rw-r--r--games/xboard/pkg-plist13
3 files changed, 23 insertions, 12 deletions
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index 3dad970a5c7d..050abce18ee6 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xboard
-PORTVERSION= 4.4.4
+PORTVERSION= 4.5.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= xboard
@@ -18,7 +18,8 @@ OPTIONS= XAW3D "Use Xaw3d widgets (instead of Xaw)" On
USE_XORG= xt xpm xaw
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ MKDIR_P="${MKDIR}"
MAN6= xboard.6
INFO= xboard
USE_PERL5_BUILD=yes
@@ -34,13 +35,19 @@ LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= Does not install on sparc64
+BROKEN= Does not install on sparc64
.endif
post-patch:
- @${REINPLACE_CMD} -e 's/fairymax/gnuchessx/' ${WRKSRC}/xboard.h
+ @${REINPLACE_CMD} -e 's/fairymax/gnuchessx/' \
+ ${WRKSRC}/xboard.h ${WRKSRC}/xboard.conf.in
+ @${REINPLACE_CMD} -e '/^#include..malloc.h/d' \
+ ${WRKSRC}/engineoutput.c ${WRKSRC}/uci.c
+ @${REINPLACE_CMD} -e 's:INSTALL.*sysconfdir):&/$$$$files.dist:' \
+ ${WRKSRC}/Makefile.in
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/cmail ${PREFIX}/bin/
+ @${INSTALL_SCRIPT} ${WRKSRC}/cmail ${PREFIX}/bin/
+ @${CP} -pn ${PREFIX}/etc/xboard.conf.dist ${PREFIX}/etc/xboard.conf
.include <bsd.port.post.mk>
diff --git a/games/xboard/distinfo b/games/xboard/distinfo
index 5d6a5170910c..10811afdc947 100644
--- a/games/xboard/distinfo
+++ b/games/xboard/distinfo
@@ -1,3 +1,2 @@
-MD5 (xboard-4.4.4.tar.gz) = 06a2d921650718ea272e7c0ec957dccc
-SHA256 (xboard-4.4.4.tar.gz) = 33297c170fca99d10b53ba8f6bebdfa65ac69c918358299e96156456f2b4d5a9
-SIZE (xboard-4.4.4.tar.gz) = 1992091
+SHA256 (xboard-4.5.0.tar.gz) = fc70a435de177861bd0f0eced921c248f24e854b09a7ea9dbfacf27d076e8815
+SIZE (xboard-4.5.0.tar.gz) = 2336119
diff --git a/games/xboard/pkg-plist b/games/xboard/pkg-plist
index 9ffd921b5d8c..5a9ebc223064 100644
--- a/games/xboard/pkg-plist
+++ b/games/xboard/pkg-plist
@@ -2,13 +2,18 @@ bin/xboard
bin/cmail
share/icons/hicolor/48x48/apps/xboard.png
share/icons/hicolor/scalable/apps/xboard.svg
+share/applications/xboard.desktop
+share/games/xboard/wood_d.xpm
+share/games/xboard/wood_l.xpm
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrmtry share
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-@dirrmtry share
+@dirrmtry share/applications
+@dirrmtry share/games/xboard
+@dirrmtry share/games
+@unexec if cmp -s %D/etc/xboard.conf.dist %D/etc/xboard.conf; then rm -f %D/etc/xboard.conf; fi
+etc/xboard.conf.dist
+@exec cp -pn %D/%F %B/orbit.conf