aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-12 21:07:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-12 21:07:11 +0000
commite4550385b3689a3aa43d86171a86b6719fee9d59 (patch)
treeb6eb529eb0baf10de992bb765c545001dfd181f9 /games
parentcdb45f517bf5956fea04bbe26b40421f8f54e4a2 (diff)
[PATCH] games/quake3: prevent quake from creating botlib.log in the current dir
quake3 creates botlib.log in the current directory. Such action is annoying and should be prevented. PR: ports/90263 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=151051
Diffstat (limited to 'games')
-rw-r--r--games/q3cellshading/Makefile1
-rw-r--r--games/quake3/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 24b9abdefe07..8fa5ce2be241 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -45,6 +45,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-
post-patch:
@${REINPLACE_CMD} -e 's|%%Q3DIR%%|"${Q3DIR}"|' \
${WRKSRC}/code/unix/unix_shared.c
+ @${REINPLACE_CMD} -e 's|botlib.log|/dev/null|' ${WRKSRC}/code/botlib/be_interface.c
pre-build:
${MKDIR} ${WRKSRC}/lcc/build
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 24b9abdefe07..8fa5ce2be241 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -45,6 +45,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-
post-patch:
@${REINPLACE_CMD} -e 's|%%Q3DIR%%|"${Q3DIR}"|' \
${WRKSRC}/code/unix/unix_shared.c
+ @${REINPLACE_CMD} -e 's|botlib.log|/dev/null|' ${WRKSRC}/code/botlib/be_interface.c
pre-build:
${MKDIR} ${WRKSRC}/lcc/build