aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-07 18:06:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-07 18:06:21 +0000
commit7746b4c6fb3ef37fefbb68efdaf2630e98ded3c2 (patch)
treebb20d833a1ff34c0021ac76809be82d6f1169bb1 /games
parente866ea4c99109feee1f5492da3ea97a3ad2544ca (diff)
downloadports-7746b4c6fb3ef37fefbb68efdaf2630e98ded3c2.tar.gz
ports-7746b4c6fb3ef37fefbb68efdaf2630e98ded3c2.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/hedgewars/Makefile3
-rw-r--r--games/meritous/Makefile5
-rw-r--r--games/openlierox/Makefile3
-rw-r--r--games/openmortal/Makefile5
-rw-r--r--games/osgg/Makefile2
-rw-r--r--games/peg-e/Makefile3
-rw-r--r--games/reminiscence/Makefile3
-rw-r--r--games/ri-li/Makefile3
-rw-r--r--games/sdl-ball/Makefile9
-rw-r--r--games/simplevaders/Makefile2
-rw-r--r--games/tomatoes/Makefile3
-rw-r--r--games/vor/Makefile7
-rw-r--r--games/xorgramana/Makefile5
-rw-r--r--games/zaz/Makefile3
14 files changed, 17 insertions, 39 deletions
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index 197454a09039..559c8b3a67dc 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -18,8 +18,7 @@ LICENSE_COMB= multi
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= depends on fpc which is only available for i386 and amd64
-USE_BZIP2= yes
-USES= cmake
+USES= tar:bzip2 cmake
USE_SDL= sdl mixer image ttf net
USE_FPC= opengl libpng
USE_LUA= 5.1+
diff --git a/games/meritous/Makefile b/games/meritous/Makefile
index 8f779ff2deb6..cba5b4481600 100644
--- a/games/meritous/Makefile
+++ b/games/meritous/Makefile
@@ -14,11 +14,10 @@ COMMENT= Action-adventure dungeon crawl game
LICENSE= GPLv3
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 dos2unix gmake
USE_SDL= sdl mixer image
ALL_TARGET= default
-USE_DOS2UNIX= dat/d/helpfile.txt src/*.c
+DOS2UNIX_FILES= dat/d/helpfile.txt src/boss.c src/levelblit.c
PLIST_FILES= bin/${PORTNAME}
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 7c0debb20815..536cc533b2cb 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libcurl.so:${PORTSDIR}/ftp/curl \
libalut.so:${PORTSDIR}/audio/freealut
-USE_BZIP2= yes
+USES= tar:bzip2 cmake openal pkgconfig
USE_SDL= sdl image
USE_GNOME= libxml2
USE_GCC= any # too many gcc'isms
@@ -26,7 +26,6 @@ CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= cmake openal pkgconfig
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index aba0c45fd3c4..b626fa5915c9 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -12,11 +12,10 @@ COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USE_BZIP2= yes
+USES= tar:bzip2 dos2unix perl5
GNU_CONFIGURE= yes
-USES= perl5
USE_SDL= mixer image sdl net
-USE_DOS2UNIX= src/gfx.cpp
+DOS2UNIX_FILES= src/gfx.cpp
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
diff --git a/games/osgg/Makefile b/games/osgg/Makefile
index ed1f5774a3dc..1433b3312ae1 100644
--- a/games/osgg/Makefile
+++ b/games/osgg/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OldSkool Gravity Game
-USE_BZIP2= yes
+USES= tar:bzip2
USE_SDL= sdl image ttf mixer
USE_GL= yes
diff --git a/games/peg-e/Makefile b/games/peg-e/Makefile
index 65c3fb19925b..14f31cea9de1 100644
--- a/games/peg-e/Makefile
+++ b/games/peg-e/Makefile
@@ -11,8 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Peg elimination game
-USES= qmake
-USE_BZIP2= yes
+USES= tar:bzip2 qmake
USE_QT4= corelib gui moc_build rcc_build
INSTALLS_ICONS= yes
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index 58a5920eb3d6..4d24ed57115f 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -11,8 +11,7 @@ MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A rewritten engine for Flashback
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
USE_SDL= sdl
ALL_TARGET= rs
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index 4e3936fab8b5..9ea29449bea7 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}%20Linux_Unix/${PORTNAME}%20V${PORTVE
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Drive a toy wood train in many levels - snake-like arcade game
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
-USES= gmake
USE_SDL= sdl mixer
CPPFLAGS+= `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
diff --git a/games/sdl-ball/Makefile b/games/sdl-ball/Makefile
index fee67e928661..73322ac078c7 100644
--- a/games/sdl-ball/Makefile
+++ b/games/sdl-ball/Makefile
@@ -13,12 +13,11 @@ COMMENT= Arkanoid/Breakout clone with pretty graphics
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= gmake
-USE_BZIP2= yes
+USES= tar:bzip2 dos2unix gmake
USE_SDL= sdl mixer image ttf
USE_GL= gl glu
MAKE_ENV= DATADIR=${DATADIR}/
-USE_DOS2UNIX= main.cpp
+DOS2UNIX_FILES= main.cpp
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -28,8 +27,6 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-build:
cd ${WRKSRC} && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --cflags --libs` \
-lGL -lGLU -lSDL_image -lSDL_ttf -lSDL_mixer \
@@ -39,9 +36,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/themes && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/games/simplevaders/Makefile b/games/simplevaders/Makefile
index 96ea3762507e..e71f234a5f2f 100644
--- a/games/simplevaders/Makefile
+++ b/games/simplevaders/Makefile
@@ -13,7 +13,7 @@ COMMENT= A Space-Invaders like 2D space shooter
LICENSE= GPLv3
-USE_BZIP2= yes
+USES= tar:bzip2
USE_SDL= sdl mixer image ttf
USE_GL= gl glu
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index 355e8563e917..6cdb2e173474 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -15,10 +15,9 @@ COMMENT= Tomato-smashing, Q-Bert style
WRKSRC= ${WRKDIR}/tomatoes-${PORTVERSION}5
TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
USE_SDL= mixer image
USE_GL= gl
-USES= gmake
MAKEFILE= makefile
MAKE_ARGS= CC="${CXX}" \
MPKDIR="${DATADIR}/" \
diff --git a/games/vor/Makefile b/games/vor/Makefile
index 942d368acc80..1b85006ade20 100644
--- a/games/vor/Makefile
+++ b/games/vor/Makefile
@@ -11,9 +11,8 @@ MASTER_SITES= http://qualdan.com/vor/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Dodge the rocks until you die
-USES= gmake
+USES= tar:bzip2 gmake
USE_SDL= mixer image sdl
-USE_BZIP2= yes
GNU_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME}
@@ -29,12 +28,8 @@ DESKTOP_ENTRIES="Variations on Rockdodger" \
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/games/xorgramana/Makefile b/games/xorgramana/Makefile
index 47d07f1fa042..000297c5f5b2 100644
--- a/games/xorgramana/Makefile
+++ b/games/xorgramana/Makefile
@@ -12,8 +12,7 @@ DISTNAME= XorGramana-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Logic word puzzle game set inside a series of mazes
-USE_BZIP2= yes
-USES= gmake
+USES= tar:bzip2 gmake
USE_SDL= sdl image
USE_GL= glu
@@ -30,8 +29,6 @@ DESKTOP_ENTRIES="XorGramana" \
"Game;LogicGame;" \
false
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|GFX/|${DATADIR}/&|' ${WRKSRC}/icons.c
diff --git a/games/zaz/Makefile b/games/zaz/Makefile
index 6c849ef718d1..8a7e1a9f4eac 100644
--- a/games/zaz/Makefile
+++ b/games/zaz/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libftgl.so:${PORTSDIR}/graphics/ftgl
-USE_BZIP2= yes
+USES= tar:bzip2 pkgconfig
GNU_CONFIGURE= yes
-USES= pkgconfig
USE_SDL= sdl image
USE_GL= gl glu