aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
commita3c56e68df3a7bf6713f80ab7c2e99f961e98a80 (patch)
tree831a3c893bea5650066440c5b2854bd428d2cc44 /games
parent680550419d6ab5747243411408ef3f63ee7d4b77 (diff)
downloadports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.tar.gz
ports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/assaultcube/Makefile1
-rw-r--r--games/bloodfrontier/Makefile1
-rw-r--r--games/cube/Makefile1
-rw-r--r--games/fillets-ng/Makefile1
-rw-r--r--games/freeminer/Makefile1
-rw-r--r--games/gemrb/Makefile1
-rw-r--r--games/kobodeluxe/Makefile1
-rw-r--r--games/minetest/Makefile2
-rw-r--r--games/powder-toy/Makefile1
-rw-r--r--games/quakeforge/Makefile3
-rw-r--r--games/redeclipse/Makefile2
-rw-r--r--games/sauerbraten/Makefile1
-rw-r--r--games/stonesoup/Makefile2
-rw-r--r--games/teeworlds/Makefile2
-rw-r--r--games/tesseract/Makefile1
-rw-r--r--games/xbill/Makefile1
-rw-r--r--games/xpilot-ng-server/Makefile2
-rw-r--r--games/zangband/Makefile1
18 files changed, 20 insertions, 5 deletions
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 33eb034d2ff6..9f3a15d01a22 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -40,6 +40,7 @@ OPTIONS_DEFAULT= CLIENT DEDICATED
CLIENT_DESC= Build client
CLIENT_USES= gettext-runtime openal:al
+CLIENT_USES= gl xorg
CLIENT_USE= GL=gl SDL=image,sdl XORG=x11
CLIENT_LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libcurl.so:ftp/curl
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index a831b310ec1c..0eed8aee072c 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -37,6 +37,7 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
+CLIENT_USES= gl sdl xorg
CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/bfclient libexec/bfclient \
diff --git a/games/cube/Makefile b/games/cube/Makefile
index 55c5e7837be2..a9df40fe4801 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -34,6 +34,7 @@ OPTIONS_SUB= yes
FLAVOR_DESC= Clients and servers
CLIENT_DESC= Build client
+CLIENT_USES= gl xorg
CLIENT_USE= GL=gl,glu SDL=image,mixer,sdl XORG=x11
CLIENT_LDFLAGS= -lX11
CLIENT_ALL_TARGET= client
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index 2c537cd3a1be..414132aea052 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -46,6 +46,7 @@ FRIBIDI_LIB_DEPENDS= libfribidi.so:converters/fribidi
SMPEG_DESC= Video playback support
SMPEG_LIB_DEPENDS= libsmpeg.so:multimedia/smpeg
X11_DESC= X11 window manager support
+X11_USES= xorg
X11_USE= xorg=x11
X11_CONFIGURE_ON= --with-X=yes
X11_CONFIGURE_OFF= --with-X=no
diff --git a/games/freeminer/Makefile b/games/freeminer/Makefile
index 94ce89d6e4df..60cec5996b2d 100644
--- a/games/freeminer/Makefile
+++ b/games/freeminer/Makefile
@@ -44,6 +44,7 @@ CLIENT_CMAKE_OFF= -DBUILD_CLIENT=0
CLIENT_LIB_DEPENDS= libpng.so:graphics/png \
libIrrlicht.so:x11-toolkits/irrlicht
CLIENT_USES= jpeg
+CLIENT_USES= gl xorg
CLIENT_USE= GL=gl XORG=x11
SERVER_CMAKE_ON= -DBUILD_SERVER=1
SERVER_CMAKE_OFF= -DBUILD_SERVER=0
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index 6fc558fda8f3..86b86ed29a7d 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
OPTIONS_DEFINE= DOCS OPENGL
OPTIONS_SUB= yes
+OPENGL_USES= gl
OPENGL_USE= gl=gl,glu,glew
OPENGL_CMAKE_ON=-DOPENGL_BACKEND=OpenGL
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 0da1577bce3e..22c014360a4f 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -30,6 +30,7 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS OPENGL
OPTIONS_DEFAULT=OPENGL
+OPENGL_USES= gl
OPENGL_USE= GL=gl
OPENGL_CONFIGURE_ENABLE= opengl
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index aca2c52bef78..f1ff80de5090 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -45,7 +45,7 @@ CLIENT_DESC= Build client
CLIENT_CMAKE_BOOL= BUILD_CLIENT
CLIENT_LIB_DEPENDS= libpng.so:graphics/png \
libIrrlicht.so:x11-toolkits/irrlicht
-CLIENT_USES= gl jpeg
+CLIENT_USES= gl jpeg xorg
CLIENT_USE= GL=gl XORG=x11,xext,xxf86vm
SERVER_DESC= Build server
SERVER_CMAKE_BOOL= BUILD_SERVER
diff --git a/games/powder-toy/Makefile b/games/powder-toy/Makefile
index 01438e708d05..b34c213ee1d0 100644
--- a/games/powder-toy/Makefile
+++ b/games/powder-toy/Makefile
@@ -38,6 +38,7 @@ SSE_MAKE_ARGS_OFF= --no-sse
SSE3_DESC= Enable SSE3 optimizations
SSE3_MAKE_ARGS= --sse3
SSE3_IMPLIES= SSE
+OPENGL_USES= gl
OPENGL_USE= GL=gl,glu,glew
OPENGL_MAKE_ARGS= --opengl --opengl-renderer
OPENGL_BROKEN= Application dies with SIGBUS at startup
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 0e010fa8ec3a..705d69ae2aff 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -48,6 +48,7 @@ CLIENTS_BUILD_DEPENDS= icotool:graphics/icoutils
CLIENTS_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libcurl.so:ftp/curl
CLIENTS_USES= pkgconfig
+CLIENTS_USES= gl xorg
CLIENTS_USE= gl=glu xorg=xext
CLIENTS_CONFIGURE_OFF= --with-clients=""
CLIENTS_VERS= INSTALLS_ICONS=yes
@@ -76,10 +77,12 @@ VORBIS_CONFIGURE_ON= --with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
VORBIS_CONFIGURE_OFF= --disable-vorbis
VORBIS_IMPLIES= CLIENTS
XXF86DGA_DESC= XFree86 DGA Extension support
+XXF86DGA_USES= xorg
XXF86DGA_USE= xorg=xxf86dga
XXF86DGA_CONFIGURE_OFF= --disable-dga
XXF86DGA_IMPLIES= CLIENTS
XXF86VM_DESC= XFree86 Vidmode Extension support
+XXF86VM_USES= xorg
XXF86VM_USE= xorg=xxf86vm
XXF86VM_CONFIGURE_OFF= --disable-vidmode
XXF86VM_IMPLIES= CLIENTS
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index fde193763244..133107819948 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -35,7 +35,7 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
-CLIENT_USES= gl sdl
+CLIENT_USES= gl sdl xorg
CLIENT_USE= GL=gl SDL=image2,mixer2,sdl2 XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME} \
diff --git a/games/sauerbraten/Makefile b/games/sauerbraten/Makefile
index 0b912d83a324..d399a5e10418 100644
--- a/games/sauerbraten/Makefile
+++ b/games/sauerbraten/Makefile
@@ -36,6 +36,7 @@ SUB_FILES= pkg-message ${PLIST_FILES:Mbin/*:T}
OPTIONS_DEFINE= DOCS
CLIENT_DESC= Build client
+CLIENT_USES= gl xorg
CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/sauer_client libexec/sauer_client
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index e55b6df8aa22..c3457c09660e 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -63,7 +63,7 @@ LUA_DESC= Bindings for LUA user scripts
SDL_CONFLICTS= ${PORTNAME}-[0-9]*
SDL_USE= sdl=sdl2,image2,mixer2 gl=gl,glu
-SDL_USES= gl
+SDL_USES= gl sdl
SDL_USES_OFF= ncurses
SDL_MAKE_ARGS= TILES=y SOUND=y
SDL_BUILD_DEPENDS= \
diff --git a/games/teeworlds/Makefile b/games/teeworlds/Makefile
index 6641bf496d15..239d1d1a590d 100644
--- a/games/teeworlds/Makefile
+++ b/games/teeworlds/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFAULT= CLIENT TEST
CLIENT_DESC= Build game client
CLIENT_CMAKE_BOOL= CLIENT
-CLIENT_USES= gl sdl
+CLIENT_USES= gl sdl xorg
CLIENT_USE= GL=gl,glu XORG=x11 SDL=sdl2
CLIENT_LIB_DEPENDS= libfreetype.so:print/freetype2 \
libwavpack.so:audio/wavpack \
diff --git a/games/tesseract/Makefile b/games/tesseract/Makefile
index a9870b51e398..b62d79aebccc 100644
--- a/games/tesseract/Makefile
+++ b/games/tesseract/Makefile
@@ -31,6 +31,7 @@ OPTIONS_MULTI= FLAVOR
OPTIONS_MULTI_FLAVOR=CLIENT DEDICATED MASTER
CLIENT_DESC= Build client
+CLIENT_USES= gl xorg
CLIENT_USE= GL=gl SDL=image2,mixer2 XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/tess_client libexec/tess_client
diff --git a/games/xbill/Makefile b/games/xbill/Makefile
index 5954621a40dc..62827bf576a7 100644
--- a/games/xbill/Makefile
+++ b/games/xbill/Makefile
@@ -38,6 +38,7 @@ ATHENA_DESC= Athena widget set
MOTIF_DESC= Motif widget set
ATHENA_CONFIGURE_ON= --disable-motif
+ATHENA_USES= xorg
ATHENA_USE= xorg=xaw,xmu
MOTIF_CONFIGURE_ON= --disable-athena
diff --git a/games/xpilot-ng-server/Makefile b/games/xpilot-ng-server/Makefile
index 0217531ab5aa..e1525cac2a0a 100644
--- a/games/xpilot-ng-server/Makefile
+++ b/games/xpilot-ng-server/Makefile
@@ -51,7 +51,7 @@ SOUND_USES= openal:al,alut
SDL_CONFIGURE_ENABLE= sdl-client
SDL_USE= SDL=image,sdl,ttf GL=gl
-SDL_USES= gl
+SDL_USES= gl sdl
.endif
.include <bsd.port.options.mk>
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 01e3998666e8..9f851bab29d5 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -36,6 +36,7 @@ TK_CONFIGURE_ON= --with-tcltk=${TCL_INCLUDEDIR} \
--with-tkdir=${TK_INCLUDEDIR}
TK_CONFIGURE_OFF= --with-tcltk=no
TK_LDFLAGS= -lX11 -lXext
+X11_USES= xorg
X11_USE= xorg=x11,xmu,xpm
X11_CONFIGURE_ENV= ac_cv_lib_Xm_main=no
X11_CONFIGURE_OFF= --with-x11=no