aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-05-07 08:31:52 +0000
committerRene Ladan <rene@FreeBSD.org>2013-05-07 08:31:52 +0000
commitc84102f49b42e75fb9108ac791209fc843e16e9a (patch)
treee48eb0c296cda2c3d06f48c5425fbe507f26b4c6 /games
parent69f460782ecf48664eb093d81191a13ec4fa44a5 (diff)
downloadports-c84102f49b42e75fb9108ac791209fc843e16e9a.tar.gz
ports-c84102f49b42e75fb9108ac791209fc843e16e9a.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/torcs/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index c281526eb71d..427ad4190447 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
vorbis:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+USES= shebangfix
+SHEBANG_FILES= src/linux/torcs.in src/tools/accc/accc.in \
+ src/tools/nfsperf/nfsperf.in \
+ src/tools/texmapper/texmapper.in src/tools/nfs2ac/nfs2ac.in \
+ src/tools/trackgen/trackgen.in \
+ src/modules/telemetry/telemetry.sh robotgen Make-default.mk
USE_XORG= xrender xmu ice xext x11 xxf86vm xrandr
USE_GL= glut
USE_OPENAL= al alut
@@ -26,7 +32,6 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-REINPLACE_ARGS= -i ""
CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
@@ -40,12 +45,6 @@ INSTDIR= ${PREFIX}/share/games/${PORTNAME}
PORTDOCS= faq.html
-BASH2FIX= src/linux/torcs.in src/tools/accc/accc.in \
- src/tools/nfsperf/nfsperf.in \
- src/tools/texmapper/texmapper.in src/tools/nfs2ac/nfs2ac.in \
- src/tools/trackgen/trackgen.in \
- src/modules/telemetry/telemetry.sh robotgen Make-default.mk
-
DESKTOP_ENTRIES= "TORCS" \
"The Open Racing Car Simulator" \
"${INSTDIR}/Ticon.png" \
@@ -59,12 +58,6 @@ OPTIONS_DEFINE= DOCS
EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
-post-patch:
-.for FILE in ${BASH2FIX}
- @${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
- ${WRKSRC}/${FILE}
-.endfor
-
pre-install:
@${MKDIR} ${PREFIX}/share/games