aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 12:49:57 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 12:49:57 +0000
commitc8a8b04b8e249c083726a2cddd8c43edf35439c7 (patch)
treecdd5b6587302848cb4b2e98b8fc8f7856341f64e /games
parentd0341951c50ec683f54def1e593ce631e6ddc83b (diff)
downloadports-c8a8b04b8e249c083726a2cddd8c43edf35439c7.tar.gz
ports-c8a8b04b8e249c083726a2cddd8c43edf35439c7.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/opensurge/Makefile29
-rw-r--r--games/opensurge/Makefile.svn_rev2
-rw-r--r--games/opensurge/files/pkg-deinstall.in18
-rw-r--r--games/opensurge/files/pkg-message.in12
4 files changed, 14 insertions, 47 deletions
diff --git a/games/opensurge/Makefile b/games/opensurge/Makefile
index cbb653ad4d9e..f2bf91d3e65f 100644
--- a/games/opensurge/Makefile
+++ b/games/opensurge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opensurge
PORTVERSION= 0.1.r${SVN_REV}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://www.ime.usp.br/~alemart/opensurge_nightly/ \
SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
@@ -18,34 +18,32 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv2+ = ${WRKSRC}/licenses/GPLv2.txt
LICENSE_FILE_CC-BY-SA-3.0= ${WRKSRC}/licenses/CC-BY-SA-3.0.txt
-BUILD_DEPENDS= ${LOCALBASE}/lib/libaldmb.a:audio/dumb-allegro \
- ${LOCALBASE}/include/alfont.h:x11-fonts/alfont \
- alureplay:audio/alure
+BUILD_DEPENDS= ${LOCALBASE}/lib/libaldmb.a:audio/dumb-allegro
LIB_DEPENDS= libalfont.so:x11-fonts/alfont \
liballeg.so:devel/allegro \
+ libalure.so:audio/alure \
+ libpng.so:graphics/png \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
-RUN_DEPENDS= ${LOCALBASE}/lib/libaldmb.a:audio/dumb-allegro
WRKSRC= ${WRKDIR}/${PORTNAME}-src-build${SVN_REV}
-USES= cmake dos2unix openal:soft
+USES= cmake dos2unix localbase openal:soft
DOS2UNIX_GLOB= *.bg *.brk *.grp *.inc *.lev *.lng *.obj *.qst *.spr *.txt
-USE_GCC= yes
PORTDOCS= readme.html
PORTDATA= *
OPTIONS_DEFINE= DOCS
-SUB_FILES= ${PORTNAME} pkg-deinstall pkg-message
-
-INSTALLS_ICONS= yes
-ICON_SIZES= 16x16 32x32 48x48 64x64 72x72 96x96 128x128 256x256
+SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Open Surge" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
+INSTALLS_ICONS= yes
+LLD_UNSAFE= yes
-.include "Makefile.svn_rev"
+SVN_REV= 765
+MODS_VER= 20140321
post-extract-script:
@(cd ${WRKDIR}/opensurge-mods && ${COPYTREE_SHARE} . ${WRKSRC})
@@ -68,15 +66,16 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
-.for s in ${ICON_SIZES}
+.for s in 16x16 32x32 48x48 64x64 72x72 96x96 128x128 256x256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKSRC}/src/misc/${PORTNAME}_${s}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${RLN} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/opensurge/Makefile.svn_rev b/games/opensurge/Makefile.svn_rev
deleted file mode 100644
index 0872e2e26398..000000000000
--- a/games/opensurge/Makefile.svn_rev
+++ /dev/null
@@ -1,2 +0,0 @@
-SVN_REV= 765
-MODS_VER= 20140321
diff --git a/games/opensurge/files/pkg-deinstall.in b/games/opensurge/files/pkg-deinstall.in
deleted file mode 100644
index 4b297e3acd1f..000000000000
--- a/games/opensurge/files/pkg-deinstall.in
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-if [ "$2" = "POST-DEINSTALL" ]; then
- echo ""
- echo ""
- echo "==============================================================================="
- echo ""
- echo "After deinstallation, some files may stay in %%DATADIR%%,"
- echo "you can delete them with"
- echo ""
- echo " /bin/rm -fr %%DATADIR%%"
- echo ""
- echo "==============================================================================="
- echo ""
-fi
diff --git a/games/opensurge/files/pkg-message.in b/games/opensurge/files/pkg-message.in
deleted file mode 100644
index dfabd7a033ea..000000000000
--- a/games/opensurge/files/pkg-message.in
+++ /dev/null
@@ -1,12 +0,0 @@
-===============================================================================
-
-Open Surge has been installed.
-
-When you have problems to build Source please reinstall
-
-audio/alure
-x11-fonts/alfont
-
-Have fun!
-
-===============================================================================