aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-08-31 07:33:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-08-31 07:33:46 +0000
commitda163a6f82cf5018c3b2bf4a062ed51d6d6e4ae7 (patch)
tree904151e6c2ae16173f281a2ea1a008954ed337b3 /games
parenta0b920fe5c602df9a6f0716073f9f00e69e91ab4 (diff)
downloadports-da163a6f82cf5018c3b2bf4a062ed51d6d6e4ae7.tar.gz
ports-da163a6f82cf5018c3b2bf4a062ed51d6d6e4ae7.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/fuhquake/Makefile20
-rw-r--r--games/fuhquake/distinfo2
-rw-r--r--games/fuhquake/pkg-plist1
3 files changed, 22 insertions, 1 deletions
diff --git a/games/fuhquake/Makefile b/games/fuhquake/Makefile
index a486251268fa..067fd00e58b3 100644
--- a/games/fuhquake/Makefile
+++ b/games/fuhquake/Makefile
@@ -7,9 +7,13 @@
PORTNAME= fuhquake
PORTVERSION= 0.31
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.fuhquake.net/files/releases/v${PORTVERSION}/:q \
+ http://www.fuhquake.net/files/extras/:s \
ftp://gibbage.mine.nu/clients/fuhquake/releases/v${PORTVERSION}/:q \
+ http://gamefiles.blueyonder.co.uk/blueyondergames/quake/quakeworld/clients/fuhquake/source/:q \
+ http://gamefiles.blueyonder.co.uk/blueyondergames/quake/quakeworld/clients/fuhquake/addons/:s \
http://danfe.machos.ru/distfiles/qw/:p \
http://freebsd.nsu.ru/distfiles/qw/:p
DISTNAME= ${PORTNAME}-source-v${PORTVERSION}
@@ -30,6 +34,14 @@ PLIST_SUB+= SHAREWARE=""
PLIST_SUB+= SHAREWARE="@comment "
.endif
+.if defined(WITH_SKYBOXES)
+DISTFILES+= ${PORTNAME}-skyboxes${EXTRACT_SUFX}:s
+EXTRACT_ONLY+= ${PORTNAME}-skyboxes${EXTRACT_SUFX}
+PLIST_SUB+= SKYBOXES=""
+.else
+PLIST_SUB+= SKYBOXES="@comment "
+.endif
+
.if exists(${LOCALBASE}/lib/libvga.so.1)
WITH_SVGA= yes
.endif
@@ -92,9 +104,12 @@ pre-everything::
.if !defined(WITHOUT_GLX)
@${ECHO_MSG} "Define WITHOUT_GLX to disable building of GLX client"
.endif
-.if defined(WITH_SHAREWARE_DATA)
+.if !defined(WITH_SHAREWARE_DATA)
@${ECHO_MSG} "Define WITH_SHAREWARE_DATA to install demo version game data"
.endif
+.if !defined(WITH_SKYBOXES)
+ @${ECHO_MSG} "Define WITH_SKYBOXES to install additional skyboxes pak"
+.endif
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to enable extra optimization options"
.endif
@@ -138,6 +153,9 @@ do-install:
${INSTALL_DATA} ${_DISTDIR}/q1-shareware-pak0.pak \
${DATADIR}/id1/pak0.pak
.endif
+.if defined(WITH_SKYBOXES)
+ ${INSTALL_DATA} ${WRKDIR}/pakX.pak ${DATADIR}/qw/pak0.pak
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
. for txt in FAQ-v0.30-b585 FuhQuake-v0.31-FAQ benchmark config_manager crosshairs \
diff --git a/games/fuhquake/distinfo b/games/fuhquake/distinfo
index 25e4bd03ca33..8a0d1de3a22c 100644
--- a/games/fuhquake/distinfo
+++ b/games/fuhquake/distinfo
@@ -4,3 +4,5 @@ MD5 (fuhquake/fuhquake-linux-v0.31.zip) = 479a6f8dad1174333819e850b3aca8c1
SIZE (fuhquake/fuhquake-linux-v0.31.zip) = 4520020
MD5 (fuhquake/q1-shareware-pak0.pak) = 5906e5998fc3d896ddaf5e6a62e03abb
SIZE (fuhquake/q1-shareware-pak0.pak) = 18689235
+MD5 (fuhquake/fuhquake-skyboxes.zip) = 9360d7902e24e8b89d74600ce5d61b81
+SIZE (fuhquake/fuhquake-skyboxes.zip) = 3258479
diff --git a/games/fuhquake/pkg-plist b/games/fuhquake/pkg-plist
index 00a1f2f55a6d..953601ace92a 100644
--- a/games/fuhquake/pkg-plist
+++ b/games/fuhquake/pkg-plist
@@ -21,6 +21,7 @@ share/fuhquake/fuhquake/pak0.pak
share/fuhquake/qw/fragfile.dat
share/fuhquake/qw/qwprogs.dat
share/fuhquake/qw/spprogs.dat
+%%SKYBOXES%%share/fuhquake/qw/pak0.pak
@dirrm share/fuhquake/qw
%%SHAREWARE%%@dirrm share/fuhquake/id1
@dirrm share/fuhquake/fuhquake