aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-11-05 15:44:46 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-11-05 15:44:46 +0000
commitdb82c65b4c817c512f6514703b4deb207379b3ae (patch)
treefb3b704f7d491d31340bf6167e436c74238787d0 /games
parent656ff5bb3d403155e1d4db39b3043b57ff2d06e1 (diff)
downloadports-db82c65b4c817c512f6514703b4deb207379b3ae.tar.gz
ports-db82c65b4c817c512f6514703b4deb207379b3ae.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/p5-Games-AlphaBeta/Makefile23
-rw-r--r--games/p5-Games-AlphaBeta/distinfo4
-rw-r--r--games/p5-Games-AlphaBeta/pkg-plist7
3 files changed, 23 insertions, 11 deletions
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
index 93e2c391cd35..db9c972b987e 100644
--- a/games/p5-Games-AlphaBeta/Makefile
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -6,21 +6,32 @@
#
PORTNAME= Games-AlphaBeta
-PORTVERSION= 0.4.5
+PORTVERSION= 0.4.6
CATEGORIES= games perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Games
PKGNAMEPREFIX= p5-
-MAINTAINER= aaron@daltons.ca
+MAINTAINER= aaron@FreeBSD.org
COMMENT= Game-tree search with object oriented interface
-BUILD_DEPENDS= ${SITE_PERL}/Games/Sequential.pm:${PORTSDIR}/games/p5-Games-Sequential
+BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/${PERL_ARCH}/Pod/Coverage/CountParents.pm:${PORTSDIR}/devel/p5-Pod-Coverage \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
+MAN1= othello-demo.1
MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \
- Games::AlphaBeta::Reversi.3
+ Games::AlphaBeta::Reversi.3 \
+ Games::Sequential.3 Games::Sequential::Position.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires Perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>
-.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/distinfo b/games/p5-Games-AlphaBeta/distinfo
index ada2eb52ee9b..3fa39b86f939 100644
--- a/games/p5-Games-AlphaBeta/distinfo
+++ b/games/p5-Games-AlphaBeta/distinfo
@@ -1,2 +1,2 @@
-MD5 (Games-AlphaBeta-0.4.5.tar.gz) = a6a6b18960cced47f12747e26dd18271
-SIZE (Games-AlphaBeta-0.4.5.tar.gz) = 8952
+MD5 (Games-AlphaBeta-0.4.6.tar.gz) = da42047e47f485266cbddbd18c6ab797
+SIZE (Games-AlphaBeta-0.4.6.tar.gz) = 12080
diff --git a/games/p5-Games-AlphaBeta/pkg-plist b/games/p5-Games-AlphaBeta/pkg-plist
index 1a7b60a81efb..b8f8404f2fbd 100644
--- a/games/p5-Games-AlphaBeta/pkg-plist
+++ b/games/p5-Games-AlphaBeta/pkg-plist
@@ -1,8 +1,9 @@
+bin/othello-demo
%%SITE_PERL%%/Games/AlphaBeta.pm
%%SITE_PERL%%/Games/AlphaBeta/Position.pm
%%SITE_PERL%%/Games/AlphaBeta/Reversi.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta
-@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+%%SITE_PERL%%/Games/Sequential.pm
+%%SITE_PERL%%/Games/Sequential/Position.pm
@dirrm %%SITE_PERL%%/Games/AlphaBeta
+@dirrm %%SITE_PERL%%/Games/Sequential
@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true