aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-25 15:56:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-25 15:56:38 +0000
commitfa15cf58fb75e33a8990e602603fec92acb044e7 (patch)
treec3c526c9f0bfd7f0b6b25698de6d13ab873a39d1 /games
parentdfb7a9fc22a18c977dc83a883d2ee93130fdd4f9 (diff)
downloadports-fa15cf58fb75e33a8990e602603fec92acb044e7.tar.gz
ports-fa15cf58fb75e33a8990e602603fec92acb044e7.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/plonx/Makefile31
-rw-r--r--games/plonx/distinfo3
-rw-r--r--games/plonx/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2a0d5400da29..80dfcba0f91c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -442,6 +442,7 @@
SUBDIR += pinball
SUBDIR += pioneers
SUBDIR += pipenightdreams
+ SUBDIR += plonx
SUBDIR += pmars
SUBDIR += pmars-sdl
SUBDIR += polypuzzle
diff --git a/games/plonx/Makefile b/games/plonx/Makefile
new file mode 100644
index 000000000000..0d9ab710bc5a
--- /dev/null
+++ b/games/plonx/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: plonx
+# Date created: 25 November 2005
+# Whom: clive crous <clive@darkarts.co.za>
+#
+# $FreeBSD$
+
+PORTNAME= plonx
+PORTVERSION= 0.03
+CATEGORIES= games
+MASTER_SITES= http://bilious.homelinux.org/~paxed/${PORTNAME}/
+
+MAINTAINER= clive@darkarts.co.za
+COMMENT= A small ascii puzzle game
+
+PLIST_FILES= bin/plonx
+PORTDOCS= README
+
+LDFLAGS+= -lncurses
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
+ ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/plonx/distinfo b/games/plonx/distinfo
new file mode 100644
index 000000000000..4f8844c13679
--- /dev/null
+++ b/games/plonx/distinfo
@@ -0,0 +1,3 @@
+MD5 (plonx-0.03.tar.gz) = e6495ca33fe18654932db795b8e960a4
+SHA256 (plonx-0.03.tar.gz) = 2c8e5573602c5119b36c8237a34da852398a908cacf3eafe853ec6ac1cd20d85
+SIZE (plonx-0.03.tar.gz) = 3575
diff --git a/games/plonx/pkg-descr b/games/plonx/pkg-descr
new file mode 100644
index 000000000000..07373508b87a
--- /dev/null
+++ b/games/plonx/pkg-descr
@@ -0,0 +1,5 @@
+Plonx is a small ascii puzzle game, where you'll have to avoid bombs
+and collect points.
+
+Author: Pasi Kallinen
+WWW: http://bilious.homelinux.org/~paxed/plonx/