aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:16:40 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:16:40 +0000
commit6e3e856f460d3a5c4e0a1ad0eb7aed7f7499f2b5 (patch)
tree492059896ae00bfe8a31ffa80ed8cca3fd67f499 /games
parente55dcc08e3fdbca267584da82e3dfbecb85becb8 (diff)
downloadports-6e3e856f460d3a5c4e0a1ad0eb7aed7f7499f2b5.tar.gz
ports-6e3e856f460d3a5c4e0a1ad0eb7aed7f7499f2b5.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/xqf/Makefile32
-rw-r--r--games/xqf/distinfo2
-rw-r--r--games/xqf/files/patch-src::country-filter.h12
-rw-r--r--games/xqf/pkg-plist14
4 files changed, 49 insertions, 11 deletions
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index 8fdda0e858f2..149ab57294c4 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xqf
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.13
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,13 +16,37 @@ COMMENT= Find quake servers
RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
-USE_GNOME= gdkpixbuf gnometarget
+USE_GETOPT_LONG= yes
+USE_GNOME= gnometarget
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN6= xqf.6
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --enable-gtk2
+.else
+USE_GNOME+= gdkpixbuf
+.endif
+
+.if defined(WITH_GEOIP)
+LIB_DEPENDS+= GeoIP.3:${PORTSDIR}/net/GeoIP
+.else
+CONFIGURE_ARGS+= --disable-geoip
+.endif
+
+.if !defined(WITHOUT_BZIP2)
+CONFIGURE_ARGS+= --enable-bzip2
+.if !exists(/usr/bin/bzip2)
+RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/games/xqf/distinfo b/games/xqf/distinfo
index 34a8db50318a..98e26ed6f9ff 100644
--- a/games/xqf/distinfo
+++ b/games/xqf/distinfo
@@ -1 +1 @@
-MD5 (xqf-0.9.12.tar.gz) = 1e7cc65bf280b3b0a1180f425dd9bbe6
+MD5 (xqf-0.9.13.tar.gz) = d4d71965cbcd56ea363ab4c92bfbe91b
diff --git a/games/xqf/files/patch-src::country-filter.h b/games/xqf/files/patch-src::country-filter.h
new file mode 100644
index 000000000000..e222f14994b6
--- /dev/null
+++ b/games/xqf/files/patch-src::country-filter.h
@@ -0,0 +1,12 @@
+--- src/country-filter.h.orig Sun Oct 5 21:53:51 2003
++++ src/country-filter.h Fri Nov 28 11:11:26 2003
+@@ -22,6 +22,9 @@
+
+ #include <glib.h>
+ #include "pixmaps.h"
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+
+ extern const unsigned MaxCountries;
diff --git a/games/xqf/pkg-plist b/games/xqf/pkg-plist
index de5ac41bca6a..870af289511d 100644
--- a/games/xqf/pkg-plist
+++ b/games/xqf/pkg-plist
@@ -1,13 +1,15 @@
@comment $FreeBSD$
bin/xqf
-%%PORTDOCS%%share/doc/xqf/xqfdocs.html
+%%PORTDOCS%%%%DOCSDIR%%/xqfdocs.html
share/locale/ca/LC_MESSAGES/xqf.mo
share/locale/da/LC_MESSAGES/xqf.mo
share/locale/de/LC_MESSAGES/xqf.mo
share/locale/es/LC_MESSAGES/xqf.mo
share/locale/fr/LC_MESSAGES/xqf.mo
-share/xqf/qstat.cfg
-share/xqf/pixmaps/xqflogo.png
-@dirrm share/xqf/pixmaps
-@dirrm share/xqf
-%%PORTDOCS%%@dirrm share/doc/xqf
+%%DATADIR%%/default/flags/lan.png
+%%DATADIR%%/default/splash.png
+%%DATADIR%%/qstat.cfg
+@dirrm %%DATADIR%%/default/flags
+@dirrm %%DATADIR%%/default
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%