aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:00:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:00:10 +0000
commit31152de2a772626b794b5f2a2491455c43109614 (patch)
tree8d546fa2e9222b41aeaebd1cff18ba3b648be907 /games
parenta77af7207277e66f16a7d2ebdd8a33ba91ec6dc0 (diff)
downloadports-31152de2a772626b794b5f2a2491455c43109614.tar.gz
ports-31152de2a772626b794b5f2a2491455c43109614.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/tinymux/Makefile42
1 files changed, 25 insertions, 17 deletions
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index 6560553e093c..abb31b17aecf 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -7,27 +7,41 @@
PORTNAME= tinymux
PORTVERSION= 2.6.5.${PATCHLEVEL}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games net
-MASTER_SITES= ftp://ftp.tinymux.org/TinyMUX/tinymux-2.6/${PATCHLEVEL}/ \
- http://www.tinymux.org/
+MASTER_SITES= GOOGLE_CODE \
+ ftp://ftp.tinymux.org/TinyMUX/tinymux-2.6/${PATCHLEVEL}/
DISTNAME= mux-${PORTVERSION}.unix
MAINTAINER= ports@FreeBSD.org
COMMENT= A Multi-Player FreeForm adventure Program
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/mux2.6/src
+
USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_JOBS_SAFE= yes
-PATCHLEVEL= 32
-WRKSRC= ${WRKDIR}/mux2.6/src
-.if !defined(NOPORTDOCS)
PORTDOCS= *
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+PATCHLEVEL= 32
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not build
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^LIBS/s|= @LIBS@|= @LDFLAGS@ @LIBS@|g ; \
+ /^OPTIM/s|=.*|= @CPPFLAGS@|g' ${WRKSRC}/Makefile.in
+
do-install:
# Binaries
.for file in netmux slave
@@ -35,10 +49,10 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/../game/bin/dbconvert ${PREFIX}/bin
# Configuration
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${MKDIR} ${ETCDIR}
.for file in alias.conf compat.conf mux.config netmux.conf
${INSTALL_DATA} ${WRKSRC}/../game/${file} \
- ${PREFIX}/etc/${PORTNAME}/${file}.sample
+ ${ETCDIR}/${file}.sample
.endfor
# Data
${MKDIR} ${DATADIR}/game/netmux
@@ -70,10 +84,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
-
.include <bsd.port.post.mk>