aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2004-03-14 06:17:56 +0000
committerAde Lovett <ade@FreeBSD.org>2004-03-14 06:17:56 +0000
commit3f651573ad3b90cf8e6539c52b4b34a1df543fa6 (patch)
tree14261786c359f03d9574a1c204f76ddc8ec4db8a /games
parent003520276a84300843c37e85ff39f416dec0bd8e (diff)
downloadports-3f651573ad3b90cf8e6539c52b4b34a1df543fa6.tar.gz
ports-3f651573ad3b90cf8e6539c52b4b34a1df543fa6.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile2
-rw-r--r--games/asc/Makefile2
-rw-r--r--games/bomberinstinct/Makefile2
-rw-r--r--games/bombermaze/Makefile2
-rw-r--r--games/etuxracer/Makefile2
-rw-r--r--games/euchre/Makefile2
-rw-r--r--games/freecell-solver/Makefile2
-rw-r--r--games/gcompris2/Makefile2
-rw-r--r--games/glife/Makefile2
-rw-r--r--games/gno3dtet/Makefile2
-rw-r--r--games/gnocatan/Makefile2
-rw-r--r--games/gnome-games/Makefile2
-rw-r--r--games/gnomegames2/Makefile2
-rw-r--r--games/gnomememoryblocks/Makefile2
-rw-r--r--games/gturing/Makefile2
-rw-r--r--games/kobodeluxe/Makefile4
-rw-r--r--games/monkeybubble/Makefile2
-rw-r--r--games/moon-buggy/Makefile2
-rw-r--r--games/pinball/Makefile2
-rw-r--r--games/pioneers/Makefile2
-rw-r--r--games/quake2forge/Makefile2
-rw-r--r--games/quakeforge/Makefile2
-rw-r--r--games/rtb/Makefile2
-rw-r--r--games/teg/Makefile2
-rw-r--r--games/tinymux/Makefile2
-rw-r--r--games/tractorgen/Makefile2
-rw-r--r--games/tuxracer-commercial/Makefile2
-rw-r--r--games/tuxracer/Makefile2
-rw-r--r--games/vamos/Makefile2
-rw-r--r--games/xfce4-toys/Makefile2
-rw-r--r--games/xinvaders/Makefile2
-rw-r--r--games/xpuyopuyo/Makefile2
-rw-r--r--games/xracer/Makefile2
33 files changed, 32 insertions, 36 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 571f97b6627b..a73660f3ab9d 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -25,7 +25,7 @@ USE_SDL= sdl
USE_GNOME= gnometarget
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/asc/Makefile b/games/asc/Makefile
index cf44ed7c3d04..6a277762e919 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -27,7 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_SDL= image mm mixer sdl
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GETOPT_LONG= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
CXXFLAGS="-D_UNICODE_BROKEN_" \
diff --git a/games/bomberinstinct/Makefile b/games/bomberinstinct/Makefile
index 748f92b7b5ad..c5bdd1c02f15 100644
--- a/games/bomberinstinct/Makefile
+++ b/games/bomberinstinct/Makefile
@@ -20,7 +20,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
USE_SDL= mixer sdl
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_PERL5_BUILD=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
diff --git a/games/bombermaze/Makefile b/games/bombermaze/Makefile
index 05efb340826b..1beea8c98a59 100644
--- a/games/bombermaze/Makefile
+++ b/games/bombermaze/Makefile
@@ -18,7 +18,7 @@ COMMENT= A Bomberman clone for GNOME
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/etuxracer/Makefile b/games/etuxracer/Makefile
index 650fda65dc70..5fdf07a6385c 100644
--- a/games/etuxracer/Makefile
+++ b/games/etuxracer/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
USE_MESA= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
diff --git a/games/euchre/Makefile b/games/euchre/Makefile
index 64b38d705741..dd3e4815e1f3 100644
--- a/games/euchre/Makefile
+++ b/games/euchre/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= laszlof@vonostingroup.com
COMMENT= Very popular card game with variable skill levels
PLIST_FILES= bin/euchre
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
USE_GNOME= gtk12
.include <bsd.port.mk>
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 14ccd251e745..59c1530f4b3f 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://vipe.technion.ac.il/~shlomif/freecell-solver/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A program that automatically solves games of Freecell
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN6= fc-solve-board_gen.6 fc-solve.6 \
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index e6be7bf5f296..963dd061502b 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_PYTHON= yes
USE_GNOME= gnomehack lthack gnomeprefix libgnomeui pygnome2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/glife/Makefile b/games/glife/Makefile
index dee1bfac3791..42ead64abdfc 100644
--- a/games/glife/Makefile
+++ b/games/glife/Makefile
@@ -18,7 +18,7 @@ COMMENT= Conway's Game of Life for GNOME
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GNOME= gnomeprefix gnomehack libglade
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 8f2c669772cc..97b05c4bc547 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -20,7 +20,7 @@ USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index 408cc68b4827..731fd91612ac 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -17,7 +17,7 @@ COMMENT= An Internet playable version of the Settlers of Catan for GNOME/GTK
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gtk20 libgnomeui
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index a753120bfb48..3f2fdb400864 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier libgnomeui
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index a753120bfb48..3f2fdb400864 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier libgnomeui
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/gnomememoryblocks/Makefile b/games/gnomememoryblocks/Makefile
index 8187fe10ae60..b9b23e56d3b9 100644
--- a/games/gnomememoryblocks/Makefile
+++ b/games/gnomememoryblocks/Makefile
@@ -19,7 +19,7 @@ COMMENT= Memory Blocks game for GNOME
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
index 8ff7b89796c2..4eec383ce2ec 100644
--- a/games/gturing/Makefile
+++ b/games/gturing/Makefile
@@ -17,7 +17,7 @@ COMMENT= A simple turing machine simulator for GNOME 2
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 69701d504bc8..58075c1d7cd8 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -20,12 +20,8 @@ CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config
CONFIGURE_ARGS+= --program-transform-name="s/$$//"
USE_SDL= image sdl
-USE_AUTOMAKE= yes
-USE_AUTOCONF= yes
USE_AUTOCONF_VER= 253
USE_AUTOMAKE_VER= 15
-AUTOCONF= autoconf
-ACLOCAL= aclocal
.include <bsd.port.pre.mk>
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 75d28c17e3c6..38f783da312d 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= adamw@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui \
gstreamerplugins intlhack lthack
diff --git a/games/moon-buggy/Makefile b/games/moon-buggy/Makefile
index d93d8eecec66..8697c9863858 100644
--- a/games/moon-buggy/Makefile
+++ b/games/moon-buggy/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.mathematik.uni-kl.de/~wwwstoch/voss/data/ \
MAINTAINER= ralf@akk.org
COMMENT= Drive a buggy across the moons surface
-USE_AUTOCONF= YES
+USE_AUTOCONF_VER= 213
USE_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} \
--sharedstatedir=/var/games \
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 163f15a14679..fa839e4e2063 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -27,7 +27,7 @@ USE_SDL= image mixer sdl
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_MESA= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index 408cc68b4827..731fd91612ac 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -17,7 +17,7 @@ COMMENT= An Internet playable version of the Settlers of Catan for GNOME/GTK
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gtk20 libgnomeui
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 03881b1f801c..2c82b015d258 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -18,7 +18,7 @@ COMMENT= First Person Shooter with many addons available
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_XLIB= yes
INSTALLS_SHLIB= yes
WANT_SDL= yes
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index dfe1356f48bf..72acf5c9f8f6 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -31,7 +31,7 @@ WADFILE= quakesw-1.0.6.tar.gz
PROGFILE= qwsv-2.30-glibc-i386-unknown-linux2.0.tar.gz
SKINFILES= skinbase.zip qw_skins.zip
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GMAKE= yes
USE_XLIB= yes
USE_REINPLACE= yes
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index d9fab11c654b..568aeacd01aa 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -16,7 +16,7 @@ COMMENT= Robot programming game for UNIX
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --enable-debug
.include <bsd.port.pre.mk>
diff --git a/games/teg/Makefile b/games/teg/Makefile
index 40fc1e8f235c..341a095ab4d5 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -18,7 +18,7 @@ COMMENT= A turn-based strategy game for GNOME
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui lthack
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index 145e7554179f..db9abfe4f713 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
WRKSRC= ${WRKDIR}/src
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/tractorgen/Makefile b/games/tractorgen/Makefile
index a3735534ad95..4658eae138ca 100644
--- a/games/tractorgen/Makefile
+++ b/games/tractorgen/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= elfrink@introcom.nl
COMMENT= Generates ASCII tractors
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
MAN6= tractorgen.6
PLIST_FILES= bin/tractorgen
diff --git a/games/tuxracer-commercial/Makefile b/games/tuxracer-commercial/Makefile
index 650fda65dc70..5fdf07a6385c 100644
--- a/games/tuxracer-commercial/Makefile
+++ b/games/tuxracer-commercial/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
USE_MESA= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index 650fda65dc70..5fdf07a6385c 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
USE_SDL= mixer sdl
USE_MESA= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index b6909256dcfc..d857bde30b8c 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -27,7 +27,7 @@ USE_GNOME= gnometarget lthack
USE_GL= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
INSTALLS_SHLIB= yes
diff --git a/games/xfce4-toys/Makefile b/games/xfce4-toys/Makefile
index 3e463a3dbc68..7a2f5ae5f8d0 100644
--- a/games/xfce4-toys/Makefile
+++ b/games/xfce4-toys/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
diff --git a/games/xinvaders/Makefile b/games/xinvaders/Makefile
index 921aba068165..eded4f8215d9 100644
--- a/games/xinvaders/Makefile
+++ b/games/xinvaders/Makefile
@@ -21,7 +21,7 @@ NO_CDROM= "don't sell for profit"
USE_GETTEXT= yes
USE_X_PREFIX= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= --include-deps
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
diff --git a/games/xpuyopuyo/Makefile b/games/xpuyopuyo/Makefile
index 2ceaa7eb5214..90abca751663 100644
--- a/games/xpuyopuyo/Makefile
+++ b/games/xpuyopuyo/Makefile
@@ -17,7 +17,7 @@ COMMENT= A puzzle game, somewhat like Tetris
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_GNOME= gtk12
WANT_GNOME= yes
diff --git a/games/xracer/Makefile b/games/xracer/Makefile
index a4ff681eac0b..5051f62a24a2 100644
--- a/games/xracer/Makefile
+++ b/games/xracer/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_XLIB= yes
USE_MESA= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-esd