aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-05-17 09:02:35 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-05-17 09:02:35 +0000
commit5055797db8d0891a75d10d309d472b91104ddffa (patch)
treee121c66969665c311a06ebdecba810be7c1b4253 /games
parent0375af94115b9301cac82a493acfb15d38c88e9b (diff)
downloadports-5055797db8d0891a75d10d309d472b91104ddffa.tar.gz
ports-5055797db8d0891a75d10d309d472b91104ddffa.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/imaze/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index b5e0db74e14c..84b6f233ad18 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -14,31 +14,33 @@ COMMENT= Multi-player network action game for TCP/IP with 3D graphics
LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/Copyright
+USE_XORG= x11 xaw xmu xt
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= ${TOOLKIT} X11Dir="${LOCALBASE}" CFlags="${CFLAGS}"
+MAKE_ENV= SOUNDDIR="${DATADIR}/sounds"
+
+BUILD_WRKSRC= ${WRKSRC}/source
+CONFIGURE_WRKSRC= ${WRKSRC}/source
+
OPTIONS_DEFINE= AUDIO JOYSTICK
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= ATHENA MOTIF XVIEW
OPTIONS_DEFAULT= ATHENA AUDIO JOYSTICK
ATHENA_DESC= Athena widget library support
-ATHENA_VARS= TOOLKIT=athena
AUDIO_DESC= Audio support
-AUDIO_CONFIGURE_OFF= noaudio
JOYSTICK_DESC= Joystick support
+XVIEW_DESC= XView widget library support
+
+ATHENA_VARS= TOOLKIT=athena
+AUDIO_CONFIGURE_OFF= noaudio
JOYSTICK_CONFIGURE_OFF= nojoystick
MOTIF_USES= motif
MOTIF_VARS= MOTIFLIB="-L${LOCALBASE}/lib -lXm -lXt" TOOLKIT=motif
-XVIEW_DESC= XView widget library support
XVIEW_LIB_DEPENDS= libxview.so:x11-toolkits/xview
XVIEW_VARS= TOOLKIT=xview
-CONFIGURE_WRKSRC=${WRKSRC}/source
-BUILD_WRKSRC= ${WRKSRC}/source
-
-USE_XORG= x11 xaw xmu xt
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= ${TOOLKIT} X11Dir="${LOCALBASE}" CFlags="${CFLAGS}"
-MAKE_ENV= SOUNDDIR="${DATADIR}/sounds"
-
do-install:
.for i in genlab imaze imazesrv imazestat ninja xlabed
(cd ${WRKSRC}/source && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)