aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-14 12:08:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-14 12:08:09 +0000
commitc3858881071b2d3d91abd6c2612a6b43105c5d12 (patch)
treec8982fcd15fb8864dd97c826bf65c462587866e0 /games
parented86ac2de4c4e39f03b00b82fde13a8b283382d1 (diff)
downloadports-c3858881071b2d3d91abd6c2612a6b43105c5d12.tar.gz
ports-c3858881071b2d3d91abd6c2612a6b43105c5d12.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-source_utils.c12
-rw-r--r--games/openbor/files/patch-source_utils.h19
4 files changed, 34 insertions, 7 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 04423d4c56d7..95c96bf6351c 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 5137
+PORTVERSION?= 6138
.ifndef PKGNAMESUFFIX
PORTREVISION= 0
.endif
@@ -31,7 +31,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 0b077e46
+GH_TAGNAME?= 5673214c
USES+= gmake pkgconfig
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 27955ebdb155..b1bb41a76dc1 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525902990
-SHA256 (DCurrent-openbor-5137-0b077e46_GH0.tar.gz) = 549538689d66d641410abb6a25457cadd13c04176f737b9e8b5f5ac52246ec17
-SIZE (DCurrent-openbor-5137-0b077e46_GH0.tar.gz) = 74507480
+TIMESTAMP = 1526285237
+SHA256 (DCurrent-openbor-6138-5673214c_GH0.tar.gz) = e07a3970ae1eb050ade6ea02ae21dd0dbc00c028b504a8fa8f3ee73379ba7fe3
+SIZE (DCurrent-openbor-6138-5673214c_GH0.tar.gz) = 74511657
diff --git a/games/openbor/files/patch-source_utils.c b/games/openbor/files/patch-source_utils.c
index d737e7cff108..ef9cd6d5ee6d 100644
--- a/games/openbor/files/patch-source_utils.c
+++ b/games/openbor/files/patch-source_utils.c
@@ -1,6 +1,14 @@
---- source/utils.c.bak 2017-04-22 14:20:08 UTC
+source/utils.c:303:54: error: implicit declaration of function 'mallinfo' is invalid in C99
+ [-Werror,-Wimplicit-function-declaration]
+ writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
+ ^
+source/utils.c:303:64: error: member reference base type 'int' is not a structure or union
+ writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
+ ~~~~~~~~~~^~~~~~
+
+--- source/utils.c.orig 2017-04-22 14:20:08 UTC
+++ source/utils.c
-@@ -295,7 +295,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
+@@ -299,7 +299,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
"\n* Shutting Down *\n\n");
writeToLogFile("Out of memory!\n");
writeToLogFile("Allocation of size %i failed in function '%s' at %s:%i.\n", size, func, file, line);
diff --git a/games/openbor/files/patch-source_utils.h b/games/openbor/files/patch-source_utils.h
new file mode 100644
index 000000000000..8482fb199859
--- /dev/null
+++ b/games/openbor/files/patch-source_utils.h
@@ -0,0 +1,19 @@
+In file included from openborscript.c:30:
+In file included from source/openborscript/config.h:12:
+In file included from source/scriptlib/Interpreter.h:11:
+In file included from source/scriptlib/depends.h:13:
+In file included from source/globals.h:24:
+source/utils.h:65:59: error: unknown type name 'time_t'
+void get_time_string(char buffer[], unsigned buffer_size, time_t timestamp, char* pattern); // ex. "%Y-%m-%d %H:%M:%S"
+ ^
+
+--- source/utils.h.orig 2018-05-13 22:01:54 UTC
++++ source/utils.h
+@@ -10,6 +10,7 @@
+ #define UTILS_H
+
+ // *** INCLUDES ***
++#include <time.h>
+ #include "types.h"
+ #include "stringptr.h"
+