aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-19 09:05:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-19 09:05:03 +0000
commitdd05aa01acaa3ba3b5ede2536a8927ee74dc501e (patch)
tree10e091b8a49e0c275924cb9b6b0e9d55591b343f /games
parentaccd360e00b8a336ab4d1613fd52dbd2ab72be24 (diff)
downloadports-dd05aa01acaa3ba3b5ede2536a8927ee74dc501e.tar.gz
ports-dd05aa01acaa3ba3b5ede2536a8927ee74dc501e.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openbubbles/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/openbubbles/Makefile b/games/openbubbles/Makefile
index 4277a1f43c58..e3c1ebc12fa8 100644
--- a/games/openbubbles/Makefile
+++ b/games/openbubbles/Makefile
@@ -15,12 +15,12 @@ COMMENT= Clone of Evan Bailey's game Bubbles
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:bzip2
+USES= dos2unix tar:bzip2
+DOS2UNIX_FILES= ${WRKSRC}/src/BFont.cpp
USE_SDL= sdl gfx image
GNU_CONFIGURE= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
-OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
@@ -28,15 +28,18 @@ ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
DESKTOP_ENTRIES="OpenBubbles" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
+OPTIONS_DEFINE= DOCS
+
post-install:
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${LN} -sf ../../share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}