aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:15:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:15:32 +0000
commite0c091c3ce14a4cec16ddb90eca6f9ba3014247f (patch)
tree0d0ceb5acada892a334e02beaab3706ff5708833 /games
parent0e4f2cc24d8b7af2d01c4e3b35b615714d0b2e99 (diff)
downloadports-e0c091c3ce14a4cec16ddb90eca6f9ba3014247f.tar.gz
ports-e0c091c3ce14a4cec16ddb90eca6f9ba3014247f.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/quake2-data/Makefile3
-rw-r--r--games/quake2-data/Makefile.include37
-rw-r--r--games/quake2lnx/Makefile4
3 files changed, 14 insertions, 30 deletions
diff --git a/games/quake2-data/Makefile b/games/quake2-data/Makefile
index 887cb63e049b..33896fdb0fb6 100644
--- a/games/quake2-data/Makefile
+++ b/games/quake2-data/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/quake2/ \
ftp://ftp.fasta.fh-dortmund.de/mirror/idstuff/quake2/
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTFILES= ${Q2FULL}
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -25,6 +26,8 @@ NO_WRKSUBDIR= yes
OPTIONS= CTF "Install the Capture The Flag mod data" on \
SHAREWARE "Install demo version game data" off
+DATADIR= ${Q2DIR}
+
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
Q2FULL= q2-3.20-x86-full.exe
diff --git a/games/quake2-data/Makefile.include b/games/quake2-data/Makefile.include
index adb9a2faab25..afdc3ba1f537 100644
--- a/games/quake2-data/Makefile.include
+++ b/games/quake2-data/Makefile.include
@@ -1,39 +1,18 @@
# Makefile for defining variables used by other Quake II related ports.
-# Determine if the port is a Quake II engine.
+# Set variables.
-Q2ENGINES= quake2forge quake2lnx
+Q2PKGNAMEPREFIX?=quake2-
+Q2DIR?= ${LOCALBASE}/share/quake2
-.for f in ${Q2ENGINES}
-. if ${PORTNAME} == ${f}
-ENGINE= yes
-. endif
-.endfor
+# Add them to the environment.
-# Package name prefix.
+MAKE_ENV+= Q2DIR="${Q2DIR}"
+PLIST_SUB+= Q2DIR="${Q2DIR:S/${LOCALBASE}\///}"
+SUB_LIST+= Q2DIR="${Q2DIR}"
-Q2PKGNAMEPREFIX=quake2-
-
-.if !defined(ENGINE)
-PKGNAMEPREFIX?= ${Q2PKGNAMEPREFIX}
-.endif
-
-# Dependency to "games/quake2-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q2DIR}:${PORTSDIR}/games/quake2-data
.endif
-
-# Installation directories.
-
-Q2DIR= ${LOCALBASE}/share/quake2
-
-.if defined(ENGINE) || ${PORTNAME} == "data"
-DATADIR?= ${Q2DIR}
-.else
-DATADIR?= ${Q2DIR}/${PORTNAME}
-.endif
-
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= Q2DIR="${Q2DIR:S/${PREFIX}\///}"
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 97a1b3ba3d62..9218561fd525 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -45,8 +45,10 @@ OPTIONS= AA "Build ASCII software renderer" off \
X11 "Build X11 software driver" on \
X86_ASM "Enable use of x86 assembly code" on
+DATADIR= ${Q2DIR}
+
ALL_TARGET= build_release
-MAKE_ENV= DATADIR="${DATADIR}" LIBDIR="${LIBDIR}"
+MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}"