aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-23 17:12:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-23 17:12:04 +0000
commit0ae8a455c3d113ed9c85fc7f50f0b0987d22da28 (patch)
tree2f0fa679334102fddd25359aa3c7618d4e39d897 /games
parent7d86aab65b8fa9d4bc045a1b84a4eac221d5e819 (diff)
downloadports-0ae8a455c3d113ed9c85fc7f50f0b0987d22da28.tar.gz
ports-0ae8a455c3d113ed9c85fc7f50f0b0987d22da28.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Algorithm-Pair-Best2/Makefile21
-rw-r--r--games/p5-Algorithm-Pair-Best2/distinfo2
-rw-r--r--games/p5-Algorithm-Pair-Best2/pkg-descr11
-rw-r--r--games/p5-Algorithm-Pair-Best2/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 1e833b55bb41..184d0de8f59e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -616,6 +616,7 @@
SUBDIR += outerspace
SUBDIR += p5-Acme-GuessNumber
SUBDIR += p5-Algorithm-Pair-Best
+ SUBDIR += p5-Algorithm-Pair-Best2
SUBDIR += p5-Algorithm-Pair-Swiss
SUBDIR += p5-Baseball-Sabermetrics
SUBDIR += p5-Games-Alak
diff --git a/games/p5-Algorithm-Pair-Best2/Makefile b/games/p5-Algorithm-Pair-Best2/Makefile
new file mode 100644
index 000000000000..36782f35870e
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best2/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Algorithm-Pair-Best2
+# Date created: 2011-11-24
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Pair-Best2
+PORTVERSION= 2.035
+CATEGORIES= games perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Select tournament pairings
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::Pair::Best2.3
+
+.include <bsd.port.mk>
diff --git a/games/p5-Algorithm-Pair-Best2/distinfo b/games/p5-Algorithm-Pair-Best2/distinfo
new file mode 100644
index 000000000000..412899676767
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Algorithm-Pair-Best2-2.035.tar.gz) = 326fc801982cb63dc42b16c43291653db560793d52fdb3de7fc9396c70778c31
+SIZE (Algorithm-Pair-Best2-2.035.tar.gz) = 13685
diff --git a/games/p5-Algorithm-Pair-Best2/pkg-descr b/games/p5-Algorithm-Pair-Best2/pkg-descr
new file mode 100644
index 000000000000..b2e3a6f401dc
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best2/pkg-descr
@@ -0,0 +1,11 @@
+Algorithm::Pair::Best2 is a re-write of Algorithm::Pair::Best. The interface is
+simplified and the implementation is significantly streamlined.
+
+After creating an Algorithm::Pair::Best2 object (with->new), add items to the
+list of items (i.e: players) to be paired. The final list must contain an even
+number of items or picking the pairs will throw an exception.
+
+Algorithm::Pair::Best2->pick explores all combinations of items and returns the
+pairing list with the best (lowest) score.
+
+WWW: http://search.cpan.org/dist/Algorithm-Pair-Best2/
diff --git a/games/p5-Algorithm-Pair-Best2/pkg-plist b/games/p5-Algorithm-Pair-Best2/pkg-plist
new file mode 100644
index 000000000000..9c385a53c771
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best2/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Algorithm/Pair/Best2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best2/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/Algorithm/Pair
+@dirrmtry %%SITE_PERL%%/Algorithm