aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-20 14:44:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-04-20 14:44:25 +0000
commit0bb60cc35cb4423bc266b1e424c9187ab8f54972 (patch)
treef762a929d3077bb65e3ecd2a5f0911e1bdfa073e /games
parent12d6142f7643eafaf26b566ced85291182015bbb (diff)
downloadports-0bb60cc35cb4423bc266b1e424c9187ab8f54972.tar.gz
ports-0bb60cc35cb4423bc266b1e424c9187ab8f54972.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/quake2max/Makefile19
-rw-r--r--games/quake2max/files/patch-Makefile2
2 files changed, 10 insertions, 11 deletions
diff --git a/games/quake2max/Makefile b/games/quake2max/Makefile
index a1a5cdd7cbd2..a8e0977b85d0 100644
--- a/games/quake2max/Makefile
+++ b/games/quake2max/Makefile
@@ -6,8 +6,7 @@ PORTVERSION= 0.45
PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= http://www.bfeared.com/library/quake/archive/quakedev/qudos/quake2/engines/Quake2MaX/:src \
- ${MASTER_SITE_LOCAL:S/$/:data/}
-MASTER_SITE_SUBDIR= alepulver/:data
+ LOCAL/alepulver/:data
DISTNAME= Quake2maX_${PORTVERSION}-src_unix
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src ${Q2MAX_DATA}:data
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -19,8 +18,7 @@ LICENSE= GPLv2
EXTRACT_DEPENDS= unrar:${PORTSDIR}/archivers/unrar
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_XORG= xxf86dga
ALL_TARGET= release
WRKSRC= ${WRKDIR}/${DISTNAME:S/quake2max/Quake2maX/}
@@ -41,7 +39,6 @@ GLX_DESC= Build OpenGL renderer
SDLCLIENT_DESC= Build SDL client
SDLGL_DESC= Build SDL OpenGL renderer
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MSDLGL}
@@ -118,17 +115,19 @@ post-patch:
${WRKSRC}/client/qmenu.c
do-install:
- @${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${STAGEDIR}${LIBDIR}/baseq2
.for f in ${Q2MAX_BIN}
- ${INSTALL_PROGRAM} ${WRKSRC}/quake2/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/quake2/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
.for f in ${Q2MAX_REF}
- ${INSTALL_PROGRAM} ${WRKSRC}/quake2/rfx_${f}.so ${LIBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/quake2/rfx_${f}.so ${STAGEDIR}${LIBDIR}
.endfor
.if ${PORT_OPTIONS:MGAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
+ ${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so \
+ ${STAGEDIR}${LIBDIR}/baseq2
.endif
- ${INSTALL_DATA} ${WRKSRC}/_maxpak.pak ${LIBDIR}/baseq2/maxpak.pak
+ ${INSTALL_DATA} ${WRKSRC}/_maxpak.pak \
+ ${STAGEDIR}${LIBDIR}/baseq2/maxpak.pak
.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.mk>
diff --git a/games/quake2max/files/patch-Makefile b/games/quake2max/files/patch-Makefile
index 467c6b4f82ee..d633abfc8d97 100644
--- a/games/quake2max/files/patch-Makefile
+++ b/games/quake2max/files/patch-Makefile
@@ -38,7 +38,7 @@
+ifeq ($(WITH_OPTIMIZED_CFLAGS),YES)
+ RELEASE_CFLAGS+=-O2 -ffast-math -fomit-frame-pointer -fexpensive-optimizations
+ ifeq ($(ARCH),i386)
-+ RELEASE_CFLAGS+=-falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing
++ RELEASE_CFLAGS+=-falign-functions=2 -fno-strict-aliasing
+ endif
endif