aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-07-22 10:20:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-07-22 10:20:13 +0000
commit293b5512a8d675bec0d5ff143226a3ccb94fdc40 (patch)
treee895e8a603df2633682f56252954a28acf9cc291 /games
parent9b44ad368aa49bc18f6f8074915316ce7c7b8a86 (diff)
downloadports-293b5512a8d675bec0d5ff143226a3ccb94fdc40.tar.gz
ports-293b5512a8d675bec0d5ff143226a3ccb94fdc40.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/phpua-q3/Makefile22
-rw-r--r--games/phpua-q3/pkg-plist11
2 files changed, 20 insertions, 13 deletions
diff --git a/games/phpua-q3/Makefile b/games/phpua-q3/Makefile
index dd7d0a4434b6..27e052d15c4d 100644
--- a/games/phpua-q3/Makefile
+++ b/games/phpua-q3/Makefile
@@ -7,21 +7,19 @@
PORTNAME= phpua-plugin_q3
PORTVERSION= 1.1.0b
+PORTREVISION= 1
CATEGORIES= games www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpua
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= A Quake 3 plugin for phpUA
-RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
-
-BROKEN= does not install due to dependency problem in games/phpua-engine
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-09-03
+BUILD_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+RUN_DEPENDS= ${BUILD_DEPENDS}
# Some variables you can change
-PHPUA?= www/data/phpua
+PHPUA?= www/phpua
PHPUA_USER?= ${WWWOWN}
PHPUA_GROUP?= ${WWWGRP}
@@ -44,11 +42,13 @@ pre-everything::
${ECHO_MSG} '-------------------------------------------------------------------------')
.endif
+do-extract:
+ @ ${MKDIR} ${WRKSRC}
+ @ cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}
+
do-install:
- @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
- @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
- @ ${CP} -R ${WRKDIR}/images ${PREFIX}/${PHPUA}/
- @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${PREFIX}/${PHPUA}
+ @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${WRKSRC}
+ @ ${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPUA}/
@ ${ECHO_MSG} ""
@ ${ECHO_MSG} "* Files have been installed in"
@ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
diff --git a/games/phpua-q3/pkg-plist b/games/phpua-q3/pkg-plist
index c0ca823abdcd..70aaa795c93c 100644
--- a/games/phpua-q3/pkg-plist
+++ b/games/phpua-q3/pkg-plist
@@ -65,13 +65,20 @@
%%PHPUA%%/templates/default/plugin_q3/x.js
%%PHPUA%%/templates/javascript/plugin_q3/info.tpl
%%PHPUA%%/templates/wap/plugin_q3/info.tpl
-@exec chown -R %%PHPUA_USER%%:%%PHPUA_GROUP%% %D/%%PHPUA%%
@dirrm %%PHPUA%%/templates/wap/plugin_q3
+@dirrmtry %%PHPUA%%/templates/wap
@dirrm %%PHPUA%%/templates/javascript/plugin_q3
+@dirrm %%PHPUA%%/templates/javascript
@dirrm %%PHPUA%%/templates/default/plugin_q3
+@dirrm %%PHPUA%%/templates/default
+@dirrmtry %%PHPUA%%/templates
@dirrm %%PHPUA%%/plugins/plugin_q3
+@dirrmtry %%PHPUA%%/plugins
@dirrm %%PHPUA%%/images/templates/wap/plugin_q3
+@dirrmtry %%PHPUA%%/images/templates/wap
@dirrm %%PHPUA%%/images/templates/default/plugin_q3
+@dirrmtry %%PHPUA%%/images/templates/default
+@dirrmtry %%PHPUA%%/images/templates
@dirrm %%PHPUA%%/images/plugin_q3/maps
@dirrm %%PHPUA%%/images/plugin_q3
-@dirrmtry %%PHPUA%%/images/templates/wap/
+@dirrmtry %%PHPUA%%/images