aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-15 21:50:19 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-15 21:50:19 +0000
commit3d10ba819bb7c7a61693e0f4561435259c4862b5 (patch)
tree57768f4316c9361a344ee677472354d7cd0e0030 /games
parent6c8d5e017de621040d1e8d1160fa6aa4e26521e2 (diff)
downloadports-3d10ba819bb7c7a61693e0f4561435259c4862b5.tar.gz
ports-3d10ba819bb7c7a61693e0f4561435259c4862b5.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/torcs/Makefile4
-rw-r--r--games/torcs/files/patch-src::drivers::K1999::K1999.cpp28
2 files changed, 28 insertions, 4 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index c752694617c4..9f209aa3e6d7 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -73,10 +73,6 @@ PLIST_SUB+= K1999="@comment "
BASH2FIX= src/modules/telemetry/telemetry.sh src/tools/launcher/torcs.in \
Make-default.mk robotgen \
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " You might define these options:"
diff --git a/games/torcs/files/patch-src::drivers::K1999::K1999.cpp b/games/torcs/files/patch-src::drivers::K1999::K1999.cpp
new file mode 100644
index 000000000000..5adfe77559b9
--- /dev/null
+++ b/games/torcs/files/patch-src::drivers::K1999::K1999.cpp
@@ -0,0 +1,28 @@
+--- src/drivers/K1999/K1999.cpp.orig Sat Apr 19 11:48:14 2003
++++ src/drivers/K1999/K1999.cpp Sun Feb 15 21:32:27 2004
+@@ -14,8 +14,15 @@
+ ////////////////////////////////////////////////////////////////////////////
+ #include <iostream.h>
+ #ifndef WIN32
++
++#if defined(__GNUC__) && __GNUC__ > 2
++#include <strstream>
++#else
+ #include <strstream.h>
+-#endif
++#endif // __GNUC__
++
++#endif // WIN32
++
+ #include <iomanip.h>
+ #include <math.h>
+ #include <stdlib.h>
+@@ -515,7 +522,7 @@
+ OUTPUT("initTrack(" << index << ")");
+ char szSettings[100];
+ #ifndef WIN32
+- ostrstream os(szSettings, sizeof(szSettings));
++ std::ostrstream os(szSettings, sizeof(szSettings));
+ os << "drivers/K1999/" << index << "/settings.xml" << ends;
+ #else
+ sprintf(szSettings, "drivers/K1999/%d/settings.xml", index);