aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
commit41d8c3385c21ae51629c8997035eae8a9423ff6c (patch)
tree246d960cb714ce0095c452017819f6b1c64a7dfb /games
parent5e3b0872db18497aacc353b3ef94ad8dac11183f (diff)
downloadports-41d8c3385c21ae51629c8997035eae8a9423ff6c.tar.gz
ports-41d8c3385c21ae51629c8997035eae8a9423ff6c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile2
-rw-r--r--games/crack-attack/Makefile6
-rw-r--r--games/djgame2/Makefile8
-rw-r--r--games/ember/Makefile8
-rw-r--r--games/exmars/Makefile2
-rw-r--r--games/frozenbubble/Makefile8
-rw-r--r--games/kbilliards/Makefile4
-rw-r--r--games/latrine/Makefile4
-rw-r--r--games/lincity-ng/Makefile10
-rw-r--r--games/lincity-ng/files/extra-src-gui-Gradient.cpp12
-rw-r--r--games/lincity-ng/files/extra-src-gui-PainterSDL-PainterSDL.cpp13
-rw-r--r--games/monster-masher/Makefile9
-rw-r--r--games/monster-masher/files/extra-patch-src-vector.hpp30
-rw-r--r--games/torcs/Makefile10
-rw-r--r--games/tuxtype/Makefile8
15 files changed, 12 insertions, 122 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 356887dd8bee..0bd2c10905e7 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -34,7 +34,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+.if ${ARCH} == "alpha"
BROKEN= Configure fails
.endif
diff --git a/games/crack-attack/Makefile b/games/crack-attack/Makefile
index 98586d9b0fd3..b79db21a9118 100644
--- a/games/crack-attack/Makefile
+++ b/games/crack-attack/Makefile
@@ -21,11 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" CXXFLAGS="${CFLAGS}"
MAN6= crack-attack.6
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OSVERSION} >= 502126
@${REINPLACE_CMD} -e 's|#ifndef max|#if 0|' ${WRKSRC}/src/Game.h
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/djgame2/Makefile b/games/djgame2/Makefile
index 611d28db55b8..ea60cd999204 100644
--- a/games/djgame2/Makefile
+++ b/games/djgame2/Makefile
@@ -29,12 +29,6 @@ DATADIR= ${PREFIX}/share/djgame2
SUB_FILES= djgame2.desktop startdjg
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
-BROKEN= libLandLord does not compile
-.endif
-
post-patch:
${RM} -f ${WRKSRC}/Hall/HallRes/platform/x11/install
@${REINPLACE_CMD} -e 's|linux/soundcard.h|sys/soundcard.h|g' \
@@ -60,4 +54,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/djgame2.desktop ${PREFIX}/share/applications
${INSTALL_SCRIPT} ${WRKDIR}/startdjg ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 9ee31c9656f6..a3459023c084 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -39,12 +39,6 @@ USE_GNOME= gnomehack
USE_BZIP2= YES
CPPFLAGS= -DBR_NO_MACROS
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= does not compile because of inlining error
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '\
s|sdl-config|${SDL_CONFIG}|g; \
@@ -79,4 +73,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/exmars/Makefile b/games/exmars/Makefile
index ac9b8285803b..b5ef2371b786 100644
--- a/games/exmars/Makefile
+++ b/games/exmars/Makefile
@@ -54,7 +54,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|\($${OPT}\)|${CFLAGS} \1|' ${WRKSRC}/${MAKEFILE}
# Enable/disable compilation optimizations.
-.if defined(WITHOUT_OPTIMIZED_CFLAGS) || ${OSVERSION} < 500035
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|$${OPT}||' ${WRKSRC}/${MAKEFILE}
.endif
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index b2f5a13c5103..0cf8410cab6f 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -32,12 +32,6 @@ MAN6= frozen-bubble-editor.6 frozen-bubble.6
LEXECDIR= ${PREFIX}/libexec/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600020
-IGNORE= doesn't work unless MSG_NOSIGNAL is defined (FreeBSD version 600020 and higher)
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|\${SDL_CONFIG}|g' \
${WRKSRC}/c_stuff/Makefile.PL
@@ -66,4 +60,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/kbilliards/Makefile b/games/kbilliards/Makefile
index 65112670c21c..01f0c34bbec9 100644
--- a/games/kbilliards/Makefile
+++ b/games/kbilliards/Makefile
@@ -28,10 +28,6 @@ CFLAGS+= -Dsqrtl=sqrt
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502114
-CFLAGS+= -Dround=rint
-.endif
-
.if ${OSVERSION} >= 800024
BROKEN= does not compile
.endif
diff --git a/games/latrine/Makefile b/games/latrine/Makefile
index 3360f1043c27..6dc2bf42998b 100644
--- a/games/latrine/Makefile
+++ b/games/latrine/Makefile
@@ -23,10 +23,6 @@ MAN1= latrine.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503000
-IGNORE= needs libcursesw which doesnt work on this OSVERSION
-.endif
-
.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
.endif
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index 302ef777d220..8e33d71eb4d1 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -29,18 +29,10 @@ CONFIGURE_ARGS= --with-libphysfs=${PREFIX} \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 504000
-pre-configure::
- @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-src-gui-Gradient.cpp
- @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-src-gui-PainterSDL-PainterSDL.cpp
-.endif
-
do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} jam)
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} jam ${INSTALL_TARGET})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/lincity-ng/files/extra-src-gui-Gradient.cpp b/games/lincity-ng/files/extra-src-gui-Gradient.cpp
deleted file mode 100644
index 2996f8917001..000000000000
--- a/games/lincity-ng/files/extra-src-gui-Gradient.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/gui/Gradient.cpp.orig Fri Jul 15 19:47:11 2005
-+++ src/gui/Gradient.cpp Sat Jul 23 12:40:46 2005
-@@ -28,9 +28,7 @@
- #include "Painter.hpp"
- #include "ComponentFactory.hpp"
-
--#ifdef _MSC_VER
- #define lrintf(x) (long int)x
--#endif
-
- Gradient::Gradient()
- : direction(LEFT_RIGHT)
diff --git a/games/lincity-ng/files/extra-src-gui-PainterSDL-PainterSDL.cpp b/games/lincity-ng/files/extra-src-gui-PainterSDL-PainterSDL.cpp
deleted file mode 100644
index 476925c8c3ac..000000000000
--- a/games/lincity-ng/files/extra-src-gui-PainterSDL-PainterSDL.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/gui/PainterSDL/PainterSDL.cpp.orig Fri Jul 15 19:47:12 2005
-+++ src/gui/PainterSDL/PainterSDL.cpp Sat Jul 23 12:41:09 2005
-@@ -30,10 +30,8 @@
-
- #include "TextureSDL.hpp"
-
--#ifdef _MSC_VER
- #define lrint(x) (long int)x
- #define lroundf(x) (long int)(x + .5)
--#endif
-
- PainterSDL::PainterSDL(SDL_Surface* _target)
- : target(_target)
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 2348d2981f9e..633988664911 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -27,11 +27,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= monster-masher.schemas
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500010
-IGNORE= Freezes when starting a new game
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-vector.hpp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/monster-masher/files/extra-patch-src-vector.hpp b/games/monster-masher/files/extra-patch-src-vector.hpp
deleted file mode 100644
index 1ba2faf2887e..000000000000
--- a/games/monster-masher/files/extra-patch-src-vector.hpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/vector.hpp.orig Fri Aug 15 19:07:16 2003
-+++ src/vector.hpp Wed Nov 5 20:34:27 2003
-@@ -107,25 +107,17 @@
- }
-
- template <typename T>
--inline bool operator !=(Vector<T> lhs, Vector<T> rhs)
--{
-- return !(lhs == rhs);
--}
--
--template <typename T>
- inline bool operator ==(Vector<T> lhs, Vector<T> rhs)
- {
- return lhs.x == rhs.x && lhs.y == rhs.y;
- }
-
--template <>
--inline bool operator ==<double>(Vector<double> lhs, Vector<double> rhs)
-+inline bool operator ==(Vector<double> lhs, Vector<double> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }
-
--template <>
--inline bool operator ==<float>(Vector<float> lhs, Vector<float> rhs)
-+inline bool operator ==(Vector<float> lhs, Vector<float> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index b8a0db575d12..2b6c86fe9573 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -26,6 +26,9 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
+ LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
+
ALL_TARGET= default
INSTALL_TARGET= install datainstall
@@ -47,13 +50,6 @@ BASH2FIX= src/linux/torcs.in src/tools/accc/accc.in \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500041
-CPPFLAGS+= -I${LOCALBASE}/include
-.else
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
- LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
-.endif
-
.if defined(WITH_FREEGLUT)
LIB_DEPENDS+= glut.11:${PORTSDIR}/graphics/freeglut
.else
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index a0267f64ba35..dd07315517fa 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -27,10 +27,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(prefix)/doc/$$(PACKAGE)|$$(docdir)|' \
${WRKSRC}/Makefile.in ${WRKSRC}/tuxtype/docs/en/Makefile.in
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= does not build due to undefined reference to 'playsound' in 5.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>